Renato Target

Membros
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutro

About Renato Target

  1. Galera, estou com um problema. Programei um sistema em php no meu localhost, mas como não tinha acesso a internet na época que comecei a programar, criei o banco em "latin1_swedish_ci". Agora que tenho acesso a internet e uma hospedagem online, importei o banco para hospedar o sistema. Quando terminei de importar o sistema, os caracteres especiais são exibidos assim "Nova produção organizada". O head da página tanto no localhost quanto online está assim: <meta charset='utf-8' lang='pt-br'> Já tentei usar isso no arquivo de conexao: mysqli_set_charset($conexaoR,"utf8"); e mysqli_set_charset($conexaoR,"latin1_swedish_ci"); Achei vários tópicos na internet para converter, mas nenhuma solução funciona comigo. Sou leigo e ão entendo como pode a mesma configuração funcionar no localhost e não funcionar online. Alguém conhece alguma solução para isso?
  2. Sim e obrigado por responder, eu tenho acesso ao painel WHM e realmente é por la que se escolhe a versão, mas de uma forma não tão clara. Vou postar a solução que encontrei para quem quer definir uma versão exata do Php pelo WHM via EasyApache 3 ou 4. Solução: - Acesse o painel WHM da VPS, vá em "Home » Software » EasyApache 4 (ou 3)"; - Serão exibidos vários perfis, como "All PHP Options + OpCache" , "All PHP Options + ZendGuard" e outos, escolha uma e clique em "Customize" e vá em "Php Versions" no menu esquerdo. - Em cada perfil a "sub-versão" do Php é diferente, observe se a que você escolheu é a que você precisa, se for, use, se não escolha outra. - Quando achar a versão que deseja, clique em "Review" no menu esquerdo, e em seguida em "Provision" na parte inferior esquerda. Fonte: Observação própria. Outro tutorial que pode ser útil: https://outhereinthefield.wordpress.com/2016/05/15/changing-apache-and-php-versions-on-whm/
  3. Saudações. Estou usando uma vps pela primeira vez, estou tentando instalar o Magento 2.1.9 nele mas preciso de uma versão específica do php nele 7.0.2, 7.0.4, 7.0.6-7.0.x, 5.6.5-5.6.x. Tentei fazer isso pelo EasyApache 4 mas só consigo definir versões com "5.6, 7.0 ou 7.1" mas não consigo definir a versão exata, como por exemplo "7.0.2". Já tentei fazer isso pelo .htaccess e pelo php.ini, mas não achei nada na internet que me permita definir com exatidão a versão do php. Algum mito com soluções