Joelson Silva

Membros
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutro

About Joelson Silva

  1. Leonardo meu querido a sequencia ainda esta furada, mais a matriz abaixo ela atinge o objetivo, tem todas as sequencias de 3. 1 2 3 4 6 1 2 3 5 8 1 2 4 7 8 1 3 6 7 8 1 4 5 6 7 2 3 4 5 7 2 5 6 7 8 3 4 5 6 8 Talvez para se atinge a matriz acima seja o esquema abaixo, como ela foi feita deslocando as combinações, assim cada dezena tem as mesma quantidade a 1 repete 5 vezes e assim por diante, de mais essa analisada me diga qual o melhor caminho. 1 2 3 4 5 2 3 4 5 6 3 4 5 6 7 4 5 6 7 8 5 6 7 8 1 6 7 8 1 2 7 8 1 2 3 8 1 2 3 4 obrigado. um abraço.
  2. Muito obrigado Leonardo foi de grande ajuda. mais a sequencia está furada, veja que se eu escolher 8 números para formar conjuntos 5 em 5, o total da 56 volantes, aplicando a redução para se ter 3 acerto, o código apresentar o seguinte resultado: 1 2 3 4 5 1 2 3 6 7 1 2 4 6 8 1 2 5 7 8 1 3 4 7 8 1 3 5 6 8 1 4 5 6 7 as seguintes sequencias no reduzido só tem 2 acerto:> 2 3 8; 247;256;346;357;367;378;458;678 Bem a sua logica não esta errada, porque você está olhando para o sorteio que são 5 dezenas, conferindo com as 5, assim vai esta contigo o conjunto de 3, mais como o objetivo e ter apenas os 3 o algoritmo precisa de uma modificação.
  3. Olá pessoal Estou precisando de uma ajuda no código abaixo, estou fazendo exercício sobre a loteria, o que é para fazer, Dentro de um universo de numero no nosso caso eu escolhi 8 dezenas combinadas de 5 em 5, eu tenho que encontrar todas as sequencias de 3 ou seja 3 acerto iguais. exemplo, 123,124,125,126,127 até ultima 678. mais tem algum erro no código porque tem volantes se repetindo números a mais, veja no volantes 1 e volantes 3, ele repete 4 números iguais, o mesmo acontece para outro caso volantes 2=: 1 2 3 6 7 e volantes 5=: 1 2 5 6 7. segue o código abaixo para uma correção. Agradeço quem pode dar uma luz. obrigado. volantes 1=: 1 2 3 4 5 volantes 2=: 1 2 3 6 7 volantes 3=: 1 2 4 5 6 volantes 4=: 1 2 4 7 8 volantes 5=: 1 2 5 6 7 volantes 6=: 1 3 4 5 6 volantes 7=: 1 3 4 7 8 volantes 8=: 1 3 5 6 7 volantes 9=: 1 4 5 6 8 volantes 10=: 2 3 4 5 6 volantes 11=: 2 3 4 7 8 volantes 12=: 2 3 5 6 7 volantes 13=: 2 4 5 6 8 volantes 14=: 3 4 5 6 7 reduzidos: 14 total gerados: 56 algoritmo "loteria" var vetA: vetor[1..5]de inteiro vetB: vetor[1..5]de inteiro num,i,j,iguais,d,x,a,cont,total:inteiro n1,n2,n3,n4,n5:inteiro inicio // Seção de Comandos escreva("informe numero:") leia(num) para n1 de 1 ate num faca vetA[1]:= n1 para n2 de n1+1 ate num faca vetA[2]:= n2 para n3 de n2+1 ate num faca vetA[3]:= n3 para n4 de n3+1 ate num faca vetA[4]:= n4 para n5 de n4+1 ate num faca vetA[5]:= n5 total:= total + 1 para i de 1 ate 5 faca para j de 1 ate 5 faca se(vetA = vetB[j])então iguais:=iguais + 1 fimse fimpara fimpara se(iguais = 3)ou(iguais = 0)então para x de 1 ate 5 faca vetB[x]:= vetA[x] fimpara a:=a + 1 escrevaL("volantes",a,"=:",vetA[1],vetA[2],vetA[3],vetA[4],vetA[5]) cont:=cont + 1 fimse //************************************ x:=0 iguais:=0 fimpara fimpara fimpara fimpara fimpara escreval("reduzidos:", cont) escreval("total gerados:", total) fimalgoritmo