Jump to content
Fórum Script Brasil

Tite

Membros
  • Posts

    39
  • Joined

  • Last visited

About Tite

Tite's Achievements

0

Reputation

  1. Veja o problema acessando o link: clique aqui Para visualizar o problema será necessário logar tb.. para isso utilize o seguinte login: login: suporte senha: web Após isso vá para o rodapé do site e verá um chat básico... é nele q está o problema.. dpois d um determinado numero d registros, a barra de rolagem não desce mais automaticamente.. Estou utilizando a seguinte funçao em java para esta barra: function toBottom(){ if(document.all){ window.scroll(0, document.body.clientHeight); }else{ window.scroll(0,2000) } } Juntamente com o.. <BODY onLoad="toBottom()"> Alguém sabe como resolver isso??? já tentei com ancora e funcionou a barra d rolagem.. mas o chat não se atualizava mais. Abraço.
  2. é pessoal.. ainda estou na luta pra fazer isso!! Ninguém sabe ai não??? se for preciso eu pago!! Abraços.
  3. Vou dar uma pesquisada então.. mas acho dificil, pois não entendo nada de ajax!! Vou ver se dou conta.. qualquer coisa posto aki d novo. valeu. grato.
  4. Pessoal.. é possível executar uma ação de update SOMENTE AO FECHAR UMA DIV?? TIPO.. tenho o link: <a href="#" onClick="document.getElementById('aviso1').style.display = 'none'; document.getElementById('aviso_fechou').style.display = 'block'"><font color="#FFFFFF">X</font></a> acima, eu fechei a div aviso1.. e abri a div "aviso_fechou"... veja o que quero fazer nessa div somente quando for fechada a div aviso1: <div id="aviso_fechou" style="display:none"> <% alterar_aviso = "UPDATE AVISOS SET fechou='Sim' WHERE cod_aviso="& AVISOS("cod_aviso") &"" Set RS_alterar_aviso = Server.CreateObject("ADODB.Recordset") SET RS_alterar_aviso = Conex.Execute(alterar_aviso) %> </div> testei.. e não deu certo!!!! o update é feito de qualquer forma.. Agora é estranho, porq se eu colocar um response.write nesta div "aviso_fechou"... o response só é mostrado quando eu clico no link X, ou seja, fechando a div "aviso1". Entenderam aí?? E agora, o q faço?? Grato.
  5. Pessoal.. é possível executar uma ação de update SOMENTE AO FECHAR UMA DIV?? TIPO.. tenho o link: <a href="#" onClick="document.getElementById('aviso1').style.display = 'none'; document.getElementById('aviso_fechou').style.display = 'block'"><font color="#FFFFFF">X</font></a> acima, eu fechei a div aviso1.. e abri a div "aviso_fechou"... veja o que quero fazer nessa div somente quando for fechada a div aviso1: <div id="aviso_fechou" style="display:none"> <% alterar_aviso = "UPDATE AVISOS SET fechou='Sim' WHERE cod_aviso="& AVISOS("cod_aviso") &"" Set RS_alterar_aviso = Server.CreateObject("ADODB.Recordset") SET RS_alterar_aviso = Conex.Execute(alterar_aviso) %> </div> testei.. e não deu certo!!!! o update é feito de qualquer forma.. Agora é estranho, porq se eu colocar um response.write nesta div "aviso_fechou"... o response só é mostrado quando eu clico no link X, ou seja, fechando a div "aviso1". Entenderam aí?? E agora, o q faço?? Grato.
  6. Pessoal.. é possível executar uma ação de update SOMENTE AO FECHAR UMA DIV?? TIPO.. tenho o link: <a href="#" onClick="document.getElementById('aviso1').style.display = 'none'; document.getElementById('aviso_fechou').style.display = 'block'"><font color="#FFFFFF">X</font></a> acima, eu fechei a div aviso1.. e abri a div "aviso_fechou"... veja o que quero fazer nessa div somente quando for fechada a div aviso1: <div id="aviso_fechou" style="display:none"> <% alterar_aviso = "UPDATE AVISOS SET fechou='Sim' WHERE cod_aviso="& AVISOS("cod_aviso") &"" Set RS_alterar_aviso = Server.CreateObject("ADODB.Recordset") SET RS_alterar_aviso = Conex.Execute(alterar_aviso) %> </div> testei.. e não deu certo!!!! o update é feito de qualquer forma.. Agora é estranho, porq se eu colocar um response.write nesta div "aviso_fechou"... o response só é mostrado quando eu clico no link X, ou seja, fechando a div "aviso1". Entenderam aí?? E agora, o q faço?? Grato.
  7. Coloquei o (*) e não influiu em nada!! o erro acho q está nisso -----[ hora < #" & (hora_user) & "# ]---------- uma vez vi em algum canto algo +ou- assim ---[ hora < format(hora_user, d/m/aaaa) ]------- Não me lembro direito como era... já viu isso???
  8. Pessoal.. mas um probleminha. Mudei meu host hoje, e a área do site de "usuários online" parou de funcionar. Ou melhor está funcionando, o problema está na hora de deletar os usuários inativos.. o sistema deleta todos... sendo q teria q deletar apenas os registros que tenha 10minutos de inatividade. O problema está nesta linha: deletar="DELETE FROM online WHERE hora < #" & (hora_user) & "#" Conexao.Execute(deletar) Onde "hora_user" é a hora atual menos 10 minutos. (hora_user = DateAdd("n", -10, now)) Ao invés do sistema deletar só os registros cm 10 minutos d inatividade, ele está deletando todos. obs. o campo hora do access é do tipo "data/hora" Alguém sugere uma solução?? Grato.
  9. Access brabo mesmo..rs! Postei outra dúvida no forum.. veja se consegue uma solução! Abraço e obrigado.
  10. jow, Consegui resolver mudando o tipo de conexão cm o BD. Não sei porq deu certo.. mas o importante é q resolveu..rs! Muito obrigado pela atenção. Com a ajuda d vocês, consegui terminar meu trabalho e espero que gostem: www.copawe.com.br
  11. Reinstalei o IIS.. e o tipo de erro mudou.. agora aparece isso: Tipo de erro: ADODB.Recordset (0x800A0E7D) A conexão não pode ser usada para realizar esta operação. Ela está fechada ou é inválida neste contexto. lembrando q o código está correto.. aliás, o site está funcionando online.. só não funciona cm o iis.
  12. Ué.. mas é assim mesmo q acesso!! tem outra forma? Até agora, nada!! continua o erro super estranho!
  13. Endereço completo?? como assim?
  14. jow, como disse, o código asp, tanto quanto o caminho do BD estão corretissimos. Estava funcionando perfeitamente no IE anterior q eu tinha.. só veio dar esse problema quando instalei o novo IE7. Tá muito estranho mesmo.
  15. Pessoal.. fui instalar o internet explorer 7 e quando fui rodar minhas páginas ASP.. está dando erro quando há conexão cm o banco de dados access. Se a página não tiver conexão cm o BD, roda perfeitamente.. mas se tiver dá erro, e descrimina como "erro não especificado". E agora??? já fucei em tudo!! Procurei problemas parecidos.. e nada!! Alguém pode me ajudar aí??
×
×
  • Create New...