Jump to content
Fórum Script Brasil

shadow007

Membros
  • Content Count

    41
  • Joined

  • Last visited

Community Reputation

0 Neutro

1 Follower

About shadow007

Perfil

  • Gender
    Male
  • Location
    goias
  1. os excecios saum o seguinte : 1) Supondo que todos os ingredientes e utensílios para se fazer uma Pipoca estejam ao lado do fogão, construa um algoritmo que realize esta operação. Algoritmo: PIPOCA Pegue a pipoca Pegue a panela Pegue a tampa da panela Pegue o fósforo Pegue o óleo Pegue o sal Acenda o fósforo Com o fósforo aceso acenda a chama do fogão Coloque a panela no fogo Coloque o óleo Espere 1 minuto para o óleo esquentar Se o óleo estiver quente coloque a pipoca na panela Tampe a panela Espere 10 minutos Quando a pipoca estiver estourada tire a panela do fogo Senão espere ela estourar mais Apague o fogo Coloque a pipoca em uma tigela e coloque um pouco de sal 2) Sabendo que as variáveis X1, X2 e X3 do tipo inteiro contenham os seguintes valores 3, 7 e 8 e que a variável NOME do tipo caracter contenha ‘JOSEFINA’ e que a variável VERDADE do tipo lógica contenha o valor FALSO, analise e obtenha os resultados das seguintes expressões lógicas: Coloque todo o seu raciocínio, não apenas a resposta. a) NOME = ‘PAULA’ e VERDADE ou X2 * 1 > X3; ‘JOSEFINA’ = ‘PAULA’ e falso ou 7 * 3 > 8 Falso e falso ou 21 > 8 Falso e falso ou verdadeiro falso ou verdadeiro verdadeiro B) X1 + X2 >= X3 e NOME = ‘JOSEFINA’; 3 + 7 >= 8 e ‘JOSEFINA’ = ‘JOSEFIAN’ 10 >= 8 e verdadeiro Verdadeiro e verdadeiro Verdadeiro c) VERDADE ou X1 > X2; Falso ou 3 > 7 Falso ou falso Falso d) X1 + X2 > X2 e NOME = ‘JOSEFINA’ e (X1 * 2 > X2); 3 + 7 > 7 e ‘JOSEFINA’ = ‘JOSEFINA’ e (3 * 2 >7) 10 > 7 e verdadeiro e 6 > 7 Verdadeiro e verdadeiro e falso Verdadeiro e falso falso 3) Suponha que as variáveis inteiras X1, X2, X3, X4 e X5 contenham os seguintes valores respectivamente: 159, 27, 9, falso e verdadeiro. Analise e obtenha os resultados das expressões que seguem: Coloque todo o seu raciocínio, não apenas a resposta. a) X1 + X2 < X3 e X5 ou X4 ou X5; 159 + 27 < 9 e verdadeiro ou falso ou verdadeiro 186 < 9 e verdadeiro ou verdadeiro Falso e verdadeiro ou verdadeiro Falso ou verdadeiro Verdadeiro B) Não (X4 e X5); Não ( falso e verdadeiro) Não falso Verdadeiro c) (X4 ou X5) e (X1 > X2); (falso ou verdadeiro) e (159 > 27) Verdadeiro e verdadeiro verdadeiro d) (X1 > X3) e (X2 < X1); (159 > 9) e (27 < 159) Verdadeiro e verdadeiro Verdadeiro e) X2 + X3 > X1 e X4 ou X5 e não X5; 27 + 9 > 159 e verdadeiro ou falso e não verdadeiro 36 > 159 e verdadeiro e falso Falso e falso Falso f) Não X4 e não X5 e X2/X3 = 3; Não falso e não verdadeiro e 27/9 = 3 Verdadeiro e falso e verdadeiro Falso e verdadeiro falso 4) Resolva as seguintes expressões aritméticas a seguir: Coloque todo o seu raciocínio, não apenas a resposta. a) 5 * 7 mod 3 + 2; 5 * 1 + 2 5 + 2 7 B) 5 * (7 mod (3 + 2)); 5 * (7 mod 5) 5 * 2 10 c) 2 + pot(3,4) / sqrt(10); 2 + 81 / 3,16 2 + 25,6 27,6 d) ((2 + pot(4,3)) / sqrt(10)); (2 + 64 / 3,16) 2 + 20,2 22,2 5) Usando a estrutura de seleção encadeada (se... então... senão) elabore um algoritmo para ler o código do produto e informar a origem desse produto: a) O número do código do produto estiver entre 01 e 20 – Europa; B) O número do código do produto estiver entre 21 e 40 – Ásia; c) O número do código do produto estiver entre 41 e 60 – América; d) O número do código do produto estiver entre 61 e 80 - África; d) Se o código produto for maior que 80 - Paraguai; algoritmo "código_pRoduto" // Função : ler codigo produto e informa a origem do produto // Autor : Phelipe Kaick // Data : 15/2/2008 // Seção de Declarações var codigo: inteiro inicio // Seção de Comandos escreva ("entre com o codigo: ") leia (codigo) se (codigo > 80) então escreva ("paraguai") senao se (codigo > 61) então escreva ("áfrica") senao se (codigo > 41) então escreva ("américa") senao se (codigo > 21) então escreva ("asia") senao se (codigo > 1) então escreva ("europa") fimse fimse fimse fimse fimse fimalgoritmo 6) Usando a estrutura de seleção de múltipla escolha (escolha/caso) elabore um algoritmo que leia o número do dia da semana (1 a 7) sendo que Domingo corresponde ao número 1. Caso o número digitado não corresponda a nenhum dia semana, mostre uma mensagem de erro correspondente. algoritmo "numero_semana" // Função : indicar o numero da semana correspondente ao seu numero // Autor : Phelipe Kaick // Data : 14/2/2008 // Seção de Declarações var num: caracter inicio // Seção de Comandos escreva ("entre com o numero: ") leia (num) escolha num caso "1" escreva ("domingo") caso "2" escreva ("segunda") caso "3" escreva ("terça") caso "4" escreva ("quarta") caso "5" escreva ("quinta") caso "6" escreva ("sexta") caso "7" escreva ("sabado") outrocaso escreva ("não corresponde") fimescolha 7) Usando a estrutura de repetição (enquanto...faça) elabore um algoritmo que leia o salário dos 50 funcionários da Empresa XPTO e aplique um aumento salarial a todos os funcionários, usando a seguinte regra: Pressupõem-se que nenhum salário seja menor que zero. A cada reajuste concedido, mostre o funcionário que recebeu reajuste, o salário antigo e novo salário. a) 35% de aumento para os funcionários com salário menor que 1.500,00 reais; B) 15% de aumento para os funcionários com salário entre 1.500,00 e 3.000,00 reais; c) 5% de aumento para os funcionários com salários acima de 3.0000,00 reais; algoritmo "remuneração" // Função : ler salário de 50 fincionarios e adicionar amento salarioal // Autor :phelipe kaick // Data : 26/2/2008 // Seção de Declarações var sal,ContSal_35,ContSal_15,ContSal_5,aux: real cont : inteiro inicio // Seção de Comandos cont <- 1 enquanto cont < 50 faca aux <- 0 escreva (" entre com o salario: ") leia (sal) se (sal < 1500) então ContSal_35 <- (35 * sal / 100) aux <- (sal + ContSal_35) escreva (ContSal_35, "+", sal, "=", aux, " ") senao se (sal <= 3000) e (>= 1500) então ContSal_15 <- (15 * sal / 100) aux <- (sal + ContSal_15) escreva (ContSal_15, "+", sal, "=", aux, " ") senao se (sal > 3000) então ContSal_5 <- (5 * sal / 100) aux <- (sal * ContSal_5) escreva (ContSal_5, "+", sal, "=", aux, " ") fimse fimse fimse cont <- cont + 1 fimenquanto fimalgoritmo 8) Usando a estrutura de repetição (repita...até) elabore um algoritmo que leia 100 números inteiros, maiores que zero e imprima os seguintes resultados: a)A soma de todos os números impares; B)O produto de todos os números pares; c)Quantos números múltiplos de 10 (inclusive), foram digitados; d)Quantos números múltiplos de 3 (inclusive), foram digitados; algoritmo “números_inteiros” // Função : Ler números inteiros e informa: soma de todos os números impares, soma de todos números pares, números múltiplos de dez, múltiplo de três. // Autor :Phelipe kaick // Data : 18/3/2008 // Seção de Declarações var num, cont, multiplo_10,multiplo_3, soma_impar,produto_par: inteiro incio \\ Seção de Comandos multiplo_10 <- 0 multiplo_3 <- 0 produto_par <- 1 soma_impar <- 0 repita escreva ("entre com o numero: ") leia (num) se (num mod 2 <> 0) então soma_impar <- soma_impar + num fimse se (num mod 2 = 0) então produto_par <- produto_par * num fimse se (num mod 10 = 0) então multiplo_10 <-multiplo_10 + 1 fimse se (num mod 3 = 0) então multiplo_3 <- multiplo_3 + 1 fimse cont <- cont + 1 ate cont = 5 se (produto_par = 1) então produto_par <- 0 fimse escreval ("soma dos numeros impares: ", soma_impar) escreval ("quantidade de produtos pares: ", produto_par) escreval ("numero multiplo de dez: ", multiplo_10) escreval ("numero multiplo de trez: ", multiplo_3) fimalgoritmo 9) Usando a estrutura de repetição (para...faça) elabore um algoritmo leia os dados pessoais de 20 pessoas, mais precisamente a idade e o sexo, e que calcule e imprima os seguintes resultados: a) Total de pessoas com menos de 18 anos; B) Total de mulheres com mais de 23 anos; c) Total de homens com 18 anos; d) Total de homens; e)Total de mulheres; algoritmo "dados_pessoais" // Função :Ler dados pessoais e informa a quantidade de pessoas // Autor : Phelipe Kaick // Data : 4/3/2008 // Seção de Declarações var cont, total_mul, mul_maior_23, hom_com_18, total_hom, total_pess_menor_18, idade:inteiro sexo:caracter inicio // Seção de Comandos total_mul <- 0 mul_maior_23 <- 0 hom_com_18 <- 0 total_hom <- 0 total_pess_menor_18 <- 0 para cont de 1 ate 20 faca escreva ("entre com o sexo: ") leia (sexo) escreva ("entre com a idade: ") leia (idade) se (sexo = "F") então total_mul <- total_mul + 1 se (idade > 23) então mul_maior_23 <- mul_maior_23 + 1 fimse fimse se (sexo = "M") então total_hom <- total_hom + 1 se (idade = 18) então hom_com_18 <- hom_com_18 + 1 fimse fimse se (idade < 18) então total_pess_menor_18 <- total_pess_menor_18 + 1 fimse fimpara escreva ("total de pessoas menor que 18: ",total_pess_menor_18," ") escreva ("total de mulheres maior que 23: ",mul_maior_23," ") escreva ("total de homens com 18: ",hom_com_18," ") escreva ("total de mulheres: ",total_mul," ") escreva ("total de homens: ",total_hom," ") fimalgoritmo 10) Usando a estrutura de dados homogênea unidimensional (Vetor) elabore um algoritmo que leia dois vetores contendo a nota 35 alunos. O Vetor1 contém a nota do 1° bimestre e o Vetor2 contem a nota do 2° bimestre. Em seguida armazene em um Vetor3 a média das notas dois vetores lidos. Calcule a média da turma, o total de alunos que tiraram notas acima da média. Ao final, imprima o vetor resultante, a media da turma, e total de aluno de obtiveram nota acima da média. algoritmo "media_aluno" // Função : ler media dos alunos e imprimir resultados obtidos // Autor : Phelipe Kaick // Data : 24/3/2008 // Seção de Declarações var Prim_bimestre:vetor [1..35] de inteiro seg_bimestre : vetor [1..35] de inteiro media: vetor [1..35] de real media_turma, soma: real cont,aluno_acima_media : inteiro inicio // Seção de Comandos cont<- 1 enquanto cont<= 35 faca escreva ("entre com a nota do primeiro bimestre: ") leia (Prim_bimestre [cont]) escreva ("entre com a nota do segundo bimestre: ") leia (seg_bimestre [cont]) media [cont] <- (Prim_bimestre [cont]+ seg_bimestre [cont])/2 soma <- soma + Prim_bimestre [cont]+ seg_bimestre [cont] se (media [cont] > 7 ) então aluno_acima_media <- aluno_acima_media + 1 fimse cont <- cont + 1 fimenquanto media_turma <- soma / 35 escreval ("O número de alunos aprovado foi de: ",aluno_acima_media) escreval ("A média obtida entre todos os alunos foi de: ",media_turma," alunos") fimalgoritmo fimalgoritmo bom galera so preciso da aprovação de vocês aew vlw pela ajuda i ate + conto com a ajuda de você fuiZz
  2. kara eu modifei eu acho q ficou bom olha aew... :) algoritmo "semnome" // Função : // Autor : // Data : 19/3/2008 // Seção de Declarações var Prim_bimestre:vetor [1..35] de inteiro seg_bimestre : vetor [1..35] de inteiro media: vetor [1..35] de real media_turma, soma: real cont,aluno_acima_media : inteiro inicio // Seção de Comandos cont<- 1 enquanto cont<= 35 faca escreva ("entre com a nota do primeiro bimestre: ") leia (Prim_bimestre [cont]) escreva ("entre com a nota do segundo bimestre: ") leia (seg_bimestre [cont]) media [cont] <- (Prim_bimestre [cont]+ seg_bimestre [cont])/2 soma:= soma + Prim_bimestre [cont]+ seg_bimestre [cont] media_turma <- soma / cont se (media [cont] > 7 ) então aluno_acima_media <- aluno_acima_media + 1 cont<- cont + 1 fimse media_turma <- media_turma / 35 escreval ("O número de alunos aprovado foi de: ",aluno_acima_media) escreval (" A média obtida entre todos os alunos foi de: ",media_turma," alunos") fimenquanto se não tiver bom podi falar!!!! falou entaum Te+
  3. vlw pela dica 'nego drama' ^_^ deu certo :D Te + :) abraço
  4. Kara o algoritmo deu pau di novo, ele agora ficou infinto e por ainda por sima não faz nenhum calculo!!! estou é grilado :angry: var num, cont, multiplo_10,multiplo_3, soma_impar,produto_par: inteiro incio \\ Seção de Comandos multiplo_10 <- 0 multiplo_3 <- 0 produto_par <- 1 soma_impar <- 0 repita escreva ("entre com o numero: ") leia (num) se (num mod 2 <> 0) então soma_impar <- soma_impar + 1 fimse se (num mod 2 = 0) então produto_par <- produto_par * num fimse se (nuim mod 10 = 0) então multiplo_10 <-multiplo_10 + 1 fimse se (num mod 3 = 1) então multiplo_3 <- multiplo_3 + 1 fimse ate cont = 5 se (produto_par = 1) então produto_par <- 0 fimse escreva ("soma dos numeros impares", soma_impar, " ") escreva ("quantidade de produtos pares", produto_par, " ") escreva ("numero multiplo de dez", multiplo_10, " ") escreva ("numero multiplo de trez", multiplo_3, " ") se vocês verem algum erro por favor me diga!! vlw abraço \)_\) (='.') ((")(").... Te +
  5. kara eu fiz desse geito, mais erros q eu não consigo consertar!!! :( var num,cont,multiplo_10,multiplo_3,soma_impar,produto_par:inteiro inicio // Seção de Comandos multiplo_10 <- 0 multiplo_3 <- 0 soma_impar <- 0 produto_par <- 1 repita escreva ("entre com o numero: ") leia (num) se (num mod 2 <> ou = 0) então soma_impar <- soma_impar + 1 fimse se (num mod 2 = 0) então produto_par <- produto_par * num fimse se (num mod 10 = 0) então multiplo_10 <- multiplo_10 + 1 fimse se (num mod 3 = 0) então multiplo_3 <- multiplo_3 + 1 fimse ate cont = 5 se (produto_par = 1) então produto_par <- 0 fimse da erro nessa linha se (num mod 2 <> ou = 0) então soma_impar <- soma_impar + 1 vlw Te +
  6. kara surgiu uma nova duvida sobra as variaveis var num,cont,multiplo_10,multiplo_3,soma_impar,produto_par:inteiro minha duvida e a seguinte... todas a variaveis desse algoritmo são do tipo inteiro?? o Paulo_elite faluo o seguinte ele esta certo?
  7. ow e porque esta errado nesta linha? se (num mod <> 0) então na diferença q esta e o erro ? como posso modificar isso?
  8. aki quando você falou pra atribuir a varaiavel "produto_par <- 1" e so ela ou e todas?
  9. manim eu modifiquei mais não sei se ta bom porque o aplicativo do Visualgv2 deu "pau"! modifiquei algoritmo "semnome" // Função : // Autor : // Data : 12/3/2008 // Seção de Declarações var num,multiplo_10,multiplo_3,cont: inteiro soma_impar,produto_par: real inicio // Seção de Comandos multiplo_10 <- 0 multiplo_3 <-0 soma_impar <- 0 produto_par <- 0 repita escreva ("entre com o numero: ") leia (num) se (num mod <> 0) então soma_impar <-soma_impar + num fimse se (num mod = 2) então produto_par <- produto_par * num fimse se ( num mod 10 = 0) então multiplo_10 <- multiplo_10 + 1 fimse se (num mod 3 = 0) então multiplo_3 <- multiplo_3 + 1 ate cont = 5 escreva ("soma dos numeros impares:",soma_impar," ") escreva ("quantidade de produtos pares:",produto_par," ") escreva ("numeros multiplos de dez:",multiplo_10," ") escreva ("numeros multiplos de trêz:",multiplo_3," ") fimalgoritmo kara fiz assim aki se (num mod = 2) então produto_par <- produto_par * num aki eu acho q eu fiz certo porque qualquer numero multiplicado por 2 o resultado sempre e um numero par mais se eu tiver pensado errado me corrige firmeza falou abraço...
  10. eu queria saber porque esse programa não calcula não faz nada eu o modifiquei de novo mais deu na mesma... algoritmo "semnome" // Função : // Autor : // Data : 11/3/2008 // Seção de Declarações var num,multiplo_10,multiplo_3,cont: inteiro soma_impar,produto_par:real inicio // Seção de Comandos escreva ("entre com o numero: ") leia (num) se (num div 2 <> 0) então soma_impar<- soma_impar + num se (num div 2 = 0) então produto_par<- produto_par * num se (num div 10 = 0) então multiplo_10<- multiplo_10 + 1 se (num div 3 = 0) então multiplo_3<- multiplo_3 + 1 cont <-cont + 1 ate (cont <= 5) escreva ("soma dos numeros impares:",soma_impar," ") escreva ("quantidade de produtos pares:",produto_par," ") escreva ("numeros multiplos de dez:",multiplo_10," ") escreva ("numeros multiplos de trêz:",multiplo_3," ") fimse fimse fimse fimse fimrepita veih já to bolado com esse programa ow já ta ficando xato isso
  11. kara eu não entendi muito sobre q vocês estavam falando não entendi sobre a saida dos dados ?como seria essa saida ? e sobre seu algoritmo "paulo_elite" eu não estudei sobre isso ainda algoritmo em inglês, mais vlw a ajuda...
  12. eu fiz como tú falaou mais ele não faz nenhum calculo so pede as notas e pronto... var Prim_bimestre:vetor [1..10] de inteiro seg_bimestre : vetor [1..10] de inteiro media: vetor [1..10] de real media_turma, soma: real cont: inteiro inicio // Seção de Comandos cont:= 1 enquanto cont<= 10 faca escreva ("entre com a nota do primeiro bimestre: ") leia (Prim_bimestre [cont]) escreva ("entre com a nota do segundo bimestre: ") leia (seg_bimestre [cont]) media [cont] := (Prim_bimestre [cont]+ seg_bimestre [cont])/2 soma:= soma + Prim_bimestre [cont]+ seg_bimestre [cont] media_turma := soma / cont cont:= cont + 1 fimenquanto ele fica desse geito, quando copilado: entre com a nota do primeiro bimestre: 50 entre com a nota do segundo bimestre: 30 entre com a nota do primeiro bimestre: 60 entre com a nota do segundo bimestre: 90 entre com a nota do primeiro bimestre: 70 entre com a nota do segundo bimestre: 75 entre com a nota do primeiro bimestre: 15 entre com a nota do segundo bimestre: 25 entre com a nota do primeiro bimestre: 34 entre com a nota do segundo bimestre: 78 entre com a nota do primeiro bimestre: 79 entre com a nota do segundo bimestre: 70 entre com a nota do primeiro bimestre: 60 entre com a nota do segundo bimestre: 95 entre com a nota do primeiro bimestre: 70 entre com a nota do segundo bimestre: 85 entre com a nota do primeiro bimestre: 05 entre com a nota do segundo bimestre: 15 entre com a nota do primeiro bimestre: 45 entre com a nota do segundo bimestre: 91 *** Fim da execução. *** Feche esta janela para retornar ao Visualg.
  13. kara eu não sei mais o q fazer!!:angry: e não sei ondi q ta errado ele não dar as respostas, não faz calculos var num,multiplo_10,multiplo_3,cont: inteiro soma_impar,produto_par:real inicio // Seção de Comandos repita escreva ("entre com o numero: ") leia (num) se (num mod 2 <> 0) então soma_impar<- soma_impar + num se (num mod 2 = 0) então produto_par<- produto_par * num se (num mod 10 = 0) então multiplo_10<- multiplo_10 + 1 se (num mod 3 = 0) então multiplo_3<- multiplo_3 + 1 cont <-cont + 1 ate (cont <= 5) fimrepita escreva ("soma dos numeros impares:",soma_impar," ") escreva ("quantidade de produtos pares:",produto_par," ") escreva ("numeros multiplos de dez:",multiplo_10," ") escreva ("numeros multiplos de trêz:",multiplo_3," ") fimse fimse fimse fimse fimrepita fimalgoritmo:angry:
  14. kara porque fica desse geito quando copilado entre com o numero: 25 soma dos numeros impares: 25quantidade de produtos pares: 0numeros multiplos de dez: 0numeros multiplos de trêz: 0 *** Fim da execução. *** Feche esta janela para retornar ao Visualg. porque fica tudo junto?? sei lá tem alguma coisa coisa nesse algoritmo porque eu não consigo terminar! ele não da mais dando erro, mais não obedece so comandos algoritmo "semnome" // Função : // Autor : // Data : 7/3/2008 // Seção de Declarações var num,multiplo_10,multiplo_3,cont: inteiro soma_impar,produto_par:real inicio // Seção de Comandos repita escreva ("entre com o numero: ") leia (num) se (num mod 2 <> 0) então soma_impar<- soma_impar + num fimse se (num mod 2 = 0) então produto_par<- produto_par * num fimse se (num mod 10 = 0) então multiplo_10<- multiplo_10 + 1 fimse se (num mod 3 = 0) então multiplo_3<- multiplo_3 + 1 fimse cont <-cont + 1 ate (cont <= 5) fimrepita escreva ("soma dos numeros impares:",soma_impar) escreva ("quantidade de produtos pares:",produto_par) escreva ("numeros multiplos de dez:",multiplo_10) escreva ("numeros multiplos de trêz:",multiplo_3) fimalgoritmo kara meu racocionio esta certo?/ si tiver porque ele não sege ps comandos como determinado? ow já tentei di tudo pra terminar esse programa i não sei mais o q fazer...
×
×
  • Create New...