Jump to content
Fórum Script Brasil

bastard2003

Membros
  • Content Count

    199
  • Joined

  • Last visited

Community Reputation

0 Neutro

About bastard2003

  1. VELHO... DEU CERTO... tinha declarado a global no lugar errado!! valeu a mão ai!!! abraços!
  2. dai velho beleza?? cara... a tua ideia foi otimo... realmente a variavel $serverConnection não tem valor quando chega na função query... porem o global não serviu... tentei declarar ela como você disse e também no começo do arquivo... mas mesmo assim... não tive sucesso... então... tentei colocando a conexão em uma session! só que não sei quais são os riscos de se fazer isso! saberia me dizer algum?! abraços! valeu a ajuda ai velho...
  3. salve galera beleza?? seguinte... to com um problema pra trabalhar com duas conexão no mysql... eu to desenvolvendo um sistema que ate onde eu sabia so iria trabalhar com uma conexão o problema é que agora esse sistema vai ter que fazer uma integração com outro sistema... essa integração vai ser executada 'N' vezes ao dia, o que eu pensei em fazer foi criar uma nova conexão e usar o segundo parametro do mysql_query que seria a conexão ne... porem não está funcionando... está dando o seguinte erro: supplied argument is not a valid MySQL-Link resource porem a variavel que eu informo no mysql_query é a mesma que eu inforno no mysql_select_db! alguma ideia de qual possa ser o problema?? atualmente utilizo dessa maneira aqui: conexão if(!($serverConnection = mysql_connect($host, $user, $password))) { echo "Não foi possível estabelecer uma conexão com o servidor <b>$host</b>."; exit; } banco if(!($dbConnection = mysql_select_db($dbName,$serverConnection))) { echo "Não foi possível estabelecer uma conexão com a base de dados <b>$dbName</b>."; exit; } função do framework function query($SQL,$flag = 'n'){ if($flag == 's'){ $exec = mysql_query($SQL, $serverConnection); if($exec){ gravaHistorico($SQL); }else{ SetLogError($SQL); } return $exec; }else{ return mysql_query($SQL, $serverConnection); } } alguma ideia doq possa ser galera??? abraços!
  4. bastard2003

    Lentidão Em Rede

    primeiro: quando ele execuata essa rotina? no onExit, onChange, etc?!?! no certo você poderia colocar num botão.. só por curiosidade.. se você puder colocar aqui pra nós vermos essa rotina... porque posso te garantir.. tenho uma num dos programas q eu fiz, q faz exatamente isso... e a base de clientes já passo de 100.000 coloca a rotina ai!
  5. Kikonanet: só uma observação... qual banco você ta usando!? isso importa bastante na hora de SQL com data...
  6. sim.... essa função vai no beforPost da qry/tabela... só não entendi qualquer você quis disser com "O problema neste caso é saber o número atribuído (porém pode ser tratado)." poderia ser mais claro?! hehe abraços!
  7. desculpa se eu me expressei mau galera.. hehe seria o seguinte... digamos que tu tenha na tua tabela clientes 200 registros, quando tu for dar um novo tu vai pegar o 200+1 = 201 -> valor pro novo registro.. fica mais claro agora!? abraços!
  8. bom vamos la.. você não precisa cliar 2 proetos, basta um so... mas todos esses tem q estar ligados ao mesmo banco... você vai ter que tomar cuidado principalmente com as telas de cadastro, pra não acontecer de dois (ou mais) usuarios tentarem cadastrar alguém e este ficarem com o mesmo codigo de PK, pra isso você poderia fazer uma função que busca na base e aloca o registro atual +1, assim você teria não vai ter problemas com registros... qualquer coisa.. posta ai!
  9. coloca o banco num servidor e coloca a maquinas clientes apontando pro servidor... todos vão trabalhar no mesmo banco!
  10. pega o .caption dele...
  11. é q tipo... é o jeito de você saber quais itens você tem q mostrar no grid.. coloca o filter no evento onExit do lookup (ou edit não sei qualquer tu ta usando pra mostrar o cliente)
  12. isso ai é o codigo do teu botão! :| tu coloca alguma coisa no onCreate, onShow.. essas coisas... como tu ta passando o filter pra tabela.. ou não ta passando:!?
  13. taca um F5 e vai rodando em F7.... ve a onde da o erro e cola a linha q ta dando o erro.. e as linhas de cima tb... umas 5 linhas acima so! faz ai e coloca aqui!
  14. tu deve ter um dataset ne?? verifica se ele ta AutoEdit, passa pra True se não tiver.. outra coisa que você pode fazer é testar se a tabela ta active se ela não tiver tu passar.... tabela.active := true; isso deve resolver!
×
×
  • Create New...