ri_nepo

Membros
  • Content Count

    119
  • Joined

  • Last visited

Community Reputation

0 Neutro

About ri_nepo

  1. Galera , eu fiz um dts que executa uma procedure , na hora de concatenar ele da o seguinte erro. Incorrect syntax near '+'. A parte final do código está assim que executa a procedure está abaixo , **************************************** INSERT INTO TB_REPORT_ACUMULO (ORDEM,NIVEIS,PESSOAS,TRANSACOES,DOTZ,TKT__MEDIO_USUARIO, TKT_MEDIO_TRANSACAO) EXEC REPORT_ACUMULO '43540',@ANO + '/' + @mês + '/' + @DIA_INICIO ,@ANO + '/' + @mês + '/' + @DIA_FINAL **************************************** Quem quiser ver o código completo pode olhar o código abaixo DECLARE @DIA_INICIO CHAR(10) DECLARE @DIA_FINAL CHAR(10) DECLARE @mês CHAR(10) DECLARE @ANO CHAR(10) SET @DIA_INICIO = '1' SET @mês = MONTH(getdate()) - 1 IF MONTH(GETDATE()) = '1' BEGIN SET @ANO = YEAR(getdate()) - 1 END ELSE BEGIN SET @ANO = YEAR(getdate()) END IF MONTH(GETDATE()) = '1' OR MONTH(GETDATE()) = '2' OR MONTH(GETDATE()) = '4' OR MONTH(GETDATE()) = '6' OR MONTH(GETDATE()) = '8' OR MONTH(GETDATE()) = '9' OR MONTH(GETDATE()) = '11' BEGIN SET @DIA_FINAL = '31' END ELSE IF MONTH(GETDATE()) = '3' BEGIN SET @DIA_FINAL = '28' END ELSE BEGIN SET @DIA_FINAL = '30' END INSERT INTO TB_REPORT_ACUMULO (ORDEM,NIVEIS,PESSOAS,TRANSACOES,DOTZ,TKT__MEDIO_USUARIO, TKT_MEDIO_TRANSACAO) EXEC REPORT_ACUMULO '43540',@ANO + '/' + @mês + '/' + @DIA_INICIO ,@ANO + '/' + @mês + '/' + @DIA_FINAL ***************************************************** quem puder ajudar eu agradeço valeu Ricardo
  2. ri_nepo

    Erro Conexão Odbc

    sim , foram eles que informaram que a configuração tinha sido efetuada Alguma sugestão ?
  3. ri_nepo

    Tratamento De Datas

    Amigo tenta fazer assim year(vardata) &"/"& month(vardata) &"/"& day(vardata)
  4. ri_nepo

    Erro Conexão Odbc

    Olá Galera, Meu provedor informou ter criado uma conexão dsn para conexão ao banco sql via site , mas quando tento acessar da o seguinte erro Microsoft OLE DB Provider for ODBC Drivers error '80040e4d' [Microsoft][ODBC SQL Server Driver][sql Server]Falha de logon do usuário ''. O usuário não está associado a uma conexão confiável com o SQL Server. /teste_conexao.asp, line 3 o código está assim Quem puder ajudar eu agradeço abraços Ricardo
  5. Boa tarde Galera, Criei uma procedure que faz um insert no banco de dados e quero que traga um retorno dizendo se foi cadastrado ou se o email já existe. Procedure O asp está assim A página da o seguinte erro Microsoft OLE DB Provider for SQL Server erro '80040e10' Procedure 'SP_INSERE_RESERVA1' expects parameter '@mensagem', which was not supplied. /nepo/insere_procedure1.asp, line 12 Quem puder ajudar eu agradeço Atenciosamente Ricardo
  6. Não rolou , na realidade seria assim a procedure envia uma variavel @MSN **************************************************************** CREATE PROCEDURE SP_INSERE_RESERVA ( @nome varchar(100), @email varchar(100), @MSN varchar(100) output ) as IF EXISTS(SELECT EMAIL FROM reserva where email = @email) BEGIN SET @MSG = 'ER Usuário já existe!!' RETURN END ELSE BEGIN INSERT INTO reserva (nome,email) VALUES (@nome,@email) SET @MSG = 'ER Cadastro efetuado com sucesso!!' END GO **************************************************************** Só que no asp não está pegando , eu queria alguma dica abraços Ricardo
  7. Valeu mano , era isso mesmo , falha minha , valeu Como eu faço na procedure para passar o valor de resposta para página No lugar do print eu printo na propria página ex: IF EXISTS(SELECT EMAIL FROM reserva where email = @email) BEGIN Print 'Já existe um cadastro com este nome' RETURN END ELSE BEGIN INSERT INTO reserva (nome,email) VALUES (@nome,@email) Print 'Cadastro efetuado com sucesso' END
  8. Tentei utilizar isso também e não funcionou dados_chamadas="exec SP_INSERE_RESERVA @nome = '"& varNome &"',@email = '"& varEmail &"'" conexao.execute(dados_chamadas)
  9. Boa tarde Galera, Criei uma procedure e quando mando executar no asp ele não da erro mas também não executa O código está assim ************************************************** set conexao=server.createobject("adodb.connection")conexao.open "Provider=SQLOLEDB.1;SERVER=server;DATABASE=base;UID=usuario;PWD=senha;" varNome = Request.Form("frmNome") varEmail = Request.Form("frmEmail") Set cmdatualiza = Server.CreateObject("ADODB.Command") Set cmdatualiza.ActiveConnection = Conexao cmdatualiza.CommandText = "SP_INSERE_RESERVA" cmdatualiza.CommandType = 4 cmdatualiza.ParameteRs.Refresh cmdatualiza.ParameteRs("@nome") = varNome cmdatualiza.ParameteRs("@email") = varEmail cmdatualiza.Execute Set cmdatualiza=nothing ************************************************** A procedure está assim ***************************************************** CREATE PROCEDURE SP_INSERE_RESERVA ( @nome varchar(100), @email varchar(100) ) as IF EXISTS(SELECT EMAIL FROM reserva) BEGIN Print 'Já existe um cadastro com este nome' RETURN END ELSE BEGIN INSERT INTO reserva (nome,email) VALUES (@nome,@email) Print 'Cadastro efetuado com sucesso' END GO ******************************************************************* Quem puder ajudar eu agradeço abraços
  10. o erro no } eu já resolvi , o problema é que o meu outro select não é preenchido
  11. Valeu mano , resolveu agora ele só não carrega o meu outro select , se já fez algo em ajax parecido ? se tiver algum exemplo me envie por favor abraços Ricardo
  12. Bom dia galera, é o seguinte estou começando a mexer com ajax agora e estou tentando fazer com que um select preencha outro conforme o estado selecionado ex : eu tenho um select de estado , conforme seleciono o estado , ele me traz a cidade , na página ele traz o resultado , mas quando tento colocar dentro de um select dá erro. Segue o código abaixo : O erro que ele diz é sobre um } na linha 56 que é a linha onde está aqui alert ('Erro no retorno do servidor' + XMLHttp.statusText); Quem puder ajudar ou tiver algum exemplo pronto eu agradeço abraços Ricardo
  13. Bom dia galera, é o seguinte estou começando a mexer com ajax agora e estou tentando fazer com que um select preencha outro conforme o estado selecionado ex : eu tenho um select de estado , conforme seleciono o estado , ele me traz a cidade , na página ele traz o resultado , mas quando tento colocar dentro de um select dá erro. Segue o código abaixo : O erro que ele diz é sobre um } na linha 56 que é a linha onde está aqui alert ('Erro no retorno do servidor' + XMLHttp.statusText); Quem puder ajudar ou tiver algum exemplo pronto eu agradeço abraços Ricardo
  14. Olá , obrigado pela atenção infelizmente não funcionou , o problema está aqui Eu teria que achar uma forma dos registros ficarem juntos pois da forma que estar ele monta um grafico diferente para cada registro Se for manual funciona Quem puder ajudar eu agradeço valeu Ricardo
  15. Olá galera, Estou montando um script que gera um grafico simples , eu preciso que ele aparecesse assim na mesma tabela e um ao lado do outro , só que está aparecendo um embaixo do outro vejam no link abaixo http://www.hth.com.br/extranet/grafico.asp Veja o script Quem puder ajudar eu agradeço abraços Ricardo