Jump to content
Fórum Script Brasil

Elvio.Tchê

Membros
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutro

About Elvio.Tchê

  • Birthday 07/10/1974

Contatos

Perfil

  • Gender
    Male
  • Location
    São Leopoldo/RS
  1. Em Clipper, eu desenvolvi um projeto padrão e, a partir deste, eu iniciava qualquer projeto, fazendo alguns ajustes. Eu gostaria de sugestões, dicas, ideias, sobre o melhor caminho em Delphi para criar um projeto padrão, para iniciar os próximos, baseado no padrão, fazendo apenas ajustes de detalhes, como versão, nome da empresa, bancos de dados, tabelas e afins. ....
  2. Boa noite. É exatamente isso, depois que postei a dúvida, acabei olhando com mais calma e acabei chegando a esta solução mesmo. Só o lb_arqs.Items.Append que mantive o Add, pois toda vez que eu clicar em no botão "Converter", ele vai limpar a ListBox. Sds., Elvio.
  3. Minha ShellListView tem a listagem dos arquivos de uma determinada pasta, vou selecionar alguns arquivos, por exemplo, tem 5 arquivos, eu seleciono 3 deles... abc.doc asdf.rpt - Marcado/selecionado mko.dat qwerty.lst - Marcado/selecionado xyz.txt - Marcado/selecionado quando o for...next passar pela lista, deverá retornar somente os nomes que estão marcados/selecionados, no caso:> asdf.rpt qwerty.lst xyz.txt e estes itens vou adicionar a uma simples ListView. Porém, não consigo obter os nomes dos arquivos que estão marcados/selecionados e minha listview fica com o nro de itens corresponde
  4. Não estou conseguindo "puxar" o nome dos arquivos selecionados numa ShellListView (Delphi 7): for x:=0 to ( ShellListView1.Items.Count-1 ) do begin if ( ShellListView1.Items[x].Selected ) then // Testa se o arquivo da lista está selecionado lb_arqs.Items.Add(ShellListView1.Items[x].Caption); // Adiciona o arq. selecionado a um ListBox end; A ListBox fica com itens sem descrição, que seriam o nome dos arquivos. Grato.
  5. Gostaria de uma dica para verificar se o MySQL está presente no sistema e, posteriormente, o Banco de Dados (talvez suas tabelas também) e enviar uma "mensagemamigável" ao usuário. Só para evitar as mensagems de erro de sistema em inglês, tornando o programa um pouco mais profissional. Grato, Elvio.
  6. Bom, o problema, basicamente, estava na posição do código PHP com o html. <?php if (!empty($xCodTurma) && $xCodAluno>0 && $xCodDis>0) Cons_Notas(); ?> <td colspan="2"><div align="center"> <input type="button" name="button" id="button" value="Consultar Dados..." onclick="js_cons_notas();" /> </div> # .... a função Cons_Notas() function Cons_Notas() { global $xCodTurma; global $xCodAluno; global $xCodDis; global $nNota1;
  7. Minha experiência é pouca por estar fazendo a cadeira de PHP no curso técnico. Por isso, venho pedir ajuda da galera. Mas a situação é a seguinte: Tenho um form com três "lists" onde escolho as informações das listas e clico num botão "Consultar", este chama uma rotina de consulta a uma tabela de um banco de dados MySQL, se encootrar os dados selecionados, o sistema atribui os valores dos campos "nota1" e "nota2" as variáveis "$nNota1" e "$nNota2" (isto está fazendo, verifiquei através de "echo"), em seguida, teria que "jogar" estes valores para os TextField do form, chamados "txtNota1" e "txt
  8. Bom, depois de analisar os arquivos para download do PHP, observei que havia uma mensagem explicando sobre o VC9 e VC6. Assim, o "pacote" VC9 é para quem vai utilizar o PHP com IIS, compilado com Visual Studio 2008 (http://windows.php.net/downloads/releases/php-5.3.1-nts-Win32-VC9-x86.msi). A versão VC6 foi compiledo com o Visual Studio 6, não diz muita coisa, mas é esse que exibe a opção Apache 2.2 (http://windows.php.net/downloads/releases/php-5.3.1-Win32-VC6-x86.msi). Resolvido!
  9. Já tenho o MySQL instalado na máquina de casa (com alguns bancos de testes); instalei o Apache 2.2.14 e este está iniciado sem problemas, inclusive testado no browser os famosos "http://localhost" e "http://127.0.0.1", retornando a mensagem "It works!" do apache. O problema está na instalação do PHP 5.3.0, que não mostra, nas opções do setup, a opção "( ) Apache 2.2.x Module" (exibindo apenas as opções "( ) IIS Fast CGI", "( ) Other CGI" e "( ) Do not setup a web server"), assim, o módulo "php5apache2_2.dll" não é instalado (não estando este em "c:\arquivos de programas\php"), não sendo possí
  10. Alterei as seguintes linhas no "my.ini": Originais: basedir=c:/wamp/bin/mysql/mysql5.1.36 log-error=c:/wamp/logs/mysql.log datadir=c:/wamp/bin/mysql/mysql5.1.36/data alterações: basedir=C:/Arquivos de programas/MySQL/MySQL Server 5.1 datadir=c:/wamp/mysqldata (esta foi escolha pessoal mesmo) Voltei o serviço MySQL da minha instalação para automático novamente e está tudo funcionando. Valeu.
  11. Alguém saberia me informar como posso configurar o WAMP Server para ignorar o MySQL de seu pacote, assumindo o MySQL (última versão e com algumas tabelas) atualmente instalada e configurada na máquina ?
×
×
  • Create New...