Jump to content
Fórum Script Brasil

Robson Gaeski

Membros
  • Posts

    19
  • Joined

  • Last visited

About Robson Gaeski

Robson Gaeski's Achievements

0

Reputation

  1. Ola Senhores tenho o seguinte caso. Preciso colocar o #Map em um arquivo externo, Mas não sei como achar esse arquivo <img src="http://www.site1.com/ML/Template/Template/Tamanho.jpg" border="0" usemap="#Map2" /> <map name="Map2"> <area shape="rect" coords="1, 500, 305, 557" href="http://www.site2.com" target="_blank" /> </map> Gostaria de saber se tem uma maneira de pegar o link do Map2 de outro lugar que não o html que esta a imagem... como se em usemap="#Map2" Pegasse algo assim: usemap="http://www.site3.com/Map2.html" Grato pela ajuda
  2. Ola Senhores. Estou com um problema de desempenho em meu site. o site é www.euquero1.com.br Dentro da pagina principal tenho um IFrame que carrego as outras paginas ao ser clicado nos menus Mas quando abro demora muito pra carregar o Iframe. Carrega todo o resto do site e o Iframe fica ali "Pensando" Segue o codigo do meu Iframe No onload da pagina chamo uma função javascript para redimensionar o Iframe para o tamanho da pagina que vai abrir nele conforme o navegador segue a função alguém pode me ajudar? Obrigado
  3. Ola Senhores. Estava procurando um calculador de frete na internet e achei vários. Mas nenhum que funcione bem. Alguém tem e pode disponibilizar um calcular que seja possível o usuário alterar a quantidade de produtos e assim calcular por essa quantidade? Por Exemplo. Tenho um produto que pesa 1 kg, se o usuário por quantidade 2 teria que calcular o frete com peso de 2 kg. Obrigado a todos. Abraços
  4. Ola Senhores. Tenho uma pagina com um Iframe e gostaria de enviar o SRC uma imagem de uma pagina para outra. Pensei em enviar por URL Mas como é com Iframe a URL Sempre vai ser a mesma. Estava Fazendo Assim: Ao Clicar na Imagem Chamo Esse JavaScript function EnviarImagem(idImagem) { var separador = "?vpqtdq="; window.location = separador + document.getElementById(idImagem).src; } Que pego o SRC da imagemmais o separador e passo para o window.location E na pagina que quero abrir essa imagem Faço o seguinte Java Script function onPag2Load() { var separador = "?vpqtdq="; var dadosAux = String(window.location); var iDados = dadosAux.indexOf(separador, 0); var dados = decodeURI(dadosAux.substring(iDados + separador.length, dadosAux.length)); document.getElementById("ImagemProduto").src = dados; } Onde Passo o SRC para o componente imagem que tenho nessa Pagina, Que ira carregar a imagem aqui Fazendo paginas normais Funcina. Mas quando coloco no Site que essas paginas abem dentro do Iframe Não Funciona alguém sabe como fazer para funcionar? Ou outra maneira que eu possa fazer isso? Grato
  5. Ola senhores. Estou criando um site que usa um Iframe no meio Mas quando clica no Iframe do meio e depois clica no menu abre em uma nova aba quando clica so no menu funciona bem. Segue o código de meu Iframe <iframe id="Centro" name="Centro" onload="resizeIframe('Centro');" src="Centro/Inicio.html" scrolling="no" scroll="no" height="1" marginwidth="0" marginheight="0" frameborder="0" style="width: 100%;"></iframe> e o código do botão menu que chamo <li class="even"><a target="Centro" href="Centro/Bandas.html" onload="resizeIframe('Centro');"> Bandas</a></li> Para ver melhor o que esta acontecendo acessem o site www.euquero1.com.br Clique em uma imagem no centro e depois clique no menu novamente.(So esta pronto o Bandas e o Super Herois) alguém sabe o que esta acontecendo??
  6. Ola Assim so funionou no Chrome. No IEe o Firefox Não funcionou
  7. Ola Senhores. Uso o seguinte código para aumentar um Iframe dinamicamente conforme o conteúdo da pagina que vai abrir nele function resizeIframe(Centro) { var iframe = document.getElementsByName(Centro); if (navigator.appName.toString() == "Netscape") {//FF 3.0.11, Opera 9.63, and Chrome iframe[0].height = iframe[0].contentDocument.documentElement.scrollHeight; } else { iframe[0].height = iframe[0].contentWindow.document.body.scrollHeight; //IE6, IE7 //iframe[0].Document.body.style.overflowY = "hidden"; } } O problema é que no Firefox Não Funciona. Ele entra no If if (navigator.appName.toString() == "Netscape") {//FF 3.0.11, Opera 9.63, and Chrome iframe[0].height = iframe[0].contentDocument.documentElement.scrollHeight; } Mas não faz nada. Obs No Chrome e no IE Funciona Perfeitamente alguém sabe o porque não funciona?
  8. Ola senhores. tenho um Código php para enviar e-mail mas esta tudo certo e da mensagem que foi enviado. mas o email não envia. veja que nos códigos seguintes a unica diferença é que no primeiro(que não funciona) o Email para quem vai é passado por variável $emailamg = $_POST["emailamg"]; // Para quem vai o e-mail $to = $emailamg; e no segundo passo direto o Email que funciona. $to = "Fulano <[email protected]>" . ", "; esse é o código PHP que não funciona: <html> <?php $emailamg = $_POST["emailamg"]; // Para quem vai o e-mail $to = $emailamg; // $to .= "Outro Fulano(opcional) <[email protected]>" . ", "; // Assunto da Mensagem $assunto = "Contato On-Line"; // Corpo da Mensagem $mensagem = '<html> <body> <font face=Verdana size=1> <img src=caminho_para_img.jpg><br> <br> <b>Contato On-Line</b><br> <br> <b>Nome</b>: ' . $_POST["nome"] . ' <br> <b>E-mail</b>: ' . $_POST["emailamg"] . ' <br> <b>Mensagem</b>: ' . $_POST["mensagem"] . ' <br> <br><br> </font> </body> </html>'; // Headers $headers = "MIME-Version: 1.0\n"; $headers .= "Content-type: text/html; charset=iso-8859-1\n"; $headers .= "From: Contato On-Line <[email protected]>\n"; $headers .= "Return-Path: <[email protected]>\n"; //Envio o Email mail($to, $assunto,$mensagem, $headers); ?> <body> <!-- Manda mensagem e redireciona --> &lt;script>alert('Sua mensagem foi enviada com Sucesso!');</script> </body> </html> e esse é o que funciona <html> <?php // Para quem vai o e-mail $to = "Fulano <[email protected]>" . ", "; // $to .= "Outro Fulano(opcional) <[email protected]>" . ", "; // Assunto da Mensagem $assunto = "Contato On-Line"; // Corpo da Mensagem $mensagem = '<html> <body> <font face=Verdana size=1> <img src=caminho_para_img.jpg><br> <br> <b>Contato On-Line</b><br> <br> <b>Nome</b>: ' . $_POST["nome"] . ' <br> <b>E-mail</b>: ' . $_POST["emailamg"] . ' <br> <b>Mensagem</b>: ' . $_POST["mensagem"] . ' <br> <br><br> </font> </body> </html>'; // Headers $headers = "MIME-Version: 1.0\n"; $headers .= "Content-type: text/html; charset=iso-8859-1\n"; $headers .= "From: Contato On-Line <[email protected]>\n"; $headers .= "Return-Path: <[email protected]>\n"; //Envio o Email mail($to,$assunto,$mensagem, $headers); ?> <body> <!-- Manda mensagem e redireciona --> &lt;script>alert('Sua mensagem foi enviada com Sucesso!');</script> </body> </html> notem que a unica diferença é que me $to no primeiro codigo passo uma variável $emailamg e no segundo que funciona passo direto o e-mail. não sei mais o que fazer. e preciso que seja passado por variável pois é um formulário para indicar a um amigo. segue o código html do formulário <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml"> <head> <meta http-equiv="Content-Type" content="text/html; charset=windows-1252" /> <title>Electronix Store</title> &lt;script src="../js/boxOver.js" type="text/javascript"></script> &lt;script src="../js/jquery.js" type="text/javascript"></script> <link href="../Css/iecss.css" rel="stylesheet" type="text/css" /> <link href="../Css/style.css" rel="stylesheet" type="text/css" /> <!--[if IE 6]> <link rel="stylesheet" type="text/css" href="iecss.css" /> <![endif]--> &lt;script type="text/javascript" src="js/boxOver.js"></script> </head> <body > <form name="senddata" method="post" action="form.php"> <div id="center_content"> <div class="center_content"> <div class="center_title_bar"> Contact Us</div> <div class="prod_box_big"> <div class="top_prod_box_big"> </div> <div class="center_prod_box_big"> <div class="contact_form"> <div class="form_row"> <label class="contact"> <strong>Seu Nome:</strong></label> <input name="nome" type="text" class="contact_input" /> </div> <div class="form_row"> <label class="contact"> <strong>Seu Email:</strong></label> <input name="email" type="text" class="contact_input" /> </div> <div class="form_row"> <label class="contact"> <strong>Nome do Amigo:</strong></label> <input name="NomeAmigo" type="text" class="contact_input" /> </div> <div class="form_row"> <label class="contact"> <strong>Email do Amigo:</strong></label> <input name="emailamg" type="text" class="contact_input" /> </div> <div class="form_row"> <label class="contact"> <strong>Menssage:</strong></label> <textarea name="mensagem" class="contact_textarea"></textarea> </div> <div class="form_row"> <input name="enviar" type="submit" class="formcop" value="Enviar Mensagem" /> <a href="#" class="contact">send</a> </div> </div> </div> <div class="bottom_prod_box_big"> </div> </div> </div> </div> </form> </body> </html>
  9. Ola senhores. Estou com a seguinte situação: Tenho uma pagina “índex.html” com um IFrame no centro aonde carrego minhas paginas. Nesse iframe carrego a pagina 1 e tenho uma imagem que é um link e ao ser clicado abre a pagina2 nesse mesmo iframe. Pelo link envio a imagem da pagina 1 para a pagina 2. Gostaria de fazer um “Indique a um amigo” onde seria enviado por email um link Quando o usuário clicasse nesse link gostaria de abrir a índex mas com a pagina 2 carregada no Iframe. Fui Claro? Alguém pode me ajudar? Muito Obrigado
  10. Bom dia Senhores. estou com um erro ao tentar importar um script. ate o momento fiz o seguinte: instalei o joomla e o phpmyadmin. ao acessar o mysql pelo phpmyadmin criei um banco de dados "loja_estudio" fui então tentar importar um script do banco. (caso precisem posso postar o script) ao clicar em executar aparece esse erro. ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Erro Talvez tenha encontrado um bug no analizador (parser) do SQL. Analise a sua Consulta SQL com atenção, e verifique se as aspas estão corretas e não estão desencontradas. Outra possibilidade de falha é o fato de estar tentando subir um arquivo com saída binária de uma área de texto citada. Pode também experimentar a sua consulta SQL no prompt de comandos do MySQL. A saída de erro do MySQL, isto se existir alguma, também poderá ajudar a diagnosticar o problema. Se continuar a ter problemas ou se o analisador (parser) falhar onde a interface da linha de comandos tiver sucesso, reduza por favor a entrada da consulta SQL até aquele que causou o problema, e envie o relatório de bug com os dados do chunk da seção CORTE abaixo: ----INICIO CORTE---- eNp9UU1PwkAUnPP+incgnuhaPqpQ46HBBkhKW7sFEy8ERYUEKGLR8Hs9+DecVkAumpfXnX2dmfd2 10+SKHGlU5NOXQI/dKUmdWletpVJWYdSZsRipT+tqMHO3AauONrRLWuRvaihSSQyVfG6fphWZeRT cTdfySC67weBR6at4oHnSkM3dFvFvbjgVCNTmDS0I3f9MExV4IVdV9b5w8ba5s9WS5VtLFgQrDFj DrCDhymWmGPFqsEtAq432LK2hmL88N/xhA3eyMtKZh0aNYbGxQlrhpyxhotzxkcZet9ryV6TYy/N fCL3oP31MGWnd7Km7LWhl2BB9Ej1gk4Zp8hP+Cn5xawZ8ZRY0C0dJvjCJ6uF3sMDK8XUbVTL1ebs NtGEblLuXH6bxDFv5dd9tD/3594/+2NChyeymQ6d/lfH6DEPmvrxBosw8HmewzuMOUnEt/BxjbPX bZZfIWRhzOMMSSvQiDjgzieO+HeMe+KEeC+4+gZ2w3CZ ----FIM CORTE---- ----INICIO CRU---- ERROR: C1 C2 LEN: 1 2 479 STR: SVN: $Id$ MySQL: 5.5.8-log USR OS, AGENT, VER: Win MOZILLA 5.0 PMA: 3.3.9 PHP VER,OS: 5.3.5 WINNT LANG: ptbr-utf-8 SQL: -- phpMyAdmin SQL Dump -- version 2.11.6 -- http://www.phpmyadmin.net -- -- Servidor: localhost -- Tempo de Gera??o: Abr 29, 2010 as 01:04 PM -- Vers?o do Servidor: 5.0.51 -- Vers?o do PHP: 5.2.6 SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO"; ----FIM CRU---- consulta SQL: -- phpMyAdmin SQL Dump -- version 2.11.6 -- http://www.phpmyadmin.net -- -- Servidor: localhost -- Tempo de Gera??o: Abr 29, 2010 as 01:04 PM -- Vers?o do Servidor: 5.0.51 -- Vers?o do PHP: 5.2.6 SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO"; Mensagens do MySQL : Documentação #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-' at line 1 ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Alguém sabe como posso resolver isso? Obrigado a Todos.
  11. Obrigado Henrique Funcionou perfeitamente. mas porque sera o meu script não funcionou o html?? não tem nada de mais segue o script completo
  12. Ola Estou usando o 000webhost pode ver minha aplicação nesse link http://rob.net76.net/teste/contato.html estou verificando mensagem direto pela pagina do gmail
  13. Ola Enrique usei como me falou mas o email que recebi foi esse: <font face="Verdana, Geneva, sans-serif", size="2"> <table width="806" border="0" cellpadding="0"> <tr> <td width="186">Contato On-Line</td> <td width="614"> </td> </tr> <tr> <td><b>• Nome:</b></td> <td>a</td> </tr> <tr> <td><b>• Telefone:</b></td> <td>a</td> </tr> <tr> <td><b>• E-mail:</b></td> <td>[email protected]</td> </tr> <tr> <td><b>• Mensagem:</b></td> <td>a</td> </tr> </table></font>
  14. Ola Senhores, Estou fazendo um formulário de contato e gostaria que o email fosse em formato HTML Por exemplo, preciso enviar um link e uma imagem Segue meu código PHP // RECEBE OS VALORES VINDO DO FORMULÁRIO E ATRIBUI AS VARIÁVEIS $imagem = $_POST['imagem']; $site = $_POST['site']; $nome = $_POST['nome']; $email = $_POST['email']; $telefone = $_POST['telefone']; $cidade = $_POST['cidade']; $textodamensagem = $_POST['textodamensagem']; //CABEÇALHO - ONFIGURAÇÕES SOBRE SEUS DADOS E SEU WEBSITE $nome_do_site="Seu Site"; $email_para_onde_vai_a_mensagem = "[email protected]"; $nome_de_quem_recebe_a_mensagem = "Rob"; $exibir_apos_enviar='enviado.html'; //MAIS - CONFIGURAÇOES DA MENSAGEM ORIGINAL $cabecalho_da_mensagem_original="From: $name <$email>\n"; $assunto_da_mensagem_original="Contato no Site"; // FORMA COMO RECEBERÁ O E-MAIL (FORMULÁRIO) $configuracao_da_mensagem_original=" '<html> <body> <font face=Verdana size=1> //gostaria de pegar o caminho de uma imagem aqui <img src=' $imagem '><br> //um link passando o href por parametro <a id="link" href=' $site ' target="_blank" >Clique aqui</a> <br> <b>Contato On-Line</b><br> <br> <b>Nome</b>: ' $nome ' <br> <b>E-mail</b>: ' $email ' <br> <b>Fone</b>: ' $telefone ' <br> <b>Mensagem</b>: ' $textodamensagem ' <br> <br><br> </font> </body> </html>' "; O email esta enviado mas esta vindo o código HTML por email e não a mensagem certa Esse é o email que recebo: <html> <body> <font face=Verdana size=1> <img src=caminho_para_img.jpg><br> <br> <b>Contato On-Line</b><br> <br> <b>Nome</b>: ' . robteste . ' <br> <b>E-mail</b>: ' . [email protected] . ' <br> <b>Fone</b>: ' . rob . ' <br> <b>Cidade</b>: ' . rob . ' <br> <b>Mensagem</b>: ' .sdfsdf . ' <br> <br><br> </font> </body> </html>'; gostaria que viesse o resultado do html e não o codigo. o que estou fazendo de Errado? Grato a todos
×
×
  • Create New...