jgtb__

Membros
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutro

About jgtb__

  1. Faça um programa de lanchonete, que cadastre clientes com seu respectivo nome, produto consumido e perco do produto, perguntar quantos produtos foram consumidos antes do cadastro e cadastrar tudo relacionado ao cliente. Após o cadastro de n clientes e n produtos consumidos, diga o total gasto de cada cliente. Fiz uma parte, mas tem alguns erros no total de cada cliente. var nomes,produtos:vetor[1..50] de caractere precos:vetor[1..50] de inteiro n,i,desejo:inteiro total:inteiro inicio // Seção de Comandos total<-0 para i de 1 ate 50 faca escreval("Digite o nome do cliente:",i) leia(nomes[i]) escreval("Quantos produtos foram consumidos: ") leia(n) escreval("Digite o nome do produto: ") leia(produtos[i]) escreval("Digite o preço: ") leia(precos[i]) se (n=1) então para i de 1 ate n faca total:=total+precos[i] escreval("Total: ",total,"reais") fimpara fimse se(n>1) então para i de 1 ate n faca escreval("Digite o nome do produto: ") leia(produtos[i]) escreval("Digite o preço: ") leia(precos[i]) para i de 1 ate n faca total:=total+precos[i] fimpara escreval("Total: ",total,"reais")
  2. Faça um programa de lanchonete, que cadastre clientes com seu respectivo nome, produto consumido e perco do produto, perguntar quantos produtos foram consumidos antes do cadastro e cadastrar tudo relacionado ao cliente. Após o cadastro de n clientes e n produtos consumidos, diga o total gasto de cada cliente. Fiz uma parte, mas tem alguns erros no total de cada cliente. var nomes,produtos:vetor[1..50] de caractere precos:vetor[1..50] de inteiro n,i,desejo:inteiro total:inteiro inicio // Seção de Comandos total<-0 para i de 1 ate 50 faca escreval("Digite o nome do cliente:",i) leia(nomes[i]) escreval("Quantos produtos foram consumidos: ") leia(n) escreval("Digite o nome do produto: ") leia(produtos[i]) escreval("Digite o preço: ") leia(precos[i]) se (n=1) então para i de 1 ate n faca total:=total+precos[i] escreval("Total: ",total,"reais") fimpara fimse se(n>1) então para i de 1 ate n faca escreval("Digite o nome do produto: ") leia(produtos[i]) escreval("Digite o preço: ") leia(precos[i]) para i de 1 ate n faca total:=total+precos[i] fimpara escreval("Total: ",total,"reais") fimpara fimse fimpara fimalgoritmo