Search the Community

Showing results for tags 'pg_dump'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. Prezados, bom dia! Estou iniciando com o postgresql e me surgiu uma demanda para realizar um dump e um restore, até aí tudo bem, porém ao executar o comando me retorna a seguinte mensagem: FATAL: nenhuma entrada no pg_hba.conf para máquina "[local]", usuário "postgres", banco de dados "banco_de_dados", SSL desabilitado E o Dump não é executado. Já verifiquei no arquivo pg_hba.conf e a máquina local está com permissão trust e já executei o reload no postgres. Será que alguém pode me dar uma luz? Não faço ideia do que seja. Desde já agradeço a todos.
  2. Boa tarde pessoal, Tenho uma missão... migrar o banco de dados de um servidor para outro, sendo que para isso, não poderei simplesmente criar o database, terei que trazer no meu dump somente os dados e restaurá-los no novo servidor. Fiz o dump utilizando o phppgadmin através da opção exportar criei o SQL, selecionando somente a opção "somente dados"... isso gerou um dump de 5GB. bom, copiei o arquivo para o outro servidor e tentei o restore com o psql via shell(já que no phppgadmin não tem restore). Executei o seguinte comando: psql -h localhost -U celdba -d sagu_teste < dump.sql e recebi o seguinte erro: You are now connected to database "postgres" as user "celdba". \connect: FATAL: database "oz_sgc_" does not exist O estranho e que ele diz que estou conectado ao database "postgres" ao invés do "sagu_teste" no qual deveria executar o restore... outra coisa estranha é ele se referir ao database "oz_sgc"... não faço idéia que database seja este.. Se alguém tiver mais alguma dica, agradeço. Att, André Moreira
  3. Bom Dia, Mesmo após varias pesquisas na web e nos tópicos aqui presentes ainda não consegui resolver o problema de "Cabeçalho de pagina inválido" quando tento realizar o backup diário na base PostgreSQL, alguém já passou por isso e pode me orientar como resolver o problema ou então como contorna-lo? Hoje estou com o sistema funcionando porém sem backup da base, um problema caso seja necessário realizar algum restore. Já tentei realizar backup apenas de algumas tabelas e backup full mais o comando pg_dump falha, aponta erro no Catálogo "PostgreSQL" na tabela "pg_ts_parser", segue a msg do problema: "ERRO: cabeçalho de pagina é inválido no bloco 0 da relação base/16395/3601" onde 16395 é o OID da base de dados e 3601 da tabela de catálogo pg_ts_parser Desde já agradeço pela colaboração! Lucas Plis Dolce.
  4. Olá, boa tarde! Estou em sérios apuros aqui no trabalho, onde necessito utilizar o client do postgres no meu vagrant (postgres-9.1.14) para "dumpar" uma base remota com versão 8.4. Acontece que o problema maior é que o postgres 8.4 não reconhece o modelo de FUNCTIONS e LANGUAGE pgplsql que a versão atual possui. Preciso muito desta ajuda pessoal, pois por enquanto não podemos migrar todos os servidores e todos os clientes para a versão mais atual. Referências encontradas: **You have two choices:** Run 9.1 version, dump your database and restore it using 9.3 http://www.postgresql.org/docs/9.3/static/pgupgrade.html **pg_upgrade** pg_upgrade -- upgrade a PostgreSQL server instance http://www.postgresql.org/docs/9.3/static/pgupgrade.html Agradeço desde já.