Search the Community

Showing results for tags 'portugol'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Programação & Desenvolvimento
    • ASP
    • PHP
    • .NET
    • Java
    • C, C++
    • Delphi, Kylix
    • Lógica de Programação
    • Mobile
    • Visual Basic
    • Outras Linguagens de Programação
  • WEB
    • HTML, XHTML, CSS
    • Ajax, JavaScript, XML, DOM
    • Editores
  • Arte & Design
    • Corel Draw
    • Fireworks
    • Flash & ActionScript
    • Photoshop
    • Outros Programas de Arte e Design
  • Sistemas Operacionais
    • Microsoft Windows
    • GNU/Linux
    • Outros Sistemas Operacionais
  • Softwares, Hardwares e Redes
    • Microsoft Office
    • Softwares Livres
    • Outros Softwares
    • Hardware
    • Redes
  • Banco de Dados
    • Access
    • MySQL
    • PostgreSQL
    • SQL Server
    • Demais Bancos
  • Segurança e Malwares
    • Segurança
    • Remoção De Malwares
  • Empregos
    • Vagas Efetivas
    • Vagas para Estágios
    • Oportunidades para Freelances
  • Negócios & Oportunidades
    • Classificados & Serviços
    • Eventos
  • Geral
    • Avaliações de Trabalhos
    • Links
    • Outros Assuntos
    • Entretenimento
  • Script Brasil
    • Novidades e Anúncios Script Brasil
    • Mercado Livre / Mercado Sócios
    • Sugestões e Críticas
    • Apresentações

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 10 results

  1. Estou precisando converter a linguagem portugol para C, alguém poderia me ajudar a resolver esses exercicios na linguagem C?
  2. Uma questão simples, mas que estou tendo dificuldades: inserir o tempo de corrida de 5 participantes e imprimir os 3 primeiros lugares [Portugol; favor, preferencialmente utilizar condicionais]
  3. 1 - Deixe sua reposta para que outras pessoas posam ver 2 - Pode-se responder em qualquer linguagem, mas se puder deixar só o algoritmo escrito (Portugol) por exemplo, seria ótimo. Vamos ao desafio: Criar um algoritmo que multiplique dois números inteiros positivos maiores que zero SEM usar o operador de multiplicação (*) Boa sorte!
  4. Vocês já perceberam o quanto uma pessoa com conhecimentos de programação tem valor em meio a sociedade ?! Hoje em dia, os comércios e as empresas estão desesperadamente atrás de pessoas com conhecimentos de programação para contratar. O futuro da informática depende de pessoas com conhecimentos para programar. Sabia que agora você pode adquirir um livro ensinando a ter uma breve lógica de programação ?! Isso mesmo, não precisa sair de casa e até mesmo após ter baixado, não precisa nem ter internet para aprender a programar, é apenas necessário um computador ou celular. Muitas pessoas estão adorando essa técnica, vai ficar de fora ? Link: http://bit.ly/2CeVaHt
  5. Olá boa noite! estou com uma grande duvida, faço curso de TADS e meu professor quer que nós passemos um código que fizemos em portugol no visualg para a linguagem C, estou muito perdido em como fazer isso. algoritmo "Locação de Veiculos" // Função : Locadora de Veiculos // Autor : Maxwell Ruan // Data : 21/10/2017 // Seção de Declarações var opcao,opcao2 : inteiro CODIGO,NOME,RG,CPF,ENDERECO,DATADENASCIMENTO,CNH,CLIENTE,AUTOMOVEL:CARACTER MARCAVEICULO,CODIGOVEICULO,MODELO,ANOFABRICACAO,CLASSIFICACAO,CODIGOCLASS:CARACTER VALOR:REAL a,b,soma :numerico // procedimentos procedimento menu_principal inicio escreval ("++++++++++++++++++++++++++++++++++++") escreval (" 1- Cadastro de Cliente +") escreval (" 2- Cadastro de Veiculos +") escreval (" 3- Cadastro de Classificação +") escreval (" 4- Cadastro de movimentação +") escreval (" 5- Sair +") escreval ("++++++++++++++++++++++++++++++++++++") fimprocedimento procedimento menu_cliente inicio escreval ("======Menu do Cliente=====") escreval (" ") escreval ("==========================") escreval ("Digite o Código") leia (codigo) escreval ("Digite o Nome") leia (nome) escreval ("Digite o RG") leia (rg) escreval ("Digite o CPF") leia (cpf) escreval ("Digite o Endereço") leia (endereco) escreval ("Digite a Data de Nascimento") leia (datadenascimento) escreval ("Digite a Carteira de habilitação") leia (cnh) limpatela fimprocedimento procedimento menu_veiculo inicio escreval ("+==========Menu do Veiculo================ +") escreval ("+ Digite (01) se for do tipo Básico +") escreval ("+ Digite (02) se for do tipo Intermediário +") escreval ("+ Digite (03) se for do tipo Luxuoso +") escreval ("+========================================= +") escreval ("Digite o Código") leia (CODIGOVEICULO) escreval ("Digite a Marca do Veciulo") leia (MARCAVEICULO) escreval ("Digite o Modelo do Veiculo") leia (MODELO) escreval ("Digite o Ano de Fabricação") leia (ANOFABRICACAO) escreval ("Digite o Codigo de Classificação") leia (CLASSIFICACAO) limpatela fimprocedimento procedimento menu_class inicio escreval ("+==========Menu de Classificação========== +") escreval ("+ Digite (01) se for do tipo Básico +") escreval ("+ Digite (02) se for do tipo Intermediário +") escreval ("+ Digite (03) se for do tipo Luxuoso +") escreval ("+========================================= +") escreval ("Digite o Código") leia (CODIGOCLASS) escreval ("Digite a Marca do Veciulo") leia (MARCAVEICULO) escreval ("Digite a Classificação") leia (CLASSIFICACAO) escreval ("Digite o Valor da locação") leia (VALOR) limpatela fimprocedimento procedimento menu_movimentacao inicio escreval ("========Menu de Movimentação=======") escreval ("! [ Valor das Diárias ] !") escreval ("! Básico :R$ 80,00 !") escreval ("! Intermediário :R$ 150,00 !") escreval ("! Luxuoso :R$ 300,00 !") escreval ("!=================================!") escreval ("Digite o Código") leia (codigo) escreval ("Digite o Código do Cliente") leia (CLIENTE) escreval ("Digite o Código do Automovel") leia (AUTOMOVEL) escreval ("Digite o Valor da locação") leia (a) escreval ("Digite a Quantidade de Diarias") leia (b) soma:=(a*b) escreval ("=============================================+") escreval ("O Valor Total que o Cliente pagará será:" ,soma) escreval (" +") escreval ("=============================================+") fimalgoritmo limpatela fimprocedimento inicio // Seção de Comandos repita menu_principal escreva ("=>") leia (opcao) limpatela escolha (opcao) caso 1 // cadastro de cliente menu_cliente caso 2 // cadastro de veiculos menu_veiculo caso 3 // cadastro de classificação menu_class caso 4 // cadastro de movimentação menu_movimentacao caso 5 // sair outrocaso escreval("Opção Invalidade") fimescolha ate opcao = 5 fimalgoritmo
  6. Olá pessoal, O algoritmo abaixo deve informar a soma das matrizes A e B porém não está funcionando. Já alterei variáveis, renomeei, mas não consegui resolver porque a matriz C imprime zerada. programa { funcao inicio() { const inteiro LIN = 3, COL = 4 //declara duas constantes inteiro A[LIN][COL] //cria a matriz A inteiro B[LIN][COL] //cria a matriz B inteiro C[LIN][COL] //cria a matriz C escreva ("Digite os elementos da Matriz A: \n") Leitura_Matriz (A, LIN, COL) escreva ("Digite os elementos da Matriz B: \n") Leitura_Matriz (B, LIN, COL) Soma_Matriz (A, B, C, LIN, COL) escreva ("Os elementos da Matriz C são: \n") Imprime_Matriz (C, LIN, COL) } funcao Leitura_Matriz (inteiro &Mat[][], inteiro qlin, inteiro qcol) { inteiro l, c para (l = 0; l < qlin; l++) { para (c = 0; c < qcol; c++) { escreva ("Digite o elemento ", l, ",", c, ": ") leia (Mat[l][c]) } } } funcao Soma_Matriz (inteiro M1[][], inteiro M2[][], inteiro M3[][], inteiro qlin, inteiro qcol) { inteiro l, c para (l = 0; l < qlin; l++) { para (c = 0; c < qcol; c++) { M3[l][c] = M1[l][c] + M2[l][c] } } } funcao Imprime_Matriz (inteiro Mat[][], inteiro qlin, inteiro qcol) { inteiro l, c para (l = 0; l < qlin; l++) { para (c = 0; c < qcol; c++) { escreva (Mat[l][c], "; ") } escreva ("\n") } } }
  7. Boa tarde pessoal, desenvolvi esse algoritmo para verificar se uma matriz é inca ou não, ou seja se partindo do extremo superior esquerdo e seguindo em espiral o número seguinte é o sucessor inteiro do número anterior, meu algoritmo está dando que a matriz é errada quando eu não começo com o primeiro termo da matriz [1,1] sendo 1, gostaria de pedir um minuto da atenção e experiência de todos vocês sou grato desde já. algoritmo "Matriz Inca" var i,j,n,inicol,fimcol,inilin,fimlin,degrau:inteiro matriz:vetor[1..20,1..20] de inteiro eh_inca:logico inicio repita escreva("Escolha a dimensão da Matriz:") leia (n) se((n < 1)ou(n > 20))então escreval("A dimensão da matriz precisa estar entre 1 e 20") fimse ate ((n > 0 ) e (n < 21)) escreval("Matriz: ",n ," x ",n) escreval("Digite os numeros da Matriz abaixo:") para i de 1 ate n faca para j de 1 ate n faca escreval("Entre com o valor de matriz[",i,",",j,"]:") leia (matriz[i,j]) fimpara fimpara para i de 1 ate n faca escreval para j de 1 ate n faca escreva (matriz[i,j]) fimpara escreval fimpara inicol <-1 fimcol <-n inilin <-1 fimlin <-n degrau <-0 eh_inca <- verdadeiro enquanto ((eh_inca) e (inicol<fimcol) e (inilin<fimlin)) faca para i de inicol ate fimcol faca se (matriz[inilin,i] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara inilin <- inilin + 1 para i de inilin ate fimlin faca se (matriz[i,fimcol] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara fimcol <- fimcol - 1 para i de fimcol ate inicol passo -1 faca se (matriz[fimlin,i] = degrau + 1) então degrau <- degrau + 1 senao eh_inca <- falso fimse fimpara fimlin <- fimlin - 1 para i de fimlin ate inilin passo -1 faca se (matriz[i,inicol] = degrau + 1) então degrau <- degrau + 1 senao eh_inca<-falso fimse fimpara inicol<-inicol + 1 fimenquanto se (eh_inca) então escreval ("Matriz é inca") senao escreval ("Matriz não é inca") fimse
  8. Eu preciso fazer um programa que faça com que o usuário digite o seu nome completo, portanto exiba apenas o primeiro nome e as boas vindas. algoritmo "NomeCompleto" // Função : // Autor : // Data : 07/05/2016 // Seção de Declarações var nomecompleto : caractere inicio escreval ("Entre com um nome completo.") leia (nomecompleto) escreval ("Olá " ,nomecompleto," .Desejamos boas vindas a você!") fimalgoritmo Estou no primeiro semestre de lógica de programação.
  9. Olá,eu tenho que resolver o seguinte exercício em portugol: Fazer um algoritmo que leia um número (considere números de 5 digitos). Escreva quantos algarismos deste numero são impares e tambem a soma dos algarismos pares. Como eu faço para separar o número de 5 digitos em 5 números isolados?
  10. Boa noite, Estou a umas 15 horas programando (começando) e não consegui fazer com que identifique o menor valor de laco, onde estou errando? algoritmo "SomadorNumerio" var cont, n, s, maior, menor: inteiro inicio cont <-1 s <- 0 enquanto (cont <= 10) faca escreva ("Digite o ", cont,"o. valor: ") leia (n) se (n > maior) então //funcao para reconhecer o maior numero digitado maior <- n fimse se (n >= 0) então //funcao para reconhecer o menor numero digitado //!!!!!!!!!!!!!!não ESTA FUNCIONANDO!!!!!!!!!!!!! menor <- n fimse s <- s + n cont <- cont + 1 FimEnquanto escreval ("A soma de todos o valores foi ", s) escreval ("O maior valor digitado foi ", maior) escreva ("O menor valor digitado foi ", menor) fimalgoritmo