Jump to content
Fórum Script Brasil
  • 0

Página Aspx Não Está Reconhecendo Css.


Guest ---s_ric_ptbrasil ---
 Share

Question

Guest ---s_ric_ptbrasil ---

Página aspx não está reconhecendo CSS.

Eu tenho uma página Cabecalho Master que está com a tal CSS linkada.

As páginas aspx que fazem parte da pagina Master, não estão aparecendo o estilo da tal CSS, por quê ?

Por favor, me ajudem. Agradeço desde já pelo meu pedido.

No código da página master a css se encontra da seguinte forma:

<head runat="server">
    <title>Untitled Page</title>
    <script language="javascript" src="../js/Funcoes.js"></script>
    [b]<link rel='stylesheet' type='text/css' [color="#FF0000"]href='../css/Class.css'[/color] />[/b]
</head>

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0
Guest ---s_ric_ptbrasil ---

Na verdade é só uma página aspx que tem a tal css relacionada.

Exemplo:

Class.css (dentro dela tem vários estilos, uma delas é estilo de link do tipo "a.link1:{...} a.link2:{...} a.link3:{...}") .

Na página aspx tem uma label (Filtro) que está relacionada ao estilo "link1". Exemplo

<TABLE id="TabFiltro" width="96%" align="center" runat="server">
      <TBODY>
              <TR>
                    <TD>
                            <asp:Label id="lblFiltro" runat="server" CssClass="linkum"> ...
...
...
</Table>

Enfim, já fiz de tudo e nada: Analisei a class.css para ver se está certo, olhei no código da página aspx para ver se estava relacionada, olhei na página Master para ver se estava a class.css linkada e ainda fiz o ftp dos arquivos e não adiantou.

O que deve ser . Por favor me dêem um help. Agradeço desde já.

Link to comment
Share on other sites

  • 0

duas coisas:

<asp:Label id="lblFiltro" runat="server" CssClass="linkum">
o nome da classe ta linkum mas você disse q no css ta a.link1, você ta pondo nomes q batam mesmo?? outra coisa, se você ciruou a classe com nome a.link1 a classe so vale pra tag a e o asp:Label, quando você abrir a pagina, vira um span por isso essa classe não vai funcionar pra ele. se você criar só assim:
.link1 {
    propriedade1: valor1;
    propriedade2: valor2;
}[/code]

ai sim deve funcionar.

Link to comment
Share on other sites

  • 0
Guest --- s_ric_ptbrasil ---

1º. O nome da class está correto eu coloquei link1 só como exemplo.

2º. Eu testei como você falou, mas mesmo assim eu não entendi. O código é para inserir aonde? É dentro da class ou dentro da label?

Link to comment
Share on other sites

  • 0

quis dizer, aqui ó, você disse q seus codigos tavam tipo assim:

a.link1:{...} a.link2:{...} a.link3:{...}
quis dizer pra você fazer assim:
.link1:{...} .link2:{...} .link3:{...}
se você fizer a.link1 essa classe só vai funciona pra tag a (link). o asp:Label é uma tag span por isso não funciona com o a.link1 na hora de preencher a classe do asp:Label, pode dexar como esta:
<asp:Label id="lblFiltro" runat="server" CssClass="link1">

Link to comment
Share on other sites

  • 0
Guest --- s_ric_ptbrasil ---

o css não está na class.css, está na própria página:

<style type="text/css">
<!--
/* PARA O LINK 1 */
.link1:link {
color:#FF0000;
text-decoration:none;
}
.link1:visited {
color:#00ff00;
text-decoration:none;
}
.link1:hover {
color:#0000ff;
text-decoration:none;
}
.link1:active {
color:#ffFF00;
text-decoration:none;
background-color:#000000;
}

-->
</style>
e a página aspx:
<TABLE id="TabFiltro" cellSpacing="0" cellPadding="6" width="96%" align="center" bgColor="#eeeeee" border="0" runat="server">
    <TBODY>
    <TR>
    <TD>
    <P align="center">
    <asp:Label id="lblFiltro" runat="server" CssClass="link1">
    </asp:Label>
    </P>
    </TD>
    </TR>
    </TBODY>
    </TABLE>

Link to comment
Share on other sites

  • 0

deve estar funcionando sim (desde q tenha conteudo no label).

aparentemente não vai acontecer nd. porque você não pos formato pra classe em si mas só pra quando tiver um link nela (veja q você fez .link1:link).

mas se você passar o mouse por cima do seu label ele deve mudar para o formato q ta no hover, não??

e se você clicar ele vai tb vai mudar pro fotmato q ta no active.

so os formatos do link e do visited q você não vai ver, a não ser q ponha uma tag <a> dentro do label.

tenta passar o mouse por cima e clicar no conteudo do seu label pra ver se ele não muda.

Link to comment
Share on other sites

  • 0
Guest --- s_ric_ptbrasil ---

Eu fiz assim.

<TABLE id="TabFiltro" cellSpacing="0" cellPadding="6" width="96%" align="center" bgColor="#eeeeee" border="0" runat="server">

<TBODY>

<TR>

<TD>

<P align="center"><a class="link1">

<asp:Label id="lblFiltro" runat="server">

</asp:Label></a>

</P>

</TD>

</TR>

</TBODY>

</TABLE>

Eu estou errado?Não funcionou.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.2k
    • Total Posts
      647.4k
×
×
  • Create New...