• 0
Sign in to follow this  
Charles G. P.

(Resolvido) Alguém poderia me dar uma luz com esses dois algoriti

Question

Boa noite pessoal,

Sou novo na área de programação e estou tendo dificuldade em resolver os dois problemas abaixo... Sera que alguém pode me ajudar?

1) Fazer um programa que leia o código do aluno e a sua nota para um número indeterminado de alunos. O programa deve ler o código do aluno, se for diferente de zero, pergunta a nota. Se o código for zero, encerra o programa. O programa deve apresentar os seguintes itens:

a) A menor nota;

b ) A maior nota;

c) A média de todos alunos;

OBS: Nesse primeiro problema não sei como resolver a apresentação da menor e maior nota?! abaixo se encontra o inicio da minha solução... Ah! uso o AMBAP para testar!!!

variaveis

numerico nota, media_da_turma, codaluno, menornota, maiornota, cont, acum

inicio

cont := 0

totalnota := 0

escrever "Informe codigo do aluno: "

ler codaluno

faca enquanto (codaluno<>0)

escrever "Informe a nota: "

ler nota

cont := cont + 1

totalnota:= totalnota + nota

escrever "Informe codigo do aluno: "

ler codaluno

fim_enquanto

//menornota := ??????

//maiornota := ??????

media_da_turma := (totalnota / cont)

escrever "A media da turma foi: ", media_da_turma

fim

Esse segundo problema não sei nem por onde começar... :wacko:

2)Fazer um programa que leia os valores das variáveis a 1, q e n referentes a uma progressão geométrica

(a 1: primeiro elemento; q: razão da progressão; n: número de elementos da progressão).

Apresentar os seguintes resultados:

a) Mostrar todos os elementos da PG na tela;

b ) Calcular e apresentar na tela a soma de todos os elementos que forem par;

c) Calcular e apresentar a média aritmética de todos os elementos da PG;

Edited by Charles G. P.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Charles G. P. no seu primeiro para fazer a aprezentação fará o seguinte

como você atribuiu 0 a variavel cont e totalnota,

cont := 0
totalnota := 0
maior_nota := 0
menor_nota := 100
///
//
///
/
//
///
se (maior_nota < nota ) então
      maior_nota := nota
   fimse
   se (menor_nota > nota) então
      menor_nota := nota
   fimse
//
/

/
/
/

Share this post


Link to post
Share on other sites
  • 0

velho fiz a primeira parte da progreção geométrica faça o restante

var
a1, q, n, aux : inteiro
inicio
escreva ("entre com o valor de termos:  ")
leia (n)
escreva("entre com o valor do primeiro termo:  ")
leia (a1)
escreva ("entre com a razão:  ")
leia (q)
para aux de 1 ate n faca
   a1:= a1 * q
   escreva (a1)
fimpara
fimalgoritmo

um abraço

Share this post


Link to post
Share on other sites
  • 0

Só lembrando que a formula da soma dos N primeiros termos de uma PG é:

Estou usando :

a^n = a elevado a N,

Sn = total da soma,

A1 = primeiro elemento.

q = quociente

Sn= A1((q^n)-1)/q-1

Share this post


Link to post
Share on other sites
  • 0

Nego Drama... antes de mais nada, muito obrigado por me ajudar a solucionar esse "drama"! :rolleyes:

Sofri mais um pouco mas com a ajuda q você me deu em ambos algoritimos consegui solucionalos...

Mais uma vez... Obrigado pela força!

Abração

Edited by Charles G. P.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this