Jump to content
Fórum Script Brasil
  • 0

(Resolvido) IFRAME carrega com espaço em branco na pagina INDEX


dianabreit
 Share

Question

Bom dia, estou terminando de desenvolver um site e coloquei 2 iframes na pagina inicial, o primeiro é o home.html e o segundo cotacao.html, mas quando carrega a pagina cotacao.html (por ser uma pagina inteira), ele manetm o espaço em branco do cotacao.html, e fica um espaço horrivel na pagina inicial...

ele só volta ao normal quando clico no link "home" ou ao abrir qualquer outro link do menu... já tentei fazer de tudo e não consigo arrumar, alguém teria uma ideia de o que fazer pra não carregar com esse espaço em branco???

Edited by dianabreit
Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Altera a altura do primeiro iframe, ou melhor diminui a altura dele, pois ele tá com altura de 912px.

Link to comment
Share on other sites

  • 0

Eu vi no Firebug, e estava lá a altura de 912px. Faça um teste e coloque a altura do primeiro iframe como 400px.

Link to comment
Share on other sites

  • 0

então ai é q ta o X da questao...

eu baixei esse firebug, e fui procurando 1 ou 1 pra ver se eu encontrava, e achei o iframe com 912px (sendo q no dreamweaver não constava nada de 912), mas no firebug encontra, mass depois q eu dou um cline no link do menu "home" ele atualiza para 408px (q é o tamanho q eu coloquei no dreamweaver)...

q foi o que eu expliquei logo no inicio, ele carrega grande, mas depois q clica em qualquer outro link, ele volta ao normal... mas não tem nada de 912px no dreamweaver pra eu corrigir...

ele carrega grande, e depois q volta ao normal, mas eu não qro q carregue daquele jeito, porque alguém q não sabe desse bug, vai entrar e vai estar em um aspecto horrivel o site...

o que será q ta acontecendo??? =/

Link to comment
Share on other sites

  • 0

então, não é o menu, porque eu coloquei o menu dentro de outro iframe, eu acho q deve ser a pagina de orçamento q ta empurrando.. ela deve estar carregando e mantendo o tamanho dele inicialmente grande... porque antes de ter aquele iframe do orçamento ele não tinha esse problema...

mas não tem nada q possa corrigir isso???

Link to comment
Share on other sites

  • 0

acho q consegui resolver, dentro da pagina orçamento eu tinha colocado um código pra ele se ajustar... (mas tava se ajustando errado rs)

então resolvi tirar o codigo e tal, dai não esta mais dando erro algum...

obrigada pela ajuda....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...