Jump to content
Fórum Script Brasil
  • 0

Erro: StartIndex não pode ser menor que zero.


Question

Boa noite amigos,

to com uma aplicação em ASP.NET que dá o seguinte erro:

Erro de Servidor no Aplicativo '/PortaldoConsumidor/back153/enquetes'.

--------------------------------------------------------------------------------

StartIndex não pode ser menor que zero.

Nome do parâmetro: startIndex

Descrição: Ocorreu uma exceção não tratada durante a execução da atual solicitação da Web. Examine o rastreamento de pilha para obter mais informações sobre o erro e onde foi originado no código.

Detalhes da Exceção: System.ArgumentOutOfRangeException: StartIndex não pode ser menor que zero.

Nome do parâmetro: startIndex

Erro de Origem:

Exceção não tratada foi gerada durante a execução da atual solicitação da Web. As informações relacionadas à origem e ao local da exceção podem ser identificadas usando-se o rastreamento de pilha de exceção abaixo.

Rastreamento de Pilha:

[ArgumentOutOfRangeException: StartIndex não pode ser menor que zero.

Nome do parâmetro: startIndex]System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy) +7494975

System.String.Substring(Int32 startIndex) +17

_telaEnquetes.IncluirEnquete(Object sender, CommandEventArgs e) +1679

System.Web.UI.WebControls.ImageButton.OnCommand(CommandEventArgs e) +8738446

System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) +176

System.Web.UI.WebControls.ImageButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10

System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13

System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +36

System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1565

--------------------------------------------------------------------------------

Informações sobre a Versão: Microsoft .NET Framework Versão:2.0.50727.3615; Versão do ASP.NET:2.0.50727.3614

Esta parte do sistema é uma ENQUETE, que faz upload de uma imagem no cadastro.

Quando rodo o sistema localmente não dá erro. tipo LOCALHOST.

Agora via WEB, ou acessando o sistema por outra máquina acontece este erro.

alguém já viu isso??

Link to post
Share on other sites

2 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      148980
    • Total Posts
      645041
×
×
  • Create New...