• 0
Sign in to follow this  
malereis

Erro Ole

Question

Olá pessoal.

Boa tarde.

Tenho uma aplicação que roda muito bem na máquina onde está instalado o Delphi.

Dá o seguinte erro Ole error 8004503A quando instalado em outra máquina.

A única coisa diferente que estou usando nessa aplicação é o ClientDataSet.

O arquivo gerado pelo ClientDataSet está exatamente onde deveria estar, na máquina onde instalo o programa e que não tem Delphi instalado.

Estou usando o InnoSetup.

Será que falta alguma dll, ou outra coisa?

Alguém pode ajudar.

Grato pela resposta.

Malereis

Edited by malereis

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Dá o seguinte erro Ole error 8004503A quando instalado em outra máquina.

se voce está usando algum comando para reproduzir voz e não tiver o software instalado em outra maquina, o erro será esse mesmo ( Microsoft SAPI 5.1 )

procedure TForm1.Button1Click(Sender: TObject);
var texto : string;
    voz: OLEVariant;
begin
   texto := Label1.Caption + Label2.Caption;
   voz := CreateOLEObject ('SAPI.SpVoice');
   voz.Speak (texto, 0);
end;

abraço

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this