Jump to content
Fórum Script Brasil
  • 0

Qual erro no meu código?


rodrygonet
 Share

Question

Já procurei ajuda em vários fóruns cheguei ate ser mal interpretado, mais gostaria de um auxilio para resolver o exercício.

Alguém poderia me ajudar qual o erro no meu código. (estou com muita dificuldade)

Faça um algoritmo no Visualg que utilize estrutura de repetição que simule a locação de 10 livros (exemplo:

Solicite o titulo do livro, gênero (1- Humor, 2- suspense, 3- infanto-juvenil, 4- ficção) e o valor

de locação, calcule o total a ser pago pela locação com valor de desconto de cada gênero.

Tabela descontos: Humor: 5% - suspense: 8% - Infanto-Juvenil: 10% - Ficção: 12%

Código:

var

desconto, valorPago, valorLivro: real

totalDesconto, totalPago: real

genero, titulo_livro,opc: caractere

quantidade: logico

inicio

// Seção de Comandos

valorLivro <- 1

Quantidade <- =10

opc <- "x"

enquanto valorLivro <> 0 faca

limpatela

escreva("Digite o Título do Livro: ")

leia(titulo_livro)

escreva("Digite o valor do livro: ")

leia(valorLivro)

se valorLivro <> 0 então

escreval("Digite o Gênero")

escreva("(H)Humor / (S)Suspense / (I)Infanto-Juvenil / (F) Ficção: ")

leia(genero)

escolha genero

caso "H"

desconto <- 0.5 * valorLivro

caso "S"

desconto <- 0.8 * valorLivro

caso "I"

desconto <- 0.10 * valorLivro

caso "F"

desconto <- 0.12 * valorLivro

outrocaso

escreval("livro inválido!")

escreval("Não haverão descontos!")

desconto <- 0

fimescolha

valorPago <- (valorLivro * quantidade) - desconto

totalDesconto <- totalDesconto + desconto

totalPago <- totalPago + valorPago

escreval("Desconto no Livro: ",desconto)

escreval("Valor total a ser pago: ",valorPago)

escreval("Tecle Enter para sair...")

leia (opc)

fimse

fimenquanto

fimalgoritmo

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.9k
    • Total Posts
      648.8k
×
×
  • Create New...