Jump to content
Fórum Script Brasil
  • 0

Algoritmo sobre vetor


Guilherme P.
 Share

Question

Galera eu preciso de ajuda pra iniciar esse algoritmo que esta dando muita dor de cabeça (VISUALG).

Se tiver um filho de Deus pra me ajudar eu ficarei muito grato.

Desde já agradeço.

Uma empresa possui um ônibus com 48 lugares (24 janelas e 24 no corredor). Faça um

programa que utilize dois vetores para controlar as poltronas ocupadas no corredor e na janela.

Considere que zero representa poltrona desocupada e um representa poltrona ocupada.

Esse programa deve controlar a venda de passagens da seguinte maneira:

O cliente informa se deseja poltrona no corredor ou na janela e, depois, o programa

deve informar quais poltronas estão disponíveis para a venda;

Quando não existirem poltronas livres no corredor, nas janelas ou, ainda, quando o ônibus estiver

completamente cheio, deve ser mostrada uma mensagem;

Consegui fazer isso:

algoritmo "Venda De Pass"

var

jan: vetor [1..24] de inteiro

cor: vetor [24..48] de inteiro

cont:inteiro

conta:inteiro

x:inteiro

y:caracter

inicio

conta<-0

para x de 1 ate 48 faca

escreval("Você quer poltrona na janela ou no corredor? ")

leia(y)

se y="janela" então

conta<-conta+1

Escreval("Qual poltrona você gostaria?")

para cont de 1 ate 24 faca

se jan[cont] = 0 então

Escreva(cont)

fimse

fimpara

se y="corredor" então

cont1<-cont1+1

escreval("Qual poltrona você gostaria?")

fimse

para cont de 24 ate 48 faca

se cor[cont]=0 então

escreva (cont)

fimse

fimpara

fimse

fimpara

fimalgoritmo

Edited by Guilherme P.
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Cara é simples

Não entendi a parte que escolhe as poltronas no seu código :wacko: . tu pode fazer ex:

Digita o número que tu quer

"Código pra ver se a poltrona esta ocupada"

Se não ta ocupada beleza, determina a variável como 1 que siginfica ocupada.

Na parte da escolha janela ou corredor tu pode fazer:

se variavel = "janela" então
/codigo da escolha de janelas\
senao
/codigo da escolha de corredor\
Para mostrar as poltronas vazias etc você pode usar assim:
para i de 1 ate 24 faca
se Janelas[i] = 1 então
escreval("Janela",i," Ocupada ")
senao
escreval("Janela",i," Vazia ")
fimse
fimpara
No caso de ocupado pode fazer assim: pega o número digitado antes na escolha da poltrona e
enquanto Janelas[numero] = 1 faca
escreval("Poltrona ocupada escolha outra")
leia(numero)
fimenquanto

Pra ver se o onibus está cheio tu pode colocar uma variável no final de cada escolha de poltrona e quando chegar a X ocupados não repete mais ou não executa mais o código. :mellow:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.8k
    • Total Posts
      648.8k
×
×
  • Create New...