Jump to content
Fórum Script Brasil
  • 0

Problema com INSERT


Renato Penna
 Share

Question

Gente, estou com problema ao dar insert no banco quando insiro uma string com caracteres especiais (acentos, cedilha, etc.). Já tentei mudar o collation para uft-8-general-ci ou latin1-general-ci, mas nenhum dos dois deu jeito.

Para ser mais específico... Por exemplo, quando eu tento inserir por PHP a string "NewProcess Serviços de Consultor", ele insere "NewProcess Serviços de Consultor". Mas se eu na página coloco: echo $str_sql; exit; e depois copio e colo a query no phpmyadmin, ai insere direito. Alguém sabe o que está acontecendo ?

Desde já agradeço.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Resolvido! Eu estava usando uma função que passava os dados por parâmetro e essa função era chamada dentro de uma primeira função que recebia os dados do form. Quando eu passei a chamar a segunda função pela página que recebe os dados do form ao invés de chama-la dentro da primeira função e passei a por como parâmetros os requests do form, ai funcionou.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.9k
    • Total Posts
      648.7k
×
×
  • Create New...