• 0
Sign in to follow this  
jgtb__

Duvida em relacao a esse exercicio!

Question

Faça um programa de lanchonete, que cadastre clientes com seu respectivo nome, produto consumido e perco do produto, perguntar quantos produtos foram consumidos antes do cadastro e cadastrar tudo relacionado ao cliente. Após o cadastro de n clientes e n produtos consumidos, diga o total gasto de cada cliente.

Fiz uma parte, mas tem alguns erros no total de cada cliente.

var
nomes,produtos:vetor[1..50] de caractere
precos:vetor[1..50] de inteiro
n,i,desejo:inteiro
total:inteiro
inicio
// Seção de Comandos
total<-0
para i de 1 ate 50 faca
escreval("Digite o nome do cliente:",i)
leia(nomes[i])
escreval("Quantos produtos foram consumidos: ")
leia(n)
escreval("Digite o nome do produto: ")
leia(produtos[i])
escreval("Digite o preço: ")
leia(precos[i])

se (n=1) então
para i de 1 ate n faca
total:=total+precos[i]
escreval("Total: ",total,"reais")
fimpara
fimse
se(n>1) então

para i de 1 ate n faca
escreval("Digite o nome do produto: ")
leia(produtos[i])
escreval("Digite o preço: ")
leia(precos[i])

para i de 1 ate n faca
total:=total+precos[i]

fimpara

escreval("Total: ",total,"reais")

Edited by kuroi
Adicionar tag CODE

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Guest
This topic is now closed to further replies.
Sign in to follow this