Jump to content
Fórum Script Brasil
  • 0

Ajuda com Loop de um Loop!


cigarretts
 Share

Question

Boa noite galera, eu queria um modo de repetir esse loop "PARA" , 32 vezes na tela... sem ter que copiar o mesmo código... fazer um loop de tudo isso abaixo, 32 vezes... tem algum comando pra fazer isso?! Obrigado desde já!
algoritmo "Tabuada ate 32x"
// Função : Apresentar tabuada do 8 até 32x
// Autor : Nobru
// Data : 25/05/2015
// Seção de Declarações
var
CONT, TAB, NUM: INTEIRO
inicio
CONT <- 0
NUM <- 0
ESCREVAL ("TABUADA DO 8")
PARA NUM de 0 ate 10 faca
ESCREVAL (NUM, " X ", "8 ", " = ", NUM*8)
cont <- cont+1
fimrepita
FIMPARA
fimalgoritmo
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Bem se o seu objetivo era apenas imprimir o LOOP 32 vezes esta a solução,

Fiz apenas um outro loop antes do que você já tinha feito.

VAR
NUM,VEZES: INTEIRO
INICIO
NUM <- 0
VEZES <- 0
PARA VEZES DE 1 ATE 32 FACA
ESCREVAL ("VOLTA NUMERO ", VEZES)
PARA NUM de 0 ate 10 FACA
ESCREVAL (NUM, " X ", "8 ", " = ", NUM*8)
FIMPARA
ESCREVAL ("------------------------------")
FIMPARA
FIMALGORITMO
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.8k
    • Total Posts
      646.6k
×
×
  • Create New...