Jump to content
Fórum Script Brasil
  • 0

Exercícios Resolvidos - Certo ou Errado?!


Tiagosr1
 Share

Question

Boa noite Srs.

Meu nome é Tiago Rodrigues, tenho 23 anos e sou de Criciúma - SC. Sou apaixonado por jogos e meu foco é aprender algumas linguagens da programação para utiliza-las futuramente e ingressar nessa área de difícil acesso no Brasil. Quero aprender C/C++/Java. 
No momento, diante algumas pesquisas e orientações, decidi começar do início e estudar Lógica de programação, Algoritmos e Estrutura de dados. Como todo leigo na área estou tendo dificuldades no início e sei que nem comecei ainda uma linguagem, mas faz parte do aprendizado e com meu esforço quero conseguir vencer as dificuldades. Contando um pouco do meu foco para meu futuro, quero disponibilizar abaixo os exercícios que vou fazendo e pedir aos senhores que tem conhecimento na área, para que me ajudem na correção dos exercício. Não preciso da solução pronta, só gostaria de um feedback de quem domina o conteúdo para ver se meus resultados estão CERTOS ou ERRADOS. Acredito que também vai ajudar os leigos e iniciantes da área que procuram como base exercícios e conteúdo a respeito.
Então é isso, quem conseguir corrigir meus exercícios somente com um feedback de CORRETO ou ERRADO e me informando qual é a questão, eu agradeço.

Abaixo segue minhas respostas para os exercícios:
 
1) Crie uma sequencia lógica para tomar banho:
• Início
• Pegar a roupa
• Seguir até o banheiro
• Abrir a porta do banheiro
• Entrar no banheiro
• Fechar a porta do banheiro
• Colocar a roupa limpa estendida
• Tirar a roupa
• Abrir o box
• Entrar no box
• Fechar o box
• Abrir o chuveiro
• Se molhar
• Se ensaboar
• Se enxaguar
• Fechar o chuveiro
• Abrir o box
• Pegar a toalha
• Se secar
• Sair do box
• Fechar o box
• Vestir a roupa limpa
• Pegar a roupa suja 
• Abrir a porta
• Colocar a roupa suja para lavar
• Fechar a porta
• Fim
 
2) Faça um algoritmo para somar dois números e multiplicar o resultado pelo primeiro número
Resultadosoma = numero1 + numero2
Resultadomulti  = resultadosoma * numero1
 
3) Descreva sequencia lógica para trocar o pneu do carro:
• INÍCIO  // caso você for o motorista 
• Ligar o pisca-alerta
• Estacionar o carro
• Desligar o carro
• Retirar o cinto
• Pegar a chave
• Abrir a porta do motorista
• Fechar a porta do motorista
• Abrir o porta-malas
• Pegar o triangulo
• Colocar o triangulo a uma distancia segura
• Voltar para o carro e virar a chave na ignição para que fique acesso o pisca-alerta
• Ir até o porta-malas
• Pegar o pneu (STEP) 
• Pegar o macaco
• Utilizar o macaco para deixar o carro suspenso
• Pegar a chave
• Tirar os parafusos da roda
• Retirar o pneu usado
• Colocar o pneu novo (STEP)
• Pegar os parafusos
• Pegar a chave
• Parafusar os parafusos
• Pegar a chave
• Pegar o pneu usado
• Ir até o porta-malas
• Guardar o pneu usado
• Guardar a chave que utilizou para apertar os parafusos
• Retirar e guardar o triangulo
• Fechar o porta-malas
• Abrir a porta do motorista
• Entrar no carro
• Fechar a porta do motorista
• Colocar o sinto
• Ligar o carro
• Desligar o pisca alerta
• Dar seta para sair
• FIM
 
4) Faça um algoritmo para trocar uma lâmpada. Descreva com detalhes:
 
• INÍCIO
• Ir ao supermercado mais próximo
• Comprar uma lâmpada
• Voltar para o local onde a lâmpada deve ser trocada
• Colocar a lâmpada nova em local seguro
• Desligar a chave-geral (ENERGIA)
• Pegar uma escada 
• Fixar a escada no local da troca
• Subir na escada
• Retirar a lâmpada usada
• Descer a escada
• Colocar a lâmpada usada em local seguro
• Pegar a lâmpada nova
• Subir a escada
• Colocar a lâmpada nova no bucal
• Descer a escada
• Ligar a chave-geral (ENERGIA)
• Testar e ver se funcionou a lâmpada nova
• Guarda a escada
• Descartar a lâmpada usada
• FIM
 
5) Identifique os dados de entrada, processamento e saída no algoritmo abaixo
•Receba código da peça
•Receba valor da peça
•Receba Quantidade de peças
•Calcule o valor total da peça (Quantidade * Valor da peça)
•Mostre o código da peça e seu valor total
 
• Dados de entrada – Receba código da peça, Receba valor da peça, Receba quantidade de peças.
• Processamento – Calcule o valor total da peça (Quantidade * Valor da peça).
• Dados de saída – Mostre o código da peça e seu valor.
 
6) Faça um algoritmo para “Calcular o estoque médio de uma peça”, sendo que
ESTOQUEMÉDIO = (QUANTIDADE MÍNIMA + QUANTIDADE MÁXIMA) /2
 
Dados de entrada –
 Quantidade mínima (30)
Quantidade máxima (100)
 
Processamento – 
EstoqueMedio = Quantidade mínima (30) + quantidade máxima (100) / 2
 
Dados de saída –
Estoque médio = 65
 
7) Teste o algoritmo anterior com dados definidos por você.
 
Quantidade mínima    Quantidade máxima   Estoque Médio
              30                                100                         65
 
Por enquanto são esses os exercícios, provavelmente vou atualizando a lista diária ou sempre que obtiver novos exercícios resolvidos por mim. Agradeço a participação e a colaboração de todos.
 
Abraços!
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Um algoritmo deve ser detalhado o maximo possivel ...porque depois que for convertido na linguagem de programação, poderá não funcionar como esperado.  O uso de algoritmo serve apenas para treinar a lógica de programação

exemplo

 

1) Crie uma sequencia lógica para tomar banho:
• Início
• Pegar a roupa
• Seguir até o banheiro
• Abrir a porta do banheiro
• Entrar no banheiro
• Fechar a porta do banheiro
• Colocar a roupa limpa estendida
• Tirar a roupa
• Abrir o box
• Entrar no box
• Fechar o box
• Abrir o chuveiro
       Se tem agua ....(• Se molhar • Se ensaboar • Se enxaguar • Fechar o chuveiro )
       Se não tem agua .... (• Fechar o chuveiro )
• Abrir o box
• Pegar a toalha
• Se secar
• Sair do box
• Fechar o box
• Vestir a roupa limpa
• Pegar a roupa suja 
• Abrir a porta
• Colocar a roupa suja para lavar
• Fechar a porta
• Fim
 
OBS: outros detalhes podem surgir ...
por exemplo:
 
se tem agua, mas o chuveiro não esquenta
 
se não tem agua ... vai para a etapa Sair do Box
 
se não tomou o banho, porque trocar de roupa
 
em termos de programação, o algoritmo ajuda a nortear o rumo que voce deve seguir, mas depois de algum tempo já não será mais necessario o seu uso...sendo então substituido pela lógica de programação.
 
na pratica vai valer mais o conhecimento dos comandos da linguagem  e de como utiliza-los
 
voce está no caminho correto....  basta apenas ter força de vontade, estudar muito, praticar sempre e ter paciencia
 
abraço
 
 
 
Link to comment
Share on other sites

  • 0

Um algoritmo deve ser detalhado o maximo possivel ...porque depois que for convertido na linguagem de programação, poderá não funcionar como esperado.  O uso de algoritmo serve apenas para treinar a lógica de programação

exemplo

 

1) Crie uma sequencia lógica para tomar banho:
• Início
• Pegar a roupa
• Seguir até o banheiro
• Abrir a porta do banheiro
• Entrar no banheiro
• Fechar a porta do banheiro
• Colocar a roupa limpa estendida
• Tirar a roupa
• Abrir o box
• Entrar no box
• Fechar o box
• Abrir o chuveiro
       Se tem agua ....(• Se molhar • Se ensaboar • Se enxaguar • Fechar o chuveiro )
       Se não tem agua .... (• Fechar o chuveiro )
• Abrir o box
• Pegar a toalha
• Se secar
• Sair do box
• Fechar o box
• Vestir a roupa limpa
• Pegar a roupa suja 
• Abrir a porta
• Colocar a roupa suja para lavar
• Fechar a porta
• Fim
 
OBS: outros detalhes podem surgir ...
por exemplo:
 
se tem agua, mas o chuveiro não esquenta
 
se não tem agua ... vai para a etapa Sair do Box
 
se não tomou o banho, porque trocar de roupa
 
em termos de programação, o algoritmo ajuda a nortear o rumo que voce deve seguir, mas depois de algum tempo já não será mais necessario o seu uso...sendo então substituido pela lógica de programação.
 
na pratica vai valer mais o conhecimento dos comandos da linguagem  e de como utiliza-los
 
voce está no caminho correto....  basta apenas ter força de vontade, estudar muito, praticar sempre e ter paciencia
 
abraço
 
 
 

Jhonas, Boa noite!

 Muito obrigado pelas dicas! são de grande valia para mim. Consegui compreender o que você quis me passar e achei bem interessante. É fantástico e enorme as probabilidades que aparecem de opções para se fazer enquanto paramos para criar um algoritmo, uma sequencia lógica. É bem como você falou "detalhes podem surgir" e vão surgir, e isso me deixa muito animado. Gostaria de compartilhar um acontecimento, Hoje pela manhã estava estudando um pouco de algoritmos e lógica de programação e utilizando um pouco da linguagem do Portugol. Ai me veio na cabeça "Vou tentar utilizar algumas variáveis simples aqui para criar algum utilitário e ver como ficaria (isso pelo visualg). Ai fiz ali algo muito simples como por exemplo:
VAR
peso, altura: real
inicio

  ai fiz um simples comando escreval (" Qual sua altura?")

                                            leia (altura)

                                           escreval ("qual seu peso")

                                             leia (peso)

 

Mandei executar, e como todo iniciante e leigo no assunto, achei aquilo ali muito legal, porque eu sempre gostei da programação e nunca tinha tirado um tempo para estudar e me focar no que eu realmente queria. Ai enviei isso para minha mulher, e ela muito carinhosa "ah mor, que legal", eu agradeci tal e ela para mim "mor, por que tu não faz um programinha para calcular o IMC de uma pessoa?" eu pensei comigo "ótimo, meu conhecimento é pouco, mas posso tentar" e comecei a quebrar a cabeça, peguei as formulas para calculo do que eu iria precisar e fui fazendo. Comecei a fazer era em torno das 09:00hs da manhã, fui terminar esse script era 17:30HS de hoje auhaeuhae. Tive bastante complicação, bastante entrave, mas eu tenho comigo que isso é extremamente normal no início. Resumindo, consegui concluir o que minha mulher me pediu, ela até me deu opinião e me ajudou e fiquei muito satisfeito com o resultado. Não deve ser a melhor forma de se fazer um calculo de IMC e o peso ideal para sua altura, mas foi o que consegui com meu conhecimento e esforço. E agora que você citou o "vão aparecer alguns detalhes" re-vendo meu "programinha" eu sei que tem muitos detalhes que apareceram, e com sua sugestão eu vou corrigir e ir atualizando detalhe por detalhe. Afinal, isso que é programação, não? Obrigado por dispor alguns minutos do seu tempo e da sua atenção para me responder neste tópico. Espero sempre atualizar esse meu tópico para quem sabe conseguir ajudar quem um dia for iniciar na área da programação. É só o inicio? é.. mas um dia chegamos lá! Abraço e fiquem com Deus! Ahh, e vou deixar aqui meu algoritmo para quem quiser ver (mas sem rir do que fiz em hehehe).

 

algoritmo "Cálculo IMC"
// Disciplina: [Linguagem e Lógica de Programação]
// Professor(a): Antonio Carlos Nicolodi
// Criador : Tiago dos Santos Rodrigues
// Iniciante em programação
// Criado em: 27/08/2015
// Objetivo: Calcular o peso ideal conforme altura e o IMC (Índice de massa corporal)

var
   imc, peso, r, h: real
   nome, sexo: caractere

inicio
   escreval ("Olá, este utilitário serve para você calcular seu IMC (Índice de massa corporal).")
   escreval ("Para iniciarmos preciso saber se você é do sexo (Masculino) ou (Feminino): Pois as tabelas são diferenciadas para ambos, digite Masculino ou Feminino:")
   leia(sexo)

   escreval
   escreval ("Ótimo, estamos quase lá! Por gentileza, qual é o seu nome?")
   leia (nome)

   escreval
   escreval ("Ah, um belo nome, muito prazer " ,Nome,"! Qual é o seu peso atual em quilogramas?")
   leia(peso)

   escreval
   escreval ("Ótimo, agora me diga qual é a sua altura em metros " ,Nome, "?")
   leia(h)
   escreval
   imc <- peso/ (h*h)
   escreval ("Muito obrigado(a) pela sua paciência " ,Nome, "! Seu IMC é de" ,imc)

   escreval
   se (imc < 19.1) entao
      escreval (" Você é considerado(a) uma pessoa: abaixo do peso (Procure um nutricionista) ")
   fimse

   se sexo = "feminino" entao
      r<-32*h
      Escreval("Seu peso mínimo ideal é: ",r)
      escreval ("Você está" ,peso-r, "KG acima do peso minimo.")
      escreval (" ATENÇÃO: Estes valores são aproximado, consulte um profissional para lhe auxiliar melhor.")
   fimse

   escreval
   se sexo = "feminino" entao
      r<-43*h
      Escreval("Seu peso máximo ideal é: ",r)
      escreval ("Você está" ,peso-r, "KG acima do peso máximo.")
      escreval (" ATENÇÃO: Estes valores são aproximado, consulte um profissional para lhe auxiliar melhor.")
   fimse

   se sexo = "masculino" entao
      r<-38*h
      Escreval("Seu peso mínimo ideal é: ",r)
      escreval ("Você está" ,peso-r, "KG acima do peso mínimo.")
      escreval (" ATENÇÃO: Estes valores são aproximado, consulte um profissional para lhe auxiliar melhor.")
   fimse

   se sexo = "masculino" entao
      r<-41.9*h
      escreval ("Seu peso máximo ideal é: ",r)
      escreval ("Você está" ,peso-r, "KG acima do peso máximo.")
      escreval (" ATENÇÃO: Estes valores são aproximado, consulte um profissional para lhe auxiliar melhor.")
   fimse

   se (imc  >= 19.1) e ( imc <= 25.8) entao
      escreval (" Você é considerado(a) uma pessoa com: peso normal (Parabéns) ")
   fimse

   escreval
   se (imc >= 25.8) e (imc <= 27.3) entao
      escreval ("Você é considerado(a) uma pessoa: marginalmente acima do peso (Procure praticar exercícios)")
   fimse

   escreval
   se (imc>= 27.3) e (imc <= 32.3) entao
      escreval (" Você é considerado(a) uma pessoa: acima do peso ideal (Procure praticar exercícios)")
   fimse

   escreval
   Se (imc > 32.3) entao
      escreval (" Você é considerado(a) uma pessoa: obeso(a) (Procure um nutricionista)")
   fimse

fimalgoritmo

Esse processo foi todo feito por mim, sem consultar e seguir passos de ninguém. Você também consegue, é só tentar! não é muita coisa, mas para mim que estou começando é um grande passo. Abraço pessoal!

Link to comment
Share on other sites

  • 0

amigo, não perca nunca essa vontade de aprender... e um dia voce vai poder dizer: sou bom nesse negocio !

e uma coisa que aprendi nesses anos todos de programação... a pratica leva a perfeição e o conhecimento abre muitas portas

abraço

Link to comment
Share on other sites

  • 0
Em 27 de agosto de 2015 at 01:30, Tiagosr1 disse:

Jhonas, Boa noite!

 Muito obrigado pelas dicas! são de grande valia para mim. Consegui compreender o que você quis me passar e achei bem interessante. É fantástico e enorme as probabilidades que aparecem de opções para se fazer enquanto paramos para criar um algoritmo, uma sequencia lógica. É bem como você falou "detalhes podem surgir" e vão surgir, e isso me deixa muito animado. Gostaria de compartilhar um acontecimento, Hoje pela manhã estava estudando um pouco de algoritmos e lógica de programação e utilizando um pouco da linguagem do Portugol. Ai me veio na cabeça "Vou tentar utilizar algumas variáveis simples aqui para criar algum utilitário e ver como ficaria (isso pelo visualg). Ai fiz ali algo muito simples como por exemplo:
VAR
peso, altura: real
inicio

  ai fiz um simples comando escreval (" Qual sua altura?")

                                            leia (altura)

                                           escreval ("qual seu peso")

                                             leia (peso)

 

Mandei executar, e como todo iniciante e leigo no assunto, achei aquilo ali muito legal, porque eu sempre gostei da programação e nunca tinha tirado um tempo para estudar e me focar no que eu realmente queria. Ai enviei isso para minha mulher, e ela muito carinhosa "ah mor, que legal", eu agradeci tal e ela para mim "mor, por que tu não faz um programinha para calcular o IMC de uma pessoa?" eu pensei comigo "ótimo, meu conhecimento é pouco, mas posso tentar" e comecei a quebrar a cabeça, peguei as formulas para calculo do que eu iria precisar e fui fazendo. Comecei a fazer era em torno das 09:00hs da manhã, fui terminar esse script era 17:30HS de hoje auhaeuhae. Tive bastante complicação, bastante entrave, mas eu tenho comigo que isso é extremamente normal no início. Resumindo, consegui concluir o que minha mulher me pediu, ela até me deu opinião e me ajudou e fiquei muito satisfeito com o resultado. Não deve ser a melhor forma de se fazer um calculo de IMC e o peso ideal para sua altura, mas foi o que consegui com meu conhecimento e esforço. E agora que você citou o "vão aparecer alguns detalhes" re-vendo meu "programinha" eu sei que tem muitos detalhes que apareceram, e com sua sugestão eu vou corrigir e ir atualizando detalhe por detalhe. Afinal, isso que é programação, não? Obrigado por dispor alguns minutos do seu tempo e da sua atenção para me responder neste tópico. Espero sempre atualizar esse meu tópico para quem sabe conseguir ajudar quem um dia for iniciar na área da programação. É só o inicio? é.. mas um dia chegamos lá! Abraço e fiquem com Deus! Ahh, e vou deixar aqui meu algoritmo para quem quiser ver (mas sem rir do que fiz em hehehe).

 

algoritmo "Cálculo IMC"
// Disciplina: [Linguagem e Lógica de Programação]
// Professor(a): Antonio Carlos Nicolodi
// Criador : Tiago dos Santos Rodrigues
// Iniciante em programação
// Criado em: 27/08/2015
// Objetivo: Calcular o peso ideal conforme altura e o IMC (Índice de massa corporal)

var
   imc, peso, r, h: real
   nome, sexo: caractere

inicio
   escreval ("Olá, este utilitário serve para você calcular seu IMC (Índice de massa corporal).")
   escreval ("Para iniciarmos preciso saber se você é do sexo (Masculino) ou (Feminino): Pois as tabelas são diferenciadas para ambos, digite Masculino ou Feminino:")
   leia(sexo)

   escreval
   escreval ("Ótimo, estamos quase lá! Por gentileza, qual é o seu nome?")
   leia (nome)

   escreval
   escreval ("Ah, um belo nome, muito prazer " ,Nome,"! Qual é o seu peso atual em quilogramas?")
   leia(peso)

   escreval
   escreval ("Ótimo, agora me diga qual é a sua altura em metros " ,Nome, "?")
   leia(h)
   escreval
   imc <- peso/ (h*h)
   escreval ("Muito obrigado(a) pela sua paciência " ,Nome, "! Seu IMC é de" ,imc)

   escreval
   se (imc < 19.1) entao
      escreval (" Você é considerado(a) uma pessoa: abaixo do peso (Procure um nutricionista) ")
   fimse

   se sexo = "feminino" entao
      r<-32*h
      Escreval("Seu peso mínimo ideal é: ",r)
      escreval ("Você está" ,peso-r, "KG acima do peso minimo.")
      escreval (" ATENÇÃO: Estes valores são aproximado, consulte um profissional para lhe auxiliar melhor.")
   fimse

   escreval
   se sexo = "feminino" entao
      r<-43*h
      Escreval("Seu peso máximo ideal é: ",r)
      escreval ("Você está" ,peso-r, "KG acima do peso máximo.")
      escreval (" ATENÇÃO: Estes valores são aproximado, consulte um profissional para lhe auxiliar melhor.")
   fimse

   se sexo = "masculino" entao
      r<-38*h
      Escreval("Seu peso mínimo ideal é: ",r)
      escreval ("Você está" ,peso-r, "KG acima do peso mínimo.")
      escreval (" ATENÇÃO: Estes valores são aproximado, consulte um profissional para lhe auxiliar melhor.")
   fimse

   se sexo = "masculino" entao
      r<-41.9*h
      escreval ("Seu peso máximo ideal é: ",r)
      escreval ("Você está" ,peso-r, "KG acima do peso máximo.")
      escreval (" ATENÇÃO: Estes valores são aproximado, consulte um profissional para lhe auxiliar melhor.")
   fimse

   se (imc  >= 19.1) e ( imc <= 25.8) entao
      escreval (" Você é considerado(a) uma pessoa com: peso normal (Parabéns) ")
   fimse

   escreval
   se (imc >= 25.8) e (imc <= 27.3) entao
      escreval ("Você é considerado(a) uma pessoa: marginalmente acima do peso (Procure praticar exercícios)")
   fimse

   escreval
   se (imc>= 27.3) e (imc <= 32.3) entao
      escreval (" Você é considerado(a) uma pessoa: acima do peso ideal (Procure praticar exercícios)")
   fimse

   escreval
   Se (imc > 32.3) entao
      escreval (" Você é considerado(a) uma pessoa: obeso(a) (Procure um nutricionista)")
   fimse

fimalgoritmo

Esse processo foi todo feito por mim, sem consultar e seguir passos de ninguém. Você também consegue, é só tentar! não é muita coisa, mas para mim que estou começando é um grande passo. Abraço pessoal!

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...