Jump to content
Fórum Script Brasil
  • 0

Estrutura de repetição com vetores


Imguvoss
 Share

Question

Olá pessoal,

Eu preciso fazer um algoritmo no VisualG que leia um determinado número de notas e as organize-as de forma crescente, eu consegui elaborar o algoritmo, mais, no resultado ele aparece um 0, sendo que eu não digitei nenhum 0.

Exemplo:

Digitei: 9

           10

            2

 

No resultado aparece:  0

                                     2

                                     9

                                     10

 

O algoritmo está abaixo, obrigado.

Algoritmo "Obter notas e apresentar em ordem crescente"
Var

   aNotas: VETOR[1..50] DE INTEIRO
   I, J, Y, L, K, nNumero: INTEIRO

Inicio

   Escreva("Digite o número de notas que você deseja ordenar: ")
   Leia(nNumero)

   Para I De 1 Ate nNumero Passo 1 Faca
      Escreva("Digite a", I,"° nota: ")
      Leia(aNotas[I])
   Fimpara



   Para K De 1 Ate I-1 Faca
      Para J De 1 Ate nNumero Faca
         Se aNotas[J] > aNotas[J+1] Entao

            Y <- aNotas[J]
            aNotas[J] <- aNotas[J+1]
            aNotas[J+1] <- Y
         Fimse

      Fimpara

   Fimpara



   Para L De 1 Ate J Faca
      Escreval(aNotas[L])
   Fimpara

Fimalgoritmo

 

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...