Jump to content
Fórum Script Brasil
  • 0

matriz visualg


gabi faccioni
 Share

Question

alguém pode me ajudar corrigir erros?

 

algoritmo "MATRIZ 4 X 5"
// Função :  Dado uma Matriz de 4 x 5:
// Autor :  GABRIELA BORGES
// Data : 13/10/2015
// Seção de Declarações
var
M: VETOR [1..4,1..5] DE INTEIRO
//---------------------------------------
C, L, AUX, MINVERTIDA: INTEIRO
//---------------------------------------
SOMAL, SOMAC: VETOR  [1..4]DE INTEIRO
//---------------------------------------
VPAR, VIMPAR VETOR[1..50] DE INTEIRO
  VPARI, VIMPARI: INTEIRO
inicio


//1.    Escreva um Algoritmo que alimente esta matriz com valores randômicos até 20;
ESCREVAL( "|_________________________MATRIZES______________________|")
ESCREVAL("")
ESCREVAL (" MATRIZ 4 X 5:")
ESCREVAL("")
PARA L DE 1 ATE 4 FACA
   PARA C DE 1 ATE 5 FACA
      SE C=1 então
         ESCREVA ("|")
      FIMSE
      M[L,C]:= RANDI(50)
      ESCREVA (M[L,C]:3:0,"|")

   FIMPARA
   ESCREVAL("")
FIMPARA

//2.    Escreva um procedimento (Código) que ordene esta Matriz em Ordem Crescente

PARA  L DE 1 ATE 4 FACA
   PARA L1 DE 1 ATE 3 FACA
      SE M[L1] > M[L1+1] então
         AUX := M[L1]
         M[L1] := M[ L1+1]
         M[L1+1] := AUX
      FIMSE
   FIMPARA
FIMPARA
ESCREVAL("ORDENANDO...")
PARA L DE 1 ATE 4 FACA
   ESCREVAL("ORDENANDO LINHAS: [", L, "] = ", M[L])
FIMPARA

PARA  C DE 1 ATE 5 FACA
   PARA C1 DE 1 ATE 4 FACA
      SE M[C1] > M[C1+1] então
         AUX := M[C1]
         M[X] := M[ C1+1]
         M[C1+1] := AUX

      FIMSE
   FIMPARA
FIMPARA
ESCREVAL("ORDENANDO...")
PARA C DE 1 ATE 5 FACA
   ESCREVAL("ORDENANDO COLUNAS: [", C, "] = ", M[C])
FIMPARA


//3.    Escreva um procedimento que some as Colunas , e some as Linhas desta Matriz


PARA L DE 1 ATE 4 FACA
     PARA C DE 1 ATE 5 FACA
     SE C=1 então
     ESCREVA ("|")
     FIMSE
     SOMAL[L] := SOMAL[L] + M[L,C]
       SOMAC[C] := SOMAC[C] + M[L,C]
       ESCREVA (M[L,C]:3:0,"|")
       FIMPARA
        ESCREVAL (SOMAL[L]:3:0)
        ESCREVAL ("+___+___+___+___=___")
        FIMPARA
 PARA C DE 1 ATE 4 FACA
   SE C =1 então
   ESCREVA ("|")
   FIMSE
   ESCREVA (SOMAC[C]:3:0,"|")
   FIMPARA

//4.    Escreva um procedimento que A última posição será a primeira, a penúltima a segunda e assim sucessivamente.

PARA L DE 1 ATE 4 FACA
     PARA C DE 1 ATE 5 FACA
      LEIA (MINVERTIDA)
      M [L,C]:= MINVERTIDA
   FIMPARA
FIMPARA
L:= 4
PARA L DE 4 ATE 1 PASSO -1 FACA
   PARA C DE 1 ATE 5 FACA
   FIMPARA
    ESCREVAL (M [L,C])
FIMPARA

//5.    Crie 2 Vetores um para Valores Pares e Outro para Valores Impares, e alimente ele com os valores da Matriz,
//Valor par no Vetor Par, Valor Impar no Vetor Impar

ESCREVAL (" EXEMPLO DE MATRIZ:")
 ESCREVAL("")

 VPARI:= 1

PARA L DE 1 ATE 5 FACA
   PARA C DE 1 ATE 10 FACA
      M[L,C]:=RANDI(20)
      SE ((M[L,C] MOD 2) =0 ) então

      VPAR[VPARI] := M[L,C]
      VPARI := VPARI+1
      SENAO
      VIMPAR[VIMPARI] := M[L,C]
      VIMPARI:= VIMPARI+1
      ESCREVA ("|")
     FIMSE
   FIMPARA
         ESCREVA( VPAR :3:0,"|")
               ESCREVA( VIMPAR :3:0,"|")
FIMPARA

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Alguém poderia me ajudar na construção de um algoritmo ?

 

Faça um programa que preencha uma matriz 12 x 4 com os valores das vendas de uma loja, em que cada linha representa um mês do ano e cada coluna representa uma semana do mês. O programa deverá calcular e mostrar:

a) o total vendido em cada mês do ano, mostrando o nome do mês por extenso.

b) o total vendido em cada semana durante todo o ano;

c) o total vendido pela loja no ano.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...