Jump to content
Fórum Script Brasil
  • 0

Algoritmo


Kerlyane
 Share

Question

2 answers to this question

Recommended Posts

  • 0

Viva, 

Aqui vai:

algoritmo "numero_repeticao_21_12_2015.alg"
// Função :
//        Construa um algoritmo para entrar com um número de vezes que serão
//        repetido, encontre os números pares no intervalo de 1 até o
//        número digitado, mostre os números pares.
// Autor : ede
// Data : 12/21/2015
// Seção de Declarações 
var
numero, vezes_vector: inteiro
vet: vetor [1..100] de inteiro
inicio
// Seção de Comandos
escreval("Digite um número inteiro que será repetido o algoritmo:")
leia(numero)
//Ciclo para repetir até ao número definido pelo utilizador
repita
      //Encontrar os numero primos
      se (numero % 2) = 0 então
      //Iniciar o vetor
         vezes_vector <- vezes_vector + 1
      //Número pare
         vet[vezes_vector] <- numero
      fimse
      numero <- numero - 1
ate numero = 0
//Mostrar os números pares
repita
      escreval(vet[vezes_vector])
      vezes_vector <- vezes_vector - 1
ate vezes_vector = 0
fimalgoritmo

Diga se serve,

Bom códigos

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...