Jump to content
Fórum Script Brasil
  • 0

Ajuda Visualg - "CASO"


mgoncalv
 Share

Question

Galera,

mMeu problema é que as opções de casos não funcionam bem. Qualquer que seja o caso escolhido, o valor mostrado é sempre o discriminado para o primeiro caso. Alguém pode ajudar?

algoritmo "CRIANCAESPERANCA"
var
   D: Inteiro
   Valor: Real

inicio
      Escreval ("--------------------------")
      Escreval ("    CRIANCA ESPERANCA     ")
      Escreval ("--------------------------")
      Escreval ("   Obrigado por Ajudar!   ")
      Escreval ("--------------------------")
      Escreval ("         DIGITE:          ")
      Escreval ("   [1] Para doar R$ 10"    )
      Escreval ("   [2] Para doar R$ 25"    )
      Escreval ("   [3] Para doar R% 50"    )
      Escreval ("   [4] Para outros valores")
      Escreval ("   [5] Para cancelar"      )
      Escreval ("--------------------------")
      Escreva  ("   Escolha uma Opcao:"     )
      Leia (D)
      Escreval ("--------------------------")
      Escolha D
              Caso 1
                   Valor <- 10
              Caso 2
                   Valor <- 25
              Caso 3
                   Valor <- 50
              Caso 4
                   Escreval ("Qual o valor da doacao R$")
                   Leia (Valor)
              Caso 5
                   Valor <- 0
                   Escreval ("Mesmo assim muito obrigado")
      FimEscolha
      Escreval ("Sua doacao foi de R$ ",Valor, ".")
      Escreval ("    MUITO OBRIGADO!")
      Escreval ("--------------------------")
fimalgoritmo

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Em 08/11/2015 at 17:02, mgoncalv disse:

Galera,

mMeu problema é que as opções de casos não funcionam bem. Qualquer que seja o caso escolhido, o valor mostrado é sempre o discriminado para o primeiro caso. Alguém pode ajudar?

algoritmo "CRIANCAESPERANCA"
var
   D: Inteiro
   Valor: Real

inicio
      Escreval ("--------------------------")
      Escreval ("    CRIANCA ESPERANCA     ")
      Escreval ("--------------------------")
      Escreval ("   Obrigado por Ajudar!   ")
      Escreval ("--------------------------")
      Escreval ("         DIGITE:          ")
      Escreval ("   [1] Para doar R$ 10"    )
      Escreval ("   [2] Para doar R$ 25"    )
      Escreval ("   [3] Para doar R% 50"    )
      Escreval ("   [4] Para outros valores")
      Escreval ("   [5] Para cancelar"      )
      Escreval ("--------------------------")
      Escreva  ("   Escolha uma Opcao:"     )
      Leia (D)
      Escreval ("--------------------------")
      Escolha D
              Caso 1
                   Valor <- 10
              Caso 2
                   Valor <- 25
              Caso 3
                   Valor <- 50
              Caso 4
                   Escreval ("Qual o valor da doacao R$")
                   Leia (Valor)
              Caso 5
                   Valor <- 0
                   Escreval ("Mesmo assim muito obrigado")
      FimEscolha
      Escreval ("Sua doacao foi de R$ ",Valor, ".")
      Escreval ("    MUITO OBRIGADO!")
      Escreval ("--------------------------")
fimalgoritmo

Estou com o mesmo problema, você já conseguiu resolver esse código?

Link to comment
Share on other sites

  • 0

Amigo mgoncalv, esse código roda sem problema na versão 2.5 do visual, mas na versão 3 mostra somente o primeiro valor, mesmo digitando quaisquer uma das opções. Neste caso o problema é resolvido mudando a variável "D" para caractere e as opções de Valor você coloca entre aspas. Funciona muito bem.

 Mudança na variável

De:

Var
	D: Inteiro

Para:

Var
	D: Caracter

Mudança nos "Caso"

De:

Escolha D
              Caso 1
                   Valor <- 10
              Caso 2
                   Valor <- 25
              Caso 3
                   Valor <- 50
              Caso 4
                   Escreval ("Qual o valor da doacao R$")
                   Leia (Valor)
              Caso 5
                   Valor <- 0
                   Escreval ("Mesmo assim muito obrigado")
FimEscolha

Para:

Escolha D
              Caso "1"     // Coloque o numero entre as ASPAS
                   Valor <- 10
              Caso "2"
                   Valor <- 25
              Caso "3"
                   Valor <- 50
              Caso "4"
                   Escreval ("Qual o valor da doacao R$")
                   Leia (Valor)
              Caso "5"
                   Valor <- 0
                   Escreval ("Mesmo assim muito obrigado")
FimEscolha

 Teste e veja se funciona...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...