Moncor

Erro de tempo de execução do Microsoft VBScript erro '800a01a8'

Recommended Posts

Pessoal, tenho o seguinte código abaixo:

 

<%@ Language=VBScript %>
<!-- #include file="inc_variavel_copia_digital.asp" -->
<%
 
Response.Buffer = TRUE
Response.Clear
byteCount = Request.TotalBytes
RequestBin = Request.BinaryRead(byteCount)
Dim UploadRequest
Set UploadRequest = CreateObject("Scripting.Dictionary")
'Response.Write Request.ServerVariables("PATH_INFO")
'Response.end
 
BuildUploadRequest  RequestBin
 
contentType = UploadRequest.Item("txtArquivo1").Item("ContentType")  -> linha de erro
filepathname = UploadRequest.Item("txtArquivo1").Item("FileName") 
filename = Right(filepathname,Len(filepathname)-InstrRev(filepathname,"\")) 
filename = Replace(filename,".","_"& rndit &".") 
value = UploadRequest.Item("txtArquivo1").Item("Value")
 
 
Mensagem de erro:

Erro de tempo de execução do Microsoft VBScript erro '800a01a8'

Objeto necessário: '[undefined]'

/COPIADIGITAL/upload/upload_efetiva.asp, linha 16

 
 
E não consigo identificar o porque está acontecendo esse erro, pois sempre funcionou essa página asp, mais a partir dessa semana parou.
 
Se puderem ajudar eu agradeço.

Share this post


Link to post
Share on other sites

Estou com o mesmo problema, já reinstalei o IIS e tudo mais, aparentemente ocorreu depois de uma atualização do Windows, o que esta prejudicando muito o meu trabalho ;(

Se alguém puder ajudar serei muito grato. Continuo tentando aqui!

Share this post


Link to post
Share on other sites

Hicaro, bom dia.

 

O meu problema foi exatamente isso, depois da atualização ferrou tudo.

Vou fazer essa rotina de uma outra forma, pois preciso corrigir isso o mais rápido possível.

Se acaso achar alguma solução, me avise por favor.

Vlw.

Share this post


Link to post
Share on other sites

Então Moncor Bom dia!

No meu caso é mais complicado pois tenho isso em muitos locais, que problemão..

Poderia me dizer se utiliza o Antivírus Avira, estou desconfiado dele também...

Cheguei a testar o código original e nele também apresenta o mesmo problema

http://www.nerdbb.com/asp-como-fazer-upload-sem-componentes-t53464.html

Pode ser um problema com o recurso "Scripting.Dictionary" não encontrei como atualizar ou reinstalar isso.

Estou pensando em formatar a máquina e banir atualizações, Microsoft e suas decepções ;(

Share this post


Link to post
Share on other sites

Esse server não tem anti virús. 

O que ferrou mesmo, foi a atualização do Windows. Estou quase voltando essas paths de atualização para ver se resolve.

Moncor.

Share this post


Link to post
Share on other sites

Conseguiu identificar qual foi a atualização? qual dia aconteceu?

As minhas ultimas foram em novembro, tentei desinstalar mas o Windows não permitiu,

Se conseguir me avisa pls!

Edited by hicarocastro

Share this post


Link to post
Share on other sites

Boa tarde Moncor,

Esse problema seu esta num servidor online? pois isso que me ta me intrigando ainda mais.

O erro só esta ocorrendo nas minhas máquinas do escritório, no servidor online funciona bem, será que eles ainda não foram atualizados?

 

Share this post


Link to post
Share on other sites

Boa tarde, Hicaro.

No meu caso nem no servidor está funcionando. 

Já tentei ver se era o IIS, já fiz de tudo, mais o problema ainda persiste.

 

Lucas.

Share this post


Link to post
Share on other sites

Pois Lucas, mesmo caso que o meu.

Eu já havia reinstalado o IIS neste momento também sem sucesso!

Neste momento terminei de reinstalar o Framework 4.5, imaginando conseguir afetar o componente "Scripting.Dictionary" no entanto foi mais uma vez sem sucesso, vamos trabalhar nisso juntos, vai passando as suas tentativas e suspeitas por aqui, ficarei logado.

Precisava solucionar isso hoje.

 

Já tentei desativar o Firewall do Windows também, mas nada faz funcionar!

Share this post


Link to post
Share on other sites

Hicaro, boa tarde.

O link do servidor caiu e pedi para o pessoal de TI verificar. Assim que voltar acessarei o servidor novamente para tentar solucionar isso.

Se tiver a solução pode deixar que te aviso.

Lucas.

Share this post


Link to post
Share on other sites

Ok, se puder verifique em seu Windows Update se tem alguma atualização apresentando erro.

Tenho 2 maquinas com o IIS configurado, uma com Windows 7 e outra com Windows 10 atualizado, ambas estão com problema.

Esse servidor seu é 64bits?

Share this post


Link to post
Share on other sites

Meu querido passei a bola no fórum da Microsoft, se puder interagir enriquecendo o conteúdo com outras informações eu agradeço muito.

http://answers.microsoft.com/pt-br/windows/forum/windows_7-networking/erro-de-tempo-de-execu%C3%A7%C3%A3o-do-microsoft/b5a455f6-90cb-4692-946c-4037eebdc67d?tm=1450198030738

Share this post


Link to post
Share on other sites

Wagner bom dia!

Eu não tenho palavras para lhe agradecer, que Deus possa retribuir o que não posso, deu muito certo, isso estava me gerando um transtorno grande.

Um maravilhoso natal pra voce e sua família, pra você também Lucas!!!

E assim seguimos a vida em frente, parei por uma semana, muita gratidão amigo, deixemos o tópico aberto e vivo, pois creio que muitos virão aqui ainda!!!

Share this post


Link to post
Share on other sites

Voltou a dar problema agora.. aconteceu ai pra você também Lucas?

Como bloquear a atualização para que ela não volte?

Share this post


Link to post
Share on other sites

Pessoal, o problema realmente é com o KB3104002, a Microsoft já disponibilizou hotfix para corrigir, o link é

https://support.microsoft.com/en-us/kb/3104002

Na verdade esse link, para ser mais específico:

https://support.microsoft.com/en-us/kb/3125446

Estava com o mesmo problema em um Windows 2012, instalei o hotfix, reiniciei e funcionou.

Edited by franklinjr

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.