Jump to content
Fórum Script Brasil
  • 0

Dúvidas sobre Visualg


flvferna
 Share

Question

Olá a todos, sou novo aqui no fórum e na logica de programação. Gostaria de saber se existe a possibilidade de:

Olhem o exemplo:

Escreva ("Digite um conjunto de números: ")

Leia (a, b, c, d)

Quero que ao digitar: 

Ex: 1234

A <- 1

B <- 2

C <- 3

D <- 4

Desde já agradeço a força.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Por gentileza alguém sabe onde está o erro deste código? Ele retorna somente o valor 10 mesmo eu digitando quaisquer das opções de 1 à 5.

algoritmo "Crianca-Esperanca"
var
   D: Inteiro
   Valor: Real

inicio
      EscrevaL ("-------------------------")
      EscrevaL ("    CRIANÇA ESPERANÇA    ")
      EscrevaL ("-------------------------")
      EscrevaL ("Muito obrigado por ajudar")
      EscrevaL (" [1] para doar R$ 10,00")
      EscrevaL (" [2] para doar R$ 25,00")
      EscrevaL (" [3] para doar R$ 50,00")
      EscrevaL (" [4] para outros valores")
      EscrevaL (" [5] para cancelar")
      Escreva ("Digite uma opção acima: ")
      Leia (D)
      Escolha D
              Caso 1
                   Valor <- 10
              Caso 2
                   Valor <- 25
              Caso 3
                   Valor <- 50
              Caso 4
                   Escreva ("Qual o valor para doação? R$:")
                   Leia (Valor)
              Caso 5
                   Valor <- 0
      FimEscolha
      EscrevaL ("-------------------------------")
      EscrevaL ("SUA DOAÇÃO FOI DE R$: ",Valor)
      EscrevaL ("MUITO OBRIGADO!")
      EscrevaL ("-------------------------------")

fimalgoritmo

  Código resolvido, veja esta postagem: https://www.scriptbrasil.com.br/forum/topic/181217-ajuda-visualg-caso/

 

Edited by aguimarsp
Resolvi o código...
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...