Jump to content
Fórum Script Brasil
  • 0

POR FAVOR ME AJUDEM DESENVOLVER ESSE ALGORITMO (VISUALG)


Felipe_Sena
 Share

Question

Uma pesquisa sobre algumas características físicas da população de uma determinada região, coletou os seguintes dados, referente a cada habitante para serem analisados.
a. Sexo {M ou F} Masculino ou Feminino
b. Idade;
c. Cor dos olhos (A/ V/ C) – Azul, verde ou castanho;
Fazer um programa que leia os dados coletados para cada habitante e quando for digitada uma idade = -1, finalize o programa e escreva o seguinte relatório :
a) Quantidade de habitantes que possuem olhos azuis ou verdes;
b) Quantidade de mulheres com idade superior a 20 anos;
c) Sexo e idade do habitante mais velho;
d) Sexo e idade do habitante mais novo;
e) Diferença entre habitantes do sexo F com masculino;

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Inicio

[Declaração de variáveis]

sexo,sexmaior,sexmenor, olhos = caractere;

qntolhos, qnt20, idade1, idade2,idade3 idmaior, idmenos = inteiro;

[Declaração de Consantes]

FLAG = -1  

[Leitura / Processamento]

escreva ("Entre com a idade: ")

leia (idade1)

enquanto idade1 != FLAG faça

se (idade > 20) e (sexo = F) então

      qnt20 <- qnt20 + 1

     fim-se

   escreva("Entre com o sexo, M = masculino, F = feminino")

   leia(sexo)

 se idade1 > idade 2

     idmaior <- idade1

     sexmaior <- sexo

       senao

        idamaior <- idade2

        sexmaior <- sexo

    fim-se     

se idade3 < idade1

     idmenor <- idade3

     sexmenor <- sexo

       senao

        idamenor <- idade1

        sexmenor <- sexo

    fim-se     

   escreva ("Entre com a cor dos olhos, A = azul, V = Verde, C = Castanho")

   leia(olhos)

     se (olhos = azuis) ou (olhos = verdes) então

      qntolhos <- qntolhos + 1

     fim-se

idade2 <- idade1

idade3 <- idade1

fim-enquanto

[Resultado]

escreva ("Quantidade de habitantes que possuem olhos azuis ou verdes é :", qntolhos)

escreva ("Quantidade de mulheres com idade superior a 20 anos é: ", qnt20)

escreva ("Sexo e idade do habitante mais velho: "sexmaior, idmaior)

escreva ("Sexo e idade do habitante mais novo: "sexmenor, idmenor)

escreva ("Diferença entre habitantes do sexo F com masculino, são a cor dos olhos e o sexo em si ;D ou a idade")

fim

// Valeu espero ter ajudado.

Edited by Paoru
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...