Jump to content
Fórum Script Brasil
  • 0

Formula na macro que escreve formula no excel


Israel pelizzari
 Share

Question

Olá,

tenho a seguinte formula no excel, =SE(INDIRETO(CONCATENAR("'Dia";TEXTO(A4;"d");"'!$C$36"))=0;"";1), como faço para esceve-la na macro.

Já sei que o indireto concatenar não funciona dentro da macro, então não dá apenas para coloca-la dentro de aspas, então numa formula que somente escreve um link eu coloquei "& qualquer coisa  &", isso soma pedaços que se executa na macro com parte de texto que será escrito na célula do excel, mas no caso de formulas do excell o negócio complica. tentei a seguinte formula, "=SE(Dia"& e &"!$C$36")=0;"";1", Não funcionou.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Forum Statistics

    • Total Topics
      149.6k
    • Total Posts
      646.2k
×
×
  • Create New...