Jump to content
Fórum Script Brasil
  • 0

Digitar uma frase, e o programa contar quantas letras A existem?


gabisc
 Share

Question

Eu fiz, porém não sei qual o que fazer para ele contar quantas letras A possuem na frase que o usuário digitou.

algoritmo "palavraoufrase"
// Função :
// Autor :
// Data : 09/05/2016
// Seção de Declarações 
var
        palavrafrase: caracter
        a: caracter
        palavra: real
inicio
 escreva ("Digite uma palavra ou uma frase.")
 leia (palavrafrase)
 se ( palavrafrase = a) então
 escreva (" Contém", compr(palavrafrase))
 senao
 escreva ("não contém letras A")

fimalgoritmo

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Fala Gabisc, para isso você deve criar uma vriável que servirá como contadora para as palavras com a, e um vetor para fazer uma verificação dos caracteres (letras) da palavra.

ex:

var

        vetpala: vetor(5) de caracter

        contA, I: inteiro
inicio

para  I = 1 até 5 faça

escreva ("Digite uma palavra com 5 letras.")

// digite letra por letra
 leia (vetpala(I))
 se vetpala(I) = a então
  contA <- contA +1
 senao
 escreva ("não contém letras A")

fim-para

escreva("A quantidade de letras a é : '', contA)

fimalgoritmo

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      149.9k
    • Total Posts
      646.8k
×
×
  • Create New...