Jump to content
Fórum Script Brasil
  • 0

Duvida enviar mensagem webbrowser.


alexborges1
 Share

Question

Bom dia companheiros, estou com uma dúvida a alguns dias e não consigo resolver, fiz um webbrowser pra acessar o bate papo da uol e mandar mensagens automaticamente(um boot) mas estou enfrentando um problema, pois no botão enviar(enviar a mensagem) ele não envia o que escrevi no edit, e só envia se eu clicar no campo da mensagem dentro da página, sendo que também o campo já é preenchido pelo edit...  (lembrando que esse código funcionava perfeitamente com o modelo antigo das salas da uol, ai como mudaram o modelo das salas agora estou com esse problema...) se alguém poder me ajudar ficarei muito grato.

segue abaixo o código do meu botão enviar...

    webbrowser1.OleObject.Document.All.item('chatMessageSend').innerHTML := edit2.text;
    webbrowser1.OleObject.Document.All.item('chatMessageSend', 0).click;
    webbrowser1.OleObject.Document.All.item('sendBtn', 0).click

;

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

(lembrando que esse código funcionava perfeitamente com o modelo antigo das salas da uol, ai como mudaram o modelo das salas agora estou com esse problema...)

olhe no código da pagina e veja o que foi alterado .... talvez agora seja assim

SendChatMessage("text" [, "chatType" [, languageIndex [, "channel"]]])

o código do botão é esse
<input type="submit" value="Enviar" class="btEnviar" />

abraço

Link to comment
Share on other sites

  • 0

No campo que escreve a mensagem tem isso nas salas novas

<div id="chatMessageSend" data-joyride="data-joyride" ng-model="text" name="text" bp-textarea="bp-textarea" contenteditable="true" tabindex="1" class="ng-valid ng-dirty"></div>

e no botão enviar tem isso

<a id="sendBtn" ng-click="sendMsg()" send-msg="send-msg" tabindex="7" class="prefix button bold">Enviar</a>

Mas o que eu queria mostrar é que o código funciona, desde que eu clique dentro do campo da mensagem no webbrowser ai o botão que criei clica e envia a mensagem, Mas o problema é que assim não da pois o boot não vai ta clicando dentro do campo de mensagem da pagina pra poder enviar a mensagem, no modelo antigo funcionava perfeitamente, mas nesse novo ta complicado com isso impedindo do meu botão funcionar...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      149.9k
    • Total Posts
      646.8k
×
×
  • Create New...