Jump to content
Fórum Script Brasil
  • 0

Colar matriz de dados utilizando parâmetros diferentes


RafaelChow

Question

Boa dia!

Estou tentando criar um vba para inserir a função "=SEERRO(ÍNDICE(ATIVOS!$B:$I;CORRESP

(J$2&$F4;ATIVOS!$B:$B&ATIVOS!$C:$C;0);6);" ")" em um range de células, como na planilhas.

A questão é que o número de colunas é desconhecido, visto que o número de tipos de produtos financeiros podem variar dia após dia. Quanto a essa questão, posso criar um contador de colunas, até chegar no "Empty".

O mesmo vale para as linhas. Em cada linha há um cliente diferente. 

O grande diferencial de colocar essa fórmula em VBA é a questão do tempo de cálculo. Essa planilha demora uns 10, 12 min para ser calculada e ela é de uso diário (logo pela manhâ)

VBA.PNG

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152.1k
    • Total Posts
      652k
×
×
  • Create New...