• 0
Sign in to follow this  
Ueibson Santos

escolhendo pessoas

Question

Tou tendo problema com guarda na caixa er pra grava a quantidade de pessoas co certa idade mais so fica sempre a ultima

 

 

 

 

algoritmo "semnome"
var
   Sexo,C,A,M,F,Homens,h:Caractere
   Idade,B,B1:Inteiro
inicio
      C <- "S"
      Repita
            Escreva("Qual o sexo? [M/F] ")
            Leia(Sexo)
            Escreva("Qual a idade? ")
            Leia(Idade)
            EscrevaL("Qual a cor do cabelo")
            EscrevaL("-_-_-_-_-_-_-_-_-_-_")
            EscrevaL("|[1]Preto|")
            EscrevaL("|[2]Loiro|")
            EscrevaL("|[3]Ruivo|")
            EscrevaL("|[4]Castanho|")
            Leia(A)
            Escolha A
                    Caso "1"
                         EscrevaL("Quer continuar? [S/N]")
                         Leia(C)
                    Caso "2"
                         EscrevaL("Quer continuar? [S/N]")
                         Leia(C)
                    Caso "3"
                         EscrevaL("Quer continuar? [S/N]")
                         Leia(C)
                    Caso "4"
                         EscrevaL("Quer continuar? [S/N]")
                         Leia(C)
            FimEscolha
            LimpaTela
      Ate C = "N"
      EscrevaL("==============")
      EscrevaL("RESUTADO FINAL")
      EscrevaL("==============")
       Se (Idade > 18)então
         B <- B + 1
         Escolha Sexo
                 Caso "M"
                      M <- "CASTANHOS"
                        Escolha A
                                Caso "4"
                                EscrevaL("TOTAL DE HOMENS COM MAIS DE 18 ANOS DE CABELOS ",M," É ",B)
                                FimEscolha
                      FimEscolha
                 FimSe
           Se (Idade >= 25) e (Idade <= 30)então
              B1 <- B1 + 1
              Escolha Sexo
                          Caso "F"
                          F <- "LOIRIOS"
                          Escolha A
                          Caso "2"
                               EscrevaL("TOTAL DE MULHERES ENTRE 25 E 30 ANOS DE CABELOS ",F," É ",B1)
                               FimEscolha
                          FimEscolha

                      FimSe

fimalgoritmo
 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this