• 0
Sign in to follow this  
Patricia Carla

Algoritmo ´- Estrutura Enquanto

Question

Estou tentando escrever um algoritmo que pede ao usuário inserir os números e no final exiba qual foi o número maior e o número menor.

Só que o número menor sempre é exibido 0.

algoritmo "SomadorNumerico"
// Função :
// Autor :
// Data : 12/04/2018
// Seção de Declarações
var
cont, N, S, maior, menor: Inteiro
inicio
cont <- 1
S <-0
Enquanto (cont <= 5) faca
   Escreva (" Digite o", cont, "o. valor: ")
   Leia (N)
   Se (N > maior) então
      maior <- N
   Senao
      Se (N < menor) então
         menor <- N
      FimSe
   FimSe
   S <- S + N
   cont <- cont + 1
FimEnquanto
EscrevaL ("----------------------------------------")
EscrevaL (" A soma de todos os valores é: ", S)
EscrevaL (" O maior valor digitado foi: ", maior)
EscrevaL (" O menor valor digitado foi: ", menor)
EscrevaL ("----------------------------------------")
fimalgoritmo

 

Alguém pode me ajudar?

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Bom dia amigo,

Seria interessante você direcionar o primeiro valor digitado para as variáveis maior e menor, assim:

Já dentro do enquanto

se cont < 2 então 

maior <- N

menor <- N

Ai depois 

se N > maior

maior <- N

se N < menor

menor <- N

Não precisa do senão, pois a verificação do menor não depende da do maior. 

Qualquer duvida pode entrar em contato. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this