• 0
Sign in to follow this  
allanalencar

RESOLUÇÃO DE ALGORITMO PORTUGOL

Question

Boa noite.

 

Gostaria de apoio na resolução deste problema. Estou no início do curso e necessito de ajuda. Muito obrigado. Se possível passar a resolução para me auxiliar nos próximos. 

 

Para esta atividade MAPA queremos que você exercite o conteúdo que está sendo apresentado na disciplina. Sendo assim: Escreva um algoritmo que faça a entrevista de 20 pessoas.


Seu algoritmo em Portugol deve conter os seguintes requisitos: 
I. Realizar a leitura dos seguintes dados, para cada uma das 20 pessoas:
   - Nome.
   - Idade.
   - Sexo.
   - Quantidade de filhos.
   - Renda mensal familiar.

Obs.: Sair do laço de repetição se um nome não for preenchido, mesmo se não atingir 20 pessoas.

II. Com base nos dados coletados, apresente na tela as seguintes informações:
     - Percentual de mulheres e homens.
     - Número de pessoas com renda familiar de 500.00 (quinhentos reais) ou acima.
     - Percentual de pessoas que tem ao menos 1 filho.
     - Número de pessoas que nasceram a partir do ano 2000.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Ola!

não tenho certeza se entendi bem a forma como o algoritmo deveria ficar, mas acho que voce quer algo mais ou menos assim...

Vale observar que eu não realizei muitos testes para encontrar erros, se alguém encontrar algum erro, gostaria que fosse postado aqui... e tambem, eu não investi muito tempo para desenvolver um otimo algoritmo, então, e bem possivel que existam formas bem mais eficientes de se reescrever esse codigo.

// Algoritmo criado para tópico do forum Script Brasil
// O objetivo desse algoritmo e receber dados de, no maximo, 20 pessoas e,
// apartir desses dados, apresentar estatisticas na saida.
// Algoritmo criado por ThiagoD.
algoritmo "EntrevistaPessoas"
var
   A,B,TOTALDEMULHERES,TOTALDEHOMENS,NASCAPART2000,RENDAACIMADE500,MAISDE1FILHO : INTEIRO
   NOMES  : VETOR[0..19] DE CARACTERE
   IDADE  : VETOR[0..19] DE INTEIRO
   SEXO   : VETOR[0..19] DE CARACTERE
   FILHOS : VETOR[0..19] DE INTEIRO
   RENDA  : VETOR[0..19] DE REAL
inicio
   A:=-1
   REPITA                  // Esse bloco vai se repetir e coletar todas as informaçoes necessarias...
      A:=A+1               // ate que chegue ao numero maximo de entrevistados, ou o usuario deixe...
      LIMPATELA            // o campo "Nome:" em branco.
      ESCREVAL(A+1,"° Entrevistado")
      ESCREVAL("")
      ESCREVA(" Nome:   ")
      LEIA(NOMES[A])
      ESCREVA(" Idade:  ")
      LEIA(IDADE[A])
      ESCREVA(" Sexo:   ")
      LEIA(SEXO[A])        // E importante ressaltar que, o campo "Sexo:" deve ser preenchido com...
      ESCREVA(" Filhos: ") // os caracteres 'F' para mulheres e 'M' para homens, caso contrario...
      LEIA(FILHOS[A])      // ocorrera um erro.
      ESCREVA(" Renda:  ")
      LEIA(RENDA[A])
   ATE(A=19) OU (NOMES[A]="")
   A:=0
   ENQUANTO não(NOMES[A]="") FACA // Esse bloco se repete e manipula os dados obtidos afim de...
      SE (SEXO[B]="F") então      // obter as estatisticas que serao impressas na saida.
         TOTALDEMULHERES:=TOTALDEMULHERES+1
      FIMSE
      SE (SEXO[B]="M") então
         TOTALDEHOMENS:=TOTALDEHOMENS+1
      FIMSE
      SE não(IDADE[B]<18) então
         NASCAPART2000:=NASCAPART2000+1
      FIMSE
      SE (RENDA[B]>=500) então
         RENDAACIMADE500:=RENDAACIMADE500+1
      FIMSE
      SE (FILHOS[B]>0) então
         MAISDE1FILHO:=MAISDE1FILHO+1
      FIMSE
      A:=A+1
      B:=B+1
   FIMENQUANTO
   LIMPATELA
   ESCREVAL("")                           // Por fim, as estatisticas serao imprimidas...
   ESCREVAL(" ESTATISTICAS")
   ESCREVAL(" Total de entrevistados:",A)
   ESCREVAL("")
   ESCREVAL(" Mulheres:    ",TOTALDEMULHERES/A*100:3:2)
   ESCREVAL(" Homens:      ",TOTALDEHOMENS/A*100:3:2)
   ESCREVAL(" +De R$500,00:",RENDAACIMADE500)
   ESCREVAL(" +De 1 Filho: ",MAISDE1FILHO)
   ESCREVAL(" Apartir de 2000:",NASCAPART2000)
fimalgoritmo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this