Jump to content
Fórum Script Brasil
  • 0
Sign in to follow this  
ARSaraiva

Comando Wait com PID em

Question

Olá, estou tentando automatizar uma tarefa e estou encontrando problemas com o PID. 

Meu código:

for i in 5 10
do
echo "omnetpp.ini Generated! Running."
../../bin/Castalia -c General
PIDCAST=$(ps aux |grep CastaliaBin |tr -s " " | cut -d" " -f2)
wait $PIDCAST
cp Castalia-Trace.txt Castalia-Trace_$i.txt
rm Castalia-Trace.txt
rm omnetpp.ini
done	

essa chamada ../../bin/Castalia executa um simulador. Eu gostaria de fazer o script aguardar o fim da execução deste simulador, para copiar o arquivo de log (Catalia-Trace.txt) , apagá-lo após a cópia e executar o for de novo.

O problema é que desta forma está retornando o erro:

omnetpp.ini Generated! Running.

./executa.sh: linha 88: wait: o pid 2573 não é um processo filho deste shell
cp: não foi possível obter estado de 'Castalia-Trace.txt': Arquivo ou diretório inexistente
rm: não foi possível remover 'Castalia-Trace.txt': Arquivo ou diretório inexistente

Poderiam me auxiliar com esta situação de processos?

 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



  • Forum Statistics

    • Total Topics
      148448
    • Total Posts
      643906
×
×
  • Create New...