Jump to content
Fórum Script Brasil
  • 0

Definir menor e maior número - Help


Question

Oi pra vocês. Eu estou aprendendo a programar tem pouquíssimo tempo, e tenho que criar um programa (bem simples, no VisuAlg mesmo) pra definir a maior e a menor nota de uma quantidade de estudantes e atribuir os seus nomes no fim como "MelhorAluno" e "PiorAluno".
O problema é que sempre que executo o programa, ele me dá a menor nota sempre como "0", e não me mostra o nome do "PiorAluno" no fim.
Alguém poderia me informar/sugerir onde posso estar errando?


Vou inserir o que fiz até o momento:

algoritmo "Aluno"
var
   A, C : Inteiro
   N, MelhorAluno, PiorAluno: Caractere
   NOTA, maior, menor: Real
inicio
      Escreva ("Quantos alunos tem na turma? ")
      Leia (A)
      C <- 1
      Enquanto (C <= A) faca
               EscrevaL ("Aluno", C)
               Escreva ("Nome do aluno: ")
               Leia (N)
               Escreva ("Nota do aluno: ")
               Leia (NOTA)
               Se (NOTA > maior) então
                  maior <- NOTA
                  MelhorAluno <- N
               FimSe
               Se (NOTA < menor) então
                  menor <- NOTA
                  PiorAluno <- N
               FimSe
               C <- C + 1
      FimEnquanto
      EscrevaL ("O aluno com a maior nota foi ", MelhorAluno, " com aproveitamento de ", maior)
      EscrevaL ("O aluno com menor aproveitamento foi ", PiorAluno, " com nota ", menor)
fimalgoritmo

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      149264
    • Total Posts
      645605
×
×
  • Create New...