Jump to content
Fórum Script Brasil
  • 0

Preciso ajuda para fazer um Algoritmo em portugol para: Ler e imprimir um vetor com 42 elementos inteiros separar e escrever os números pares e impares do vetor, em dois vetores diferentes em portugol


Victor1963

Question

·         Objetivo do algoritmo: Ler e imprimir um vetor com 42 elementos inteiros separar e escrever os números pares e impares do vetor, em dois vetores diferentes.

·         Entrada: Ler um vetor com 42 números inteiros

·         Processamento: Calcular números pares e impares

·         Saída: Imprimir números pares e impares em dois vetores diferentes

 

Algoritmo vetor par – vetor impar

Var

Inteiro v[42], par[42], impar[42], x=0, y=0

Inicio

Para(inteiro x=0; x<42; x++){

escreva(“Digite 42 numeros inteiros:\n\n”)//preenchimento do vetor//

fim_para

para(i=0; i<42; i++)

se(num[i]%2 == 0)//verificação se o número é par//

par[x]=num[i];//Armazenamento dos numeros pares no vetor par//

fim_para

x++; //incremento do índice do vetor par//

  else //se o numeto inteiro não é par, é ímpar!// 

              impar[y]=num[i];//Armazenamento dos numeros ímpares no vetor ímpar//

      y++; //incremento do índice do vetor ímpar//

escreva("\nNumeros pares digitados\n"); //impressão do vetor par//

fim_para

para(i=0; i<x; i++)

escreva("\nNumeros impares digitados\n");//impressão do vetor ímpar//

fim_para

  para(i=0; i<y; i++)        

  escreva("%d\n",impar[i]);            

fim_para

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Forum Statistics

    • Total Topics
      152.1k
    • Total Posts
      651.9k
×
×
  • Create New...