• 0
Sign in to follow this  
Ganhei

Logica De ProgramaÇÃo!

Question

beleza pessoal?

Tenho dois exercicios que não consegui fazer será q alguém pode me ajudar?

1-)Escreva um algoritmo que gere os números de 1000 a 1999 e escreva aqueles que dividido por 11 dão resto igual a 5.

2-)9. Uma loja tem 150 clientes cadastrados e deseja mandar uma correspondência a cada um deles anunciando um bônus especial. Escreva um algoritmo que leia o nome do cliente e o valor das suas compras no ano passado e calcule um bônus de 10% se o valor das compras for menor que 500.000 e de 15%, caso contrário

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

O primeiro você pode fazer assim:

PARA i=1000 ATÉ 1999 FAÇA
  SE (i MOD 11)=5 ENTÃO
    ESCREVA(i)
  FIM-SE
FIM-PARA
E o segundo assim:
PARA i=1 ATÉ 150 FAÇA
  LEIA(nome)
  LEIA(valor)
  SE valor<500000 ENTÃO
    bonus = valor * 10/100
  SENÂO
    bonus = valor * 15/100
  FIM-SE
FIM-PARA

Mas, por favor, dê uma boa lida nos códigos e procure entender. Creio eu que se esses foram exercícios pedidos pelo professor é porque o mesmo já forneceu matéria suficiente para realização dos mesmos.

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites
  • 0

Entender as linhas eu entendo perfeitamente, mas no caso eu preciso usar o enquanto ou o se !

mudaria algo???

[]´s

Ganhei

Share this post


Link to post
Share on other sites
  • 0
Entender as linhas eu entendo perfeitamente, mas no caso eu preciso usar o enquanto ou o se !

mudaria algo???

[]´s

Ganhei

Calma, rapaz!

Sim, não dúvido que você entenda-as, depois de prontas... rolleyes.gif .Primeiro que "precisaria usar o 'enquanto' ou 'se'" (repare no "ou"!) já é uma prova bem substancial de que você ainda não entendeu. E, além da pergunta não ser cabível, você mesmo deveria saber a resposta.

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this