• 0
Sign in to follow this  
Ganhei

Lista De ExercÍcios!

Question

Opa pessoal beleza???

eu sei que vocês não gosta mde fazer a "resolução" dos programas para os outros, porque assim não se aprende, eu TB acho isso, por isso estou pedindo a juda de vocês pra ver se "minha logica" esta certa! É um pouco grande mas ai vai!!

1. Faça um algoritmo que leia as notas finais dos alunos de uma turma e escreva qual foi a maior nota.

Algoritmo maior_nota;

declare nota, maior_nota, auxiliar numérico;

maior_nota  0;

auxiliar  1;

enquanto auxiliar < 21

leia nota;

se nota > maior_nota ;

então maior_nota = nota;

fimse

auxiliar = auxiliar + 1;

fimenquanto

escreva “A Maior nota é” maiornota;

fim-algoritmo

2. Escreva um algoritmo que leia 20 valores e encontre o maior e o menor deles. Mostre o resultado.

Algoritmo maior_e_menor_valor

declare valor, menorvalor, maiorvalor, auxiliar numérico;

menorvalor  0;

Maiorvalor  0;

auxiliar  1;

escreva “Digite os valores”

enquanto auxiliar < 21

leia valor;

se valor > maiorvalor ;

então maiorvalor = valor;

Senão menorvalor= valor;

fimse

auxiliar = auxiliar + 1;

fimenquanto

escreva “O Maior valor é” maiorvalor;

escreva “O Menor valor é ”menorvalor;

fim-algoritmo

3. Faça um algoritmo que calcule e escreva a soma de todos os números ímpares no intervalo [1, 100].

Algoritmo Impar

Declare impar, soma, numérico;

Impar 1;

Soma 0;

Enquanto impar<100

Inicio

Soma soma+ impar;

Impar impar+2;

Fim enquanto

Escreva “A Soma dos números impares é”:impar ;

Fim-Algoritmo

4. Faça um algoritmo que calcule e escreva o valor de S:

S = 1 + (3/2) + (5/3) + (7/4) + ... + (99/50)

Algoritmo S

Declare soma,n,d numérico;

N 1;

D1;

Soma0;

Enquanto n<100

Inicio

Soma soma + n/d

D d+2

Fim-enquanto

Escreva “O valor de S é”soma;

5.Supondo que a população de um país A seja de ordem de 90.000.000 de habitantes com uma taxa anual de crescimento de 3% e que a população de um país B seja, aproximadamente, de 200.000.000 de habitantes com uma taxa anual de crescimento de 1,5%, fazer um algoritmo que calcule e escreva o número de anos necessários para que a população do país A ultrapasse ou iguale a população do país B, mantidas essas taxas de crescimento.

Algoritmo Pais

Declare ano,paisa,paisb numérico;

Leia ano,paisa,paisb ;

Enquanto pais a <pais b

Inicio

Paisa1.03 * paisa;

Paisb1.15 * paisb;

Anoano+1;

Fim-enquanto

Escreva “ Ao ano é” ano;

Fim-Algoritmo

6. [Farrer et al. 1989] Um determinado material radioativo perde metade de sua massa a cada 50 segundos. Dada a massa inicial, em gramas, fazer um algoritmo que determine o tempo necessário para que essa massa se torne menor do que 0,5 grama. Escreva a massa inicial, a massa final e o tempo calculado.

Algoritmo material

Declare t,mf,mi

T0

Mf0

Leia MI

Enquanto mf<0,5

Tt+50

Mf(mf/)2

Fimse

Escreva “a massa inicial é ”Mi;

Escreva “a massa final é ” Mf;

Escreva “o tempo final é ” t;

Fim-algoritmo

7. Escrever um algoritmo que lê um valor N inteiro e positivo e que calcula e escreve o valor de E.

E = 1 + (1 / 1!) + (1 / 2!) + (1 / 3!) + (1 / N!)

Lembrete:

1! = 1

2! = 2 * 1

3! = 3 * 2 * 1

4! = 4 * 3 * 2 * 1

Algoritmo Valor

Declare

E 1

Escreva “digite o valor de N”;

Enquanto N>=1

Inícios

EE * N

NN-1

Fim-Enquanto

Escreva “O Valor do E é”N”

8. Escreva um algoritmo que gere os números de 1000 a 1999 e escreva aqueles que dividido por 11 dão resto igual a 5.

Algoritmo gerador

Declare i numerico

Para i=1000 ate 1999

Se (i mod 11 =)5

Então escreva (i)

Fimse

fimpara

9. Uma loja tem 150 clientes cadastrados e deseja mandar uma correspondência a cada um deles anunciando um bônus especial. Escreva um algoritmo que leia o nome do cliente e o valor das suas compras no ano passado e calcule um bônus de 10% se o valor das compras for menor que 500.000 e de 15%, caso contrário.

Algoritmo cliente

Declare

Para i=1 ate 150

Leia nome

Leia valor

Se valor <5000000

Bônus=valor * 10/100

Senão bônus=valor*15/100

Fimse

Fimpara

Fim-algoritmo

10. Foi realizada uma pesquisa de algumas características físicas da população de uma certa região, a qual coletou os seguintes dados referentes a cada habitante para serem analisados:

- sexo (masculino e feminino)

- cor dos olhos (azuis, verdes ou castanhos)

- cor dos cabelos (louros, castanhos, pretos)

- idade

Faça um algoritmo que determine e escreva:

- a maior idade dos habitantes

- a quantidade de indivíduos do sexo feminino cuja idade está entre 18 e 35 anos inclusive e que tenham olhos verdes e cabelos louros.

O final do conjunto de habitantes é reconhecido pelo valor -1 entrada como idade.Algoritmo pesquisa

Declare idade,indivíduos,maioridade,porcentagem,totalindividuos numérico

Declare cabelos,olhos,sexo literal

Maioridade0

Totaldeindividuos=0

Indivíduos=0

Leia sexo,olhos,cabelo,idade

se idade<0

então escreva "idade invalida"

Enquanto idade>maioridade

maioridade=idade

Fimse

Totalindividuostotalindividuos+1

Se idade >=18 e =< 35 e sexo= “feminino” e olhos=“verdes” e cabelos = “louros”

Então indivíduosindividuos+1

Fimse

Porcentagem  indivíduos * 100 / totaldeindividuos

Escreva maioridade

Escreva porcentagem

Fim-algoritmo

AGRADEÇO A TODOS DESDE JÁ!

[]´S GANHEI

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Não tive tempo de olhar todos, mas o segundo tem um pequeno erro, nessa parte:

se valor > maiorvalor;
então maiorvalor = valor;
Senão menorvalor= valor;
fimse

Para descobrir o erro, imagine que a sequência de números digitada pelo usuário foi: 5, 1, 7, 2. A resposta correta seria 7 e 1. Porém, de acordo com esse pedaço do algorítmo não será essa a resposta, e sim 7 e 2. Por que?

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites
  • 0
Guest Guest

Fala Graymalkin Beleza???

sinceramente não achei o erro! sad.gif

Pessoal! so coloquem por exemplo 1-ok 2-ok 3-errada 4 - ok ..... mas quem quiser dar uma força agradeço muito

Valeu!

Share this post


Link to post
Share on other sites
  • 0

Repare no que o código diz:

se valor > maiorvalor;
então maiorvalor = valor;
Senão menorvalor= valor;
fimse
Se o valor digitado é maior que o maior valor, então ele será o novo maior valor, caso contrário (ou seja, caso ele não seja maior que o maior valor), ele será o novo menor valor. Porém, isso não é totalmente verdadeiro. O fato dele não ser maior que o maior, não significa que ele seja o menor de todos. Imagine a sequência proposta anteriormente: 5, 1, 7, 2. Supondo que "maiorvalor", inicialmente é zero, teríamos (as setas <-- indicam quais "Se"s e quais "Senão"s foram executados):
se 5 > 0 então
  maiorvalor = 5 <--
Senão
  menorvalor= 5;
fimse
se 1 > 5 então
  maiorvalor = 1
Senão
  menorvalor= 1; <--
fimse
se 7 > 5 então
  maiorvalor = 7 <--
Senão
  menorvalor= 7;
fimse
se 2 > 7 então
  maiorvalor = 2
Senão
  menorvalor= 2; <--
fimse

Veja que "menorvalor" acabou ficando com 2, sendo que o 1 (que passou antes) é que deveria ter ficado. Sacou agora?

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites
  • 0

Fala Graymalkin bele?

estou lotado de trabalho e prova ,ta dificil a logica...

seria isso?

se VALOR > MAIORVALOR

então MAIORVAOR= VALOR

senão se VALOR < MENORVALOR

então MENORVALOR= VALOR;

fim se

Share this post


Link to post
Share on other sites
  • 0
seria isso?

se VALOR > MAIORVALOR

então MAIORVAOR= VALOR

senão se VALOR < MENORVALOR

então MENORVALOR= VALOR;

fim se

Exatamente! biggrin.gif Depois vou salvar essa página e dar uma olhadela nos outros.

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites
  • 0

Fala Graymalkin certinho??? Pelo visto só você vai me ajudar né? biggrin.gif

Pra falar a verdade a 7 eu não tenho ideia de como fazer.... a 10 eu vi em um livro e fiz + ou - na logica dele, mas a logica dele era REPITA e não Enquanto.

Depois da uma olhada n oemail æ!!!!

Minha cabeça tá um inferno não to nem dormindo direito!

Valeuu!!!!

[ ] ´Ganhei

Share this post


Link to post
Share on other sites
  • 0

O 7 eu faria assim:

Algoritmo Valor
Declare
soma = 1
Escreva “digite o valor de N”;
M = N
PARA K=1 ATÉ M FAÇA
  N = M
  F = 1
  Enquanto N>=1
    F = F * N
    N = N-1
  Fim-Enquanto
  soma = soma + (1/F)
PRÓXIMO K

Escreva “O soma total é ”, soma
E o 10 assim:
Algoritmo pesquisa
Declare idade,indivíduos,maioridade,porcentagem,totalindividuos numérico
Declare cabelos,olhos,sexo literal
Maioridade0
Totaldeindividuos=0
Indivíduos=0
idade = 0
ENQUANTO idade<>-1 FAÇA
  Leia sexo,olhos,cabelo,idade
  se idade>maioridade
    maioridade=idade
  Fimse
  Totalindividuostotalindividuos+1
  Se idade >=18 e =< 35 e sexo= “feminino” e olhos=“verdes” e cabelos = “louros”
    Então indivíduosindividuos+1
  Fimse
FIM-ENQUANTO
Porcentagem  indivíduos * 100 / totaldeindividuos
Escreva maioridade
Escreva porcentagem
Fim-algoritmo

É bom dar uma conferida depois, pois fiz rápido aqui.

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites
  • 0

O que sria esse PROXIMO K ?

Tem como substituir ele por algum outro comando?

Abraços Ganhei

Share this post


Link to post
Share on other sites
  • 0

PRÓXIMO K seria o equivalente a FIM-PARA... Depende de como o professor ensinou. Eu gosto de usar PRÓXIMO, por que no BASIC a síntaxe do PARA é:

for i=1 to 10
  'faça algo
next i

E NEXT significa PRÓXIMO. Mas, pode-se usar FIM-PARA no lugar. Sem problemas.

Abraços,

Graymalkin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this