• 0
Sign in to follow this  
dark0

Solução Para O Erro De Permissões !

Question

Olá pessoal.

Visto que nos ultimos dias, o que mais estamos vendo por aqui, é o erro:

"A Operação deve ser uma consulta atualizavel"

Eu me deparei com esse problema aqui, e descobri passo-a-passo como resolver ele!

Eu testei isso apenas no Windows XP Professional!

- Vá em painel de controle, de um duplo clique em opções da pasta

- Vá até modo de exibição, onde tem configurações avançadas, localize a frase usar compartilhamento simples de arquivos (recomendável)

- Desmarque esta opção. Clique em aplicar e depois ok.

- Agora clique com o botão direito do mouse sobre o seu banco de dados e vá em propriedades.

- Clique no guia segurança e dê controle total ao usuário Todos, clique em ok.

- Teste Seus codigos !!!

Qualquer duvida, perguntem aí!

Abraços

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

no server deve ser geralmente bd ou db que fica na index do ftp junto a wwwroot

Share this post


Link to post
Share on other sites
  • 0
Guest - juliana -
Olá pessoal.

Visto que nos ultimos dias, o que mais estamos vendo por aqui, é o erro:

"A Operação deve ser uma consulta atualizavel"

Eu me deparei com esse problema aqui, e descobri passo-a-passo como resolver ele!

Eu testei isso apenas no Windows XP Professional!

- Vá em painel de controle, de um duplo clique em opções da pasta

- Vá até modo de exibição, onde tem configurações avançadas, localize a frase usar compartilhamento simples de arquivos (recomendável)

- Desmarque esta opção. Clique em aplicar e depois ok.

- Agora clique com o botão direito do mouse sobre o seu banco de dados e vá em propriedades.

- Clique no guia segurança e dê controle total ao usuário Todos, clique em ok.

- Teste Seus codigos !!!

Qualquer duvida, perguntem aí!

Abraços

Olá pessoal sou novata no asp, vi sobre permissoe, arrumei conforme postado, mas continua dando o mesmo erro,se alguém puder me ajudar ficarei muito grata .

Vou enviar o codigo para você olharem

<%

dim con

dim rs

dim vempresa

dim sql

dim insere

dim recset

vempresa=request.form ("Empresa")

insere = "insert into clientes(empresa) Values ('" & vempresa & "')"

db = server.MapPath ("tulio\treino.mdb")

set con = server.CreateObject("adodb.connection")

con.open "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=c:\tulio\treino.mdb"

con.execute(insere)

response.write "Dados Cadastrados com Sucesso!!!"

%>

Share this post


Link to post
Share on other sites
  • 0

posta ae o erro..

Share this post


Link to post
Share on other sites
  • 0

alguém sabe me dizer se para resolver este problema no windows 2000 é a mesma coisa????????????

Share this post


Link to post
Share on other sites
  • 0

a princípio é a mesma coisa sim..

talvez alguma tela seja diferente mas a solução é a mesma.

Share this post


Link to post
Share on other sites
  • 0

to rodando a net há semanas, procurando uma solução... essa caiu como uma luva, valeu

Share this post


Link to post
Share on other sites
  • 0
Guest ASP naum roda

já fiz todos os testes possiveis mas não estou conseguindo rodas ASP em meu PC. Aguem pode me dar uma ajuda. Mando abrir a pagina e ele fica tentando abrir a pag. por varios e varios minutos e nada.

Share this post


Link to post
Share on other sites
  • 0

Brother, você tem algum anti-virus instalado?

Se tver.. experimenta desativar ele, e rodar a pagina .asp de novo.

Se funcionar.. o problema é que alguns anti-virus.. possuem um esquema de "Bloqueio de Script".

Isso bloqueia algumas funções do asp!

posta aí o resultado

Abraço

Share this post


Link to post
Share on other sites
  • 0

Olá, eu fiz um sistema de busca com a linguagem sql do access, e funcionou, só que tem um problema, quando em um registro está escrito por exemplo: "acessórios para computador" e se eu digito na busca "acéssorios computador" ele não acha o registro. Eu queria saber como fazer para se encontrar a busca aproximada, para que ele desconsidere a sequencia exata de palavras e encontrar o registro, e se eu digitar por exemplo "casa de carnes" e não conter o "de" no registro, ele acha o registro com sucesso, alguém sabe me explicar como fazer isso?

Share this post


Link to post
Share on other sites
  • 0

utilize like.... veja o outro tópico postado com a mesma duvida

Share this post


Link to post
Share on other sites
  • 0
Guest Marcio Alves Vieira

Para acabar de vez com essa seleuma das permissões segue uma dica:

Abra o Windows explorer

Clique na pasta InetPub

Clique com o botão direito do mouse sobre a pasta wwwroot

clique em compartilhamento e segurança

Clique na guia segurança

Verifique se os usuarios:

sua_maquina\IUSR_sua_maquina

sua_maquina\IWAM_sua_maquina

Constam da lista e se suas permissões são de controle total, caso não estejam adicione-os e de permissão de controle total

Agora Clique em avançado

Na guia permissões marque a opção:

Substituir as entradas de permissão em todos os objetos filho pelas entradas aplicáveis mostradas aqui (segunda opção)

NÂO MARQUEM A PRIMEIRA OPÇÂO, caso ele esteja marcada remova a seleção da mesma !

Clique em ok

Clique em aplicar

Clique em ok.

Pronto isso deve resolver os erros referentes a permissões.

Marcio Alves Vieira

[email protected]

Share this post


Link to post
Share on other sites
  • 0
Guest --Diogo --

Esse erro é simples de resolver acontece que no servidor iis do windows você precisa desativar o acesso anônimo.

Na pasta aonde roda suas páginas em asp.

É só clicar com o botão direito do mouse e acessar as propriedades da pasta e na par te que corresponde ao tipo de acesso você desativa o ACESSO ANÔNIMO.

Share this post


Link to post
Share on other sites
  • 0
Esse erro é simples de resolver acontece que no servidor iis do windows você precisa desativar o acesso anônimo.

Na pasta aonde roda suas páginas em asp.

É só clicar com o botão direito do mouse e acessar as propriedades da pasta e na par te que corresponde ao tipo de acesso você desativa o ACESSO ANÔNIMO.

isso não resolve 100%... se você usa firefox ele pode parar de encher a paciencia... já no ie ele fica pedindo...

e ainda tem as questões de acesso externo e tal..

Share this post


Link to post
Share on other sites
  • 0
Guest Renavan

Estou enviando este tópico para agradece-lo pela ajuda, rodei a web inteira para resolver este problema e você foi o unico correto.

Grato

Share this post


Link to post
Share on other sites
  • 0
Guest Alessandro Gonzalez

Cara, eu tive um problema parecido rodando o IIS no XP, resolvi dando permissão de gravação para o meu usuário, o que esta rodando na máquina.

Share this post


Link to post
Share on other sites
  • 0

Uma outra solução também é não rodar seus scripts com o usuários "IUSR_NomeDaMáquina". Assim sempre qualquer pasta irá sempre ter permissão de gravação. Para isso:

1) Crie um usuário no windows e coloque-o no grupo "Administradores"

2) Vá ao IIS e na aba "Segurança de Diretório" do seu site (no caso do XP é Site da Web Padrão) clique em Editar na parte: "Autenticação e controle de acesso".

3) O checkbox Ativar acesso anônimo estará marcado, clique em Procurar > Avançado > Localizar Agora e selecione o usuário que você criou.

4) Digite e confirme a senha desse usuário e dê OK.

PS.: Os passos podem ser um pouco diferentes, pois uso o IIS6 e o WinXP usa o IIS5.1, mas se for diferente, deve ser bem parecido.

Dessa forma sempre qualquer diretório de seu site sempre terá permissão de gravação, pois usuários administradores, a não ser que especifique-mos ao contrário em um determinado diretório, pode gravar em qualquer lugar da máquina.

Abraço.

Share this post


Link to post
Share on other sites
  • 0

Como faz este processo em Windows Server 2003, tentei fazer o procedimento mais não contém a opção "Configurações avançadas" e nem "usar compartilhamento simples de arquivos (recomendável)"

Share this post


Link to post
Share on other sites
  • 0
Olá pessoal.

Visto que nos ultimos dias, o que mais estamos vendo por aqui, é o erro:

"A Operação deve ser uma consulta atualizavel"

Eu me deparei com esse problema aqui, e descobri passo-a-passo como resolver ele!

Eu testei isso apenas no Windows XP Professional!

- Vá em painel de controle, de um duplo clique em opções da pasta

- Vá até modo de exibição, onde tem configurações avançadas, localize a frase usar compartilhamento simples de arquivos (recomendável)

- Desmarque esta opção. Clique em aplicar e depois ok.

- Agora clique com o botão direito do mouse sobre o seu banco de dados e vá em propriedades.

- Clique no guia segurança e dê controle total ao usuário Todos, clique em ok.

- Teste Seus codigos !!!

Qualquer duvida, perguntem aí!

Abraços

Dark0

Sua dica é muito boa. 6 anos depois ainda está ajudando. Muito obrigado, pois a gente vê que na net consegue encontrar pessoas que são boas e ajudam aos que precisam. Deus te abençoe, amigo(a)!

Share this post


Link to post
Share on other sites
  • 0
Brother, você tem algum anti-virus instalado?

Se tver.. experimenta desativar ele, e rodar a pagina .asp de novo.

Se funcionar.. o problema é que alguns anti-virus.. possuem um esquema de "Bloqueio de Script".

Isso bloqueia algumas funções do asp!

posta aí o resultado

Abraço

caramba, tem toda razão, vou desabilitado e agora já está funcionando, obrigado Dark0

Share this post


Link to post
Share on other sites
  • 0

AchaBura is the best customer review website where people share their reviews with others. Customer reviews help others make the right decisions, so keep posting reviews about services and products.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this