Jump to content
Fórum Script Brasil
  • 0

Senha No Bd


serraventura
 Share

Question

Galera desculpe o sumisso..........mas é porque to tendo muita ralação....tá mó pressão......e nisso tudo tive um problema to precisando de uma ajuda...

o erro é esse abaixo...

Tipo de erro:

Microsoft JET Database Engine (0x80004005)

Não foi possível encontrar ISAM instalável.

/camacho/cadpf.asp, line 9

é porque fui usar pela primeira vez senha no bd........aí deu esse erro....acho q tem algum driver do bd q não esta instalado.......e eu não sei como faço isso......usei a conexão q peguei aqui no forum mesmo é essa

arqbd = server.mappath("lca.mdb")

sgbd = "DBQ=" & arqbd & ";Provider=Microsoft.Jet.OLEDB.4.0;Jet OLEDB:Database Password=elca;"

tem como dar uma olhada pra mim...........o q poderia ser....e como resolver???

valeu!!

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Bareta sua conexão com bd funcionou mas....ela não deixa gravar..........troço estranho.................quando uso minha antiga conexão com BD o script consulta e grava normalmente.............porem quando uso a conexão q peguei com vc........ela consulta normalmente..porem não grava na hora de gravar da erro!!

Tipo com essa

DB = "Data Source=" & Server.Mappath("bd/banco.mdb") & ";Provider=Microsoft.Jet.OLEDB.4.0;Jet OLEDB:Database Password=senha;"

quando vou fazer um cadastro da um erro na minha string sql.....porem se você tentar gravar um login q já exista ele da a mensagem de q esse login já existe....

minha string sql é essa:

sql2 = "INSERT INTO clientes (apelido, senha, opc, nome, cpf, rg, cidade, estado, end, tel, email) VALUES ('"& request.form("apelido") &"', '"& request.form("senha") &"', '1', '"& request.form("nome") &"', '"& request.form("cpf") &"', '"& request.form("rg") &"', '"& request.form("cidade") &"', '"& request.form("estado") &"', '"& request.form("end") &"', '"& request.form("tel") &"', '"& request.form("email") &"')"

db.execute(sql2)

porque isso.......???? com uma conexão de BD funciona td direito e com outra não???

Link to comment
Share on other sites

  • 0

que erro dá com a outra?

Link to comment
Share on other sites

  • 0

Já troquei a senha já fiz tudo q tinha q fazer mais da o erro!!!

pra vocês entenderem melhor vai no site.......ainda tá em construção

reso: 800x600

Clique aqui

tentem cadastrar um login q exista tipo esse (teste) e depois tente cadastrar um login q não exista aí vocês vão ver a diferença...e o erro.....q só da quando você tenta cadastrar um login q ainda não exista no BD!...

meu codigo é esse:

<%

dim mensagem

sgbd = "Data Source=" & Server.Mappath("Lca.mdb") & ";Provider=Microsoft.Jet.OLEDB.4.0;Jet OLEDB:Database Password=lca;"

set db= server.createobject("ADODB.connection")

db.open sgbd

sql = "SELECT apelido FROM clientes WHERE apelido='"& request.form("apelido") &"'"

set resultsql = db.execute(sql)

if resultsql.Eof then

sql2 = "INSERT INTO clientes (apelido, senha, opc, nome, cpf, rg, cidade, estado, end, tel, email) VALUES ('"& request.form("apelido") &"', '"& request.form("senha") &"', '1', '"& request.form("nome") &"', '"& request.form("cpf") &"', '"& request.form("rg") &"', '"& request.form("cidade") &"', '"& request.form("estado") &"', '"& request.form("end") &"', '"& request.form("tel") &"', '"& request.form("email") &"')"

db.execute(sql2)

db.close

set resultsql = nothing

set sgbd = nothing

%>

<html>

<head>

</head>

<body>

<center>

<h1>Cadastro Efetuado com sucesso seu login e senha de acesso são: Login <b><%=request.form("apelido")%></b> e senha <b><%=request.form("senha")%></b></h1>

</center>

</body>

</html>

<%

else

db.close

set resultsql = nothing

set sgbd = nothing

%>

</head>

<body>

<center>

<h1>Escolha outro apelido, pois <%=request.form("apelido")%> já esta sendo usado!</h1>

</center>

</body>

</html>

<%

end if

%>

Link to comment
Share on other sites

  • 0

<%

sql2 = "INSERT INTO clientes (apelido, senha, opc, nome, cpf, rg, cidade, estado, end, tel, email) VALUES ('"& request.form("apelido") &"', '"& request.form("senha") &"', '1', '"& request.form("nome") &"', '"& request.form("cpf") &"', '"& request.form("rg") &"', '"& request.form("cidade") &"', '"& request.form("estado") &"', '"& request.form("end") &"', '"& request.form("tel") &"', '"& request.form("email") &"')"

db.execute(sql2)

%>

cara quando eu fiz um teste deu um erro de SQL.

Verifica se a string está correta, se você não está inserindo strtng em campo numérico ou vice versa.

Quanto ao outro erro (de apenas ler, mas não gravar), clique com o botão direito em cima do arquivo de Base de Dados >> Propriedades.

Verifica se o campo somente leitura não está selecionado. As vezes pode ser isto.

Qualquer coisa estamos ai.

Abraços Daniel

Link to comment
Share on other sites

  • 0

é.. se não grava.. veja se não é problema com permissões!

Qual erro deu no SQL?

Link to comment
Share on other sites

  • 0

deve ser o campo END

muda o nome do campo END na tabela do banco, e no codigo, e testa de novo, hehe

Eu criei um tópico sobre isso esses dias aí..

Link to comment
Share on other sites

  • 0

realmente tem sentido o lance de valor numerico, pois tem um numero 1 na string......mas o mais estranho é q quando uso uma conexão de BD diferente td funciona direitinho..............da uma testada lá pra v melhor o erro!!! coloquei no post acima o endereço.....vou dar uma estudada....nesse lance de valor numerico!!......mas não desistam do meu post não hein...........rs......

valeu

Link to comment
Share on other sites

  • 0

laugh.giflaugh.giflaugh.gif huahuhau cara era esse lance de END mesmo........aí dark manda o END ....quer rs dizer o endereço desse post q fala sobre isso........huahua cara ainda não to acreditando........aí obrigado a todos aí q ajudaram.......valeu mais uma vez....... laugh.gifwacko.gifwacko.gif

se quiser já pode fechar esse tópico....mais antes coloca o endereço do post q fala sobre END......

valeu!

Link to comment
Share on other sites

  • 0

opa, beleza?

Bom.. o post não fala exatamente do END.

São posts de duvidas em erro de sintaxe.

Mas com o comando todo certo.

Aí, eu fui atrás, e descobri porque dava erro de sintaxe.

O Sql, quando achava algum campo com o nome de algum termo do proprio sql, ou do banco de dados.. dava erro, pois ele não interpretava o campo como o campo.. e sim como o termo que ele reconhece.

- http://scriptbrasil.com.br/forum/index.php...ndpost&p=156352

- http://scriptbrasil.com.br/forum/index.php...ndpost&p=156337

devem ter até mais topicos sobre isso..

Mas a verdade, é que tem que olhar bem o nome dos campos.. pois algum deles pode ser algum termo restringido!

Abraços

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.7k
    • Total Posts
      648.4k
×
×
  • Create New...