Jump to content
Fórum Script Brasil
  • 0
Sign in to follow this  
Guest - Mauro -

Como Instalar O Componente Cddonts

Question

Guest - Mauro -

Prezados Colegas

Descobri o problema usando as dicas aqui do Forum.

Coloquei um pequeno código no script para envair email e o retorno do do erro é

OBJETO NECESSÁRIO.

Eu suponho que deve ser porque o Cdonts não está instalado.

Mas não encontrei nada sobre como instalar.

Tenho Windows 2000 Server

Algue´me poderia me ajudar.

Mauro

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
Guest - Mauro -

Olha usei exatamente o modelo exibino no tópico..

Mas o erro é exatamente o mesmo...ou seja OBJETO Necessário...

E o email não é enviado...

Preciso de ajuda...agradeço muito quem puder dar uma dica...

Fiz tudo como manda o figurino e aqui vai o código ...

<%

if request("botao") = "enviar" then

Dim objNewMail

Set objNewMail = Server.CreateObject("CDONTS.NewMail")

objNewMail.From = "[email protected]"

objNewMail.To = request("to")

objNewMail.Subject = request("subject")

objNewMail.Body = request("body")

e=objNewMail.Send

if e then

Response.Write "Mensagem não enviada"

else

Response.Write "Mensagem enviada com sucesso"

end if

response.end

end if

On Error Resume Next

mailobject.send

If Err.Number = 0 Then %>

<script language="javascript"> alert ("E-Mail enviado com sucesso!");

window.close();

</script>

<%

Else

Response.Write "Error: " & Err.Description

End If

%>

<html>

<body>

<form method="POST" action="email.asp">

<table border="0" width="43%">

<tr>

<td width="13%"><strong>Para:</strong></td>

<td width="87%"><input type="text" name="to" size="32"></td>

</tr>

<tr>

<td width="13%"><strong>Assunto:</strong></td>

<td width="87%"><input type="text" name="subject" size="32"></td>

</tr>

<tr>

<td width="13%"><strong>Mensagem:</strong></td>

<td width="87%"><textarea rows="7" name="body" cols="43"></textarea></td>

</tr>

<tr>

<td width="13%"></td>

<td width="87%"><input type="submit" value="enviar" name="botao"></td>

</tr>

</table>

</form>

</body>

</html>

Share this post


Link to post
Share on other sites
  • 0

bom.

você baixou a dll, e depois registrou ela?

fez isso usando usuario administrador?

a mensagem de dll registrada apareceu?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



  • Forum Statistics

    • Total Topics
      148104
    • Total Posts
      643372
×
×
  • Create New...