• 0
Sign in to follow this  
maktub

Não Entendo

Question

Galera, tenho uma página em desenvolvimento mas estou tendo problema com o script, não da nenhum erro de execução mas para entender minha dificuldade,

na minha página inicial tem três colunas, direita, meio e esquerda.

Na coluna da esquerda tenho um include com 6 linhas, em cada linha tem um código include que chama os sisteminhas de login, banner etc.., o problema é que meu sistema de newslatter dá erro, ele não consegue encontrar o banco de dados, eu coloquei todos os arquivos dentro de uma pasta e não sei o por qe não executa, o caminho esta certinho.

Pior, quando eu executo ele fora da página, ele roda sem problema

O que pode ser?

Isso acontece também com meu sistema de banner, ele não mostra as figuras e quando eu clico em cima ele não busca o link indicado, mas fora da página ele roda normal

não sei se fui claro ms gostaria de uma ajudinha..

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Ola troque o caminho do banco de dados do seu sistma para o caminho fisico do seu banco de dados... "c:\xxxx\xxxx\xxx.mdb"

isso pode estar acontecendo pelo seguinte.

supomos que suas pastas estao organizadas como:

-wwroot

--newsletter

--Banner

dai a pagina na qual tem os includes esta na wwroot e o a pagina que é chaqmada esta na newsletter... aonde tb esta o seu banco de dados....

ao você dar um include da newsletter na pasta wwroot ela v ai ser execultada através do wwroot ai os caminhos logicos a ser utilizado temq ue ser apartir do wwroot.

não sei se consegui explicar direito mas qualquer duvida entre em contato.

t+

Share this post


Link to post
Share on other sites
  • 0

Eu entendi o que escreveu, meu site todo esta em wwwroot e dentro da pasta site e dentro desta pasta estão as outras pastas

Só um detalhe que não comentei, dentro da pasta newslatter tem um banco de dados, e quando executo ele fora do site ele roda normal, mas quando coloco o include para rodar na página principal ele da erro, é isso que não entendo, o caminho esta certinho.. só o include que não roda

Share this post


Link to post
Share on other sites
  • 0

intao... como eu havia falado.....

A pagina que está chamando o Include esta na wwroot e pagina da newsletter e seu respectivo banco de dados esta na pasta newsletter.

se você chamar a pagina da newsletter atravez do include que esta na wwroot o caminho do banco de dado tem que ser apartir da pasta wwroot...

qual o caminho que você esta utilizando?

t+

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this