• 0
Sign in to follow this  
Alemao_web

Envia Formulário, Mas Sem O Mail.body =

Question

Bom, estou com o seguinte erro, Preciso enviar um formulário, até ai tudo bem, porém esse e-mail vem sem os dados do Mail.Body =

CODE:

<%

if request("botao") = "enviar" then

Set Mail = Server.CreateObject("Persits.MailSender")

Mail.Host = "fourtrader.com"

Mail.Username = "[email protected]"

Mail.Password = "form"

Mail.From = Request.form("txtemail")

Mail.FromName = "Contato - Exportador"

Mail.AddAddress "[email protected]", "Giuliano"

Mail.Subject = "Contato Web Site - " & Request.form("txtempresa")

Mail.Body = "Produto: " & Request.form("txtproduto") & chr(13) & chr(10) & _

"Para qual país deseja exportar?: " & Request.form("txtpais") & chr(13) & chr(10) & _

"Sua empresa já exportou?: " & Request.form("txtexportou") & chr(13) & chr(10) & _

"Nome da Empresa: " & Request.form("txtempresa") & chr(13) & chr(10) & _

"Contato: " & Request.form("txtcontato") & chr(13) & chr(10) & _

"Telefone: " & Request.form("txtfone") & chr(13) & chr(10) & _

"E-mail: " & Request.form("txtemail") & chr(13) & chr(10) & _

Mail.Send

If Err <> 0 Then

Response.Write "An error occurred: " & Err.Description

Else

strMensagem = "Mensagem Enviada com Sucesso !!!"

End If

End if

%>

_______________________________________________________________

Formulário:

<form name="form1" form action="contact_export.asp" method="post">

<input name="txtproduto" type="text" style="font-family: Arial; font-size: 8pt; background-color: rgb(191,184,191); border: 1px solid rgb(0,0,0)" size="60">

<input name="txtpais" type="text" style="font-family: Arial; font-size: 8pt; background-color: rgb(191,184,191); border: 1px solid rgb(0,0,0)"size="60">

<input name="txtexportou" type="text" style="font-family: Arial; font-size: 8pt; background-color: rgb(191,184,191); border: 1px solid rgb(0,0,0)" size="60">

<input name="txtempresa" type="text" style="font-family: Arial; font-size: 8pt; background-color: rgb(191,184,191); border: 1px solid rgb(0,0,0)" size="40">

<input name="txtcontato" type="text" style="font-family: Arial; font-size: 8pt; background-color: rgb(191,184,191); border: 1px solid rgb(0,0,0)" size="40">

<input name="txtfone" type="text" style="font-family: Arial; font-size: 8pt; background-color: rgb(191,184,191); border: 1px solid rgb(0,0,0)" size="40">

<input name="txtemail" type="text" style="font-family: Arial; font-size: 8pt; background-color: rgb(191,184,191); border: 1px solid rgb(0,0,0)" size="40">

<input type="hidden" name="hidAcao" value="">

<input type="submit" value="enviar" name="botao" style="font-family: Arial; font-size: 10pt; border: 1px solid rgb(0,0,0)">

<input type="reset" name="Submit2" value="Limpar" style="font-family: Arial; font-size: 10pt; border: 1px solid rgb(0,0,0)">

</form>

______________________________________________________________

Bom, agradeço desde já...

VALEUUUUU

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Guest Guest

não sei se é o mesmo problema mais uma vez tive problema com essa lance de ficar pulando linha

eu tive se fazer assim

mensagem = "testo"

mensagem = & "testo"

algo assim tambem posso esta viajando...

Share this post


Link to post
Share on other sites
  • 0

hauhauhaha

Pode crer, em uns do "forms" um dos problemas era esse..

Valeu...

[ Podem fechar o tópico ]

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this