Jump to content
Fórum Script Brasil
  • 0
Sign in to follow this  
Sobrit

Conexão

Question

To com um problema de conexão, alguém me ajude.

já verifiquei e tentei outros modos mas não da certo, já tentei oas configurações do objeto OLE. Mas nada funciona.

alguém pode dizer se tem algo errado!

Esta é a minha conexão:

<%

DIM conCadLivro

DIM recLivro

DIM caminho = "cadlivro.MDB"

set conCadLivro = Server.CreateObject("ADODB.Connection")

set recLivro = Server.CreateObject("ADODB.Recordset")

conCadLivro.Open "driver={Microsoft Access Driver(*.mdb)};dbq=" & caminho

recLivro.Open "Livros",conCadLivro

Response.Write "Código:" & recLivro.Fields("codigo") & "<br>" & " Titulo do livro: " & recLivro.Fields("NomeLivro")

recLivro.Close

conCadLivro.Close

caminho.Close

%>

E ainda da um erro 0(80004005).

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Brother!!!

Veja se isto pode lhe ajudar:

<%
 Dim Conn, strConn, cBanco

 cBanco = Server.MapPath("cadlivro.MDB")
 Set Conn = Server.CreateObject("adodb.connection")
 strConn = "Provider = Microsoft.Jet.OLEDB.4.0; Data Souce = "&cBanco&";"
 Conn.Open(strConn) 
%>

Este código é apenas para abertura do seu banco de dados, como você mesmo mencionou no tópico, "problema de conexão".

Abraços!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



  • Forum Statistics

    • Total Topics
      148595
    • Total Posts
      644164
×
×
  • Create New...