• 0
Sign in to follow this  
Beraldo

Duas Ações Em Um Botão

Question

Fiz uma animação que, na última, cena, possui um botão que, ao clicar, vai para uma certa página e retorna ao início do arquivo.

No meu pc, funciona direitinho. Mas em alguns outros, só funciona a ação de retornar ao início do filme....

Costuma haver problemas ao se colocar mais de uma ação em um único botão?!

Ou pode ser a versão do Shockwave Flash de cada computador?

Valeu

Abraço

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

como q ehh a setrutara dessa action? po depender d como você coloco essas açoes coloca ai pra gnt ve...

Share this post


Link to post
Share on other sites
  • 0

Costuma haver problemas ao se colocar mais de uma ação em um único botão?!

Ou pode ser a versão do Shockwave Flash de cada computador?

você fala

on(release){

açao1();

açao2();

}

?

isto não da problema não, posta a action ae ^^

Share this post


Link to post
Share on other sites
  • 0

As ações são as seguintes:

on (release) {

getUrl ("http://www.desolatehope.com", "_blank");

gotoAndPlay ("inicio", 1);

}

No meu pc, tanto sem publicar na internet, quanto publicado, as duas ações funcionam perfeitamente.

Eu publiquei para fazer um teste onlaine tanto no meu pc quanto nos de alguns amigos meus, e alguns deles disseram que o botão só leva para o início da animação.

Se alguém souber o que pode estar dando errado e souber como solucionar, ajude-me!!

Valeu

Abraços!

Share this post


Link to post
Share on other sites
  • 0

Ae! Agora parece que deu certo!! =)

Obrigado!

Abraço

Só achei estranho o Get ser maiúsculo, pois o próprio Flash que gerou a ação getURL com "g" minúsculo....

Share this post


Link to post
Share on other sites
  • 0

hehe vai intende ^^

cada progrmama com sua locura xp

(aff forcei agora em tongue.gif )

t+

editado :

mais o 'g' é minusculo num é ...

o URL q tava errado acredito eu O.O"

Share this post


Link to post
Share on other sites
  • 0

Na verdade fui quem copiou o URL com letras minúsculas... o erro foi meu (não mexo muito com Action Scrip, sou iniciante na linguagem).

Mas com o "G" maiúsculo meus amigos disseram que funcionou perfeitamente no pc deles. Então está valendo! =)

Valeu!

Abraço!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this