• 0
Sign in to follow this  
Guest - JOAO -

Preloader

Question

Guest - JOAO -

estou usando o codigo de preloader no primeiro frame da camada de acoes

t=_root.getBytesTotal();

total=(t/1024);

total=Math.round(total);

c=_root.getBytesLoaded();

carregado=(c/1024);

carregado=Math.round(carregado);

porcentagem=Math.round((c/t)*100)+"%";

p=(c/t)*100;

_root.barra._xscale=p;

no segundo frame

if(carredo==total){

gotoAndPlay(3);

}

else{

gotoAndPlay(1);

}

em um outro layer tem a barra

e um tercero layer com o video , que esta inserido no terceiro frame.

a barra funciona mas o video não

alguém pode me ajudar

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

if(carredo==total){

gotoAndPlay(3);

}

else{

gotoAndPlay(1);

}

pode ser por causa disso não??? carrego, na verdade é carregado, e você tem de colocar seu video a partir do 3º frame da camada onde esta. porque os 1º e 2º frames são do carregador...

Share this post


Link to post
Share on other sites
  • 0
Guest - JOAO -

afff mano como eu num vi essa , e que to acustumado com C e la iria aavisar mas vlz falo :ph34r:

Share this post


Link to post
Share on other sites
  • 0
Guest - JOAO -

CERTINHO BROTHER FUNCIONO BELEZINHA

agora vo temta imcrementa um pouco como mask e outras coisas mais vlz

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this