Jump to content
Fórum Script Brasil
  • 0

Logica De Programação


edysnipes
 Share

Question

Tenho seguinte problema!

Ler um valor a e um valor N. Imprimir a soma dos n numeros a partir de A(inclusive). Caso N seja negarico ou ZERO, deverá ser lido um novo N (apenas)

Exemplo!

A N Soma

3 2 7 (3+4)

4 5 30 (4 + 5 + 6 + 7 + 8)

Isso eu já fiz! Mas a soma está dificil!

algoritmo "semnome"

// Função :

// Autor :

// Data : 28/10/2006

// Seção de Declarações

var

vet : vetor[0..10] de inteiro

a : inteiro

n : inteiro

i : inteiro

soma : inteiro

inicio

para i de 0 ate 10 faca

vet <- 0

fimpara

a <- 0

n <- 0

i <- 0

soma <- 0

escreval ("Digite o valor de A:")

leia(a)

escreval ("Digite o valor de N:")

leia (n)

se (n <= 0) então

escreval ("N não pode ser negativo nem igual a 0 ! Digite o valor de n novamente:")

leia (n)

fimse

// Seção de Comandos

fimalgoritmo

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Forum Statistics

    • Total Topics
      150.9k
    • Total Posts
      648.8k
×
×
  • Create New...